Results 1 to 4 of 4

Thread: Virtualbox cannot run VMs

  1. #1
    Join Date
    Nov 2009
    Beans
    3

    Question Virtualbox cannot run VMs

    I've been running several VMs on Virtualbox for years. An automatic update managed to break all of them. The version is DISTRIB_DESCRIPTION="Ubuntu 12.04.5 LTS". The upgrade event was recorded in /var/logs/dkms.log as: 2015-11-26 08:39:17 upgrade virtualbox 4.1.12-dfsg-2ubuntu0.10 4.1.44-dfsg-1+deb7u1ubuntu1. The VMs have been using VBoxGuestAdditions version is 4.1.12.

    From another Ubuntu 12.04.5 LTS system I tried to install virtualbox using Synaptic Package Manager. It gave me virtualbox 4.1.12 but when I selected it, an error occurred that the server did not have that available.

    My questions are:
    1. How to make my VMs function again.
    2. Should I upgrade Virtualbox and the VMs to some newer version like 5.0?

    Thanks,
    Charles

  2. #2
    Join Date
    Nov 2009
    Beans
    3

    Re: Virtualbox cannot run VMs

    The error message given is:
    RTR3Init failed with rc=-1912 (rc=-1912)The VirtualBox kernel modules do not match this version of VirtualBox. The installation of
    VirtualBox was apparently not successful. Executing '/etc/init.d/vboxdrv setup'may correct this. Make sure that you do not mix the OSE
    version and the PUEL version of VirtualBox.

    where: supR3HardenedMainInitRuntime
    what: 4
    VERR_VM_DRIVER_VERSION_MISMATCH (-1912) - The installed support driver doesn't match the version of the user.

  3. #3
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    13,497
    Distro
    Kubuntu 18.04 Bionic Beaver

    Re: Virtualbox cannot run VMs

    Try following the error message by running
    Code:
    sudo /etc/init.d/vboxdrv setup
    The problem is that portions of the Linux kernel need to be recompiled to use the new VirtualBox "module." If that command doesn't work, try running
    Code:
    sudo apt-get install dkms
    then try the first command again.

    Personally I use the Oracle repositories as described here: https://www.virtualbox.org/wiki/Linu...xdistributions. They keep up-to-date with new releases and install flawlessly.

    You would need to remove the Ubuntu version first with
    Code:
    sudo apt-get remove --purge virtualbox virtualbox*
    If you ask for help, do not abandon your request. Please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

  4. #4
    Join Date
    Nov 2009
    Beans
    3

    Smile Re: Virtualbox cannot run VMs

    Thank you! This worked perfectly. When I installed the new upgrade it asked for an upgrade to the extension pack as well so it guided me through.
    Thanks, SeijiSensi-san.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •