Page 1 of 33 12311 ... LastLast
Results 1 to 10 of 386

Thread: Re: Ubuntu on Dell Xps 15 9550 new Infinity display (i7 6gen 16gbr UHD 4k touch

Hybrid View

  1. #1

    Re: Ubuntu on Dell Xps 15 9550 new Infinity display (i7 6gen 16gbr UHD 4k touch

    Have anyone tried to install ubuntu on the last Dell xps 15 machine?

    I'm pondering to buy it but I'm not expert enough to be a pioneer

    Please help.


    THANKS for your effort. I find it strange apparently the previous xps15 is exactly the model shown on the ubuntu website... it looks like it
    Last edited by howefield; November 11th, 2015 at 12:56 PM.

  2. #2
    Join Date
    Jun 2009

    Re: Ubuntu 15.10 on Dell Xps 15 9550 new Infinity display (i7 6gen 16gbr UHD 4k touch

    Haven't heard of anyone else doing this so I took the risk and purchased the Dell XPS 15 (9550) with the FHD 1920x1080 matt display, Intel Skylake i7-6700HQ, 512GB PCIe SSD, 16GB DDR4, 84Wh battery. My experience is that usually Dell's have pretty good Ubuntu support, though Optimus can be a pain. The summary is that it does NOT automatically work with Ubuntu 15.10. Some tweaking is necessary but not too bad. Here are my experiences and instructions to get it to work with a UEFI install.

    0) Might not be necessary but did the following:

    BIOS > Secure Boot > Disabled

    1) The PCIe hard drive won't be recognized by live Ubuntu 15.10 by default. Change RAID to AHCI. When it works it will appear as /dev/nvme0n1.

    BIOS>System Configuration>SATA Operation> switch RAID to AHCI

    2) Random freezes will happen with the live Ubuntu 15.10. Symptoms are random freezes and infinite errors, something like the following: nouveau PFIFO SCHED_ERROR. Fix by pressing 'e' on grub menu during boot and add "nouveau.modeset=0" to the end of the line starting with "linux". Now boot live disk by pressing F10.

    3) Touchpad might not work. For some reason it worked for me the first time and then never again. Easiest is to use a USB mouse temporarily. There's a fix for after install is finished.

    4) Install should now work smoothly.

    5) Reboot. Dell SupportAssist reports a failing component. "Error Code 2000-0151, Validation 106575, Hard Drive 1 incorrect status = 8000000000000003". Ignore this. Go into bios and setup the correct boot option.

    There might be an automatically provided option to select under boot options. Otherwise manually set it up. BIOS>General>Boot Sequence > Add Boot Option > ubuntu > shimx64.efi (\EFI\ubuntu\shimx64.efi)

    6) Try booting, but make sure you press SHIFT repeatedly during boot to get to grub menu. Repeat step (2) above.

    7) On first successful boot edit /etc/default/grub, GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nouveau.modeset=0". Then run "sudo update-grub". Now won't need to manually change grub settings on every boot.

    8) Fix touchpad problem. Apparently the wrong kernel module (driver) is loaded. It's loading i2c_hid instead of i2c_designware_*.

    lsmod | grep i2c #check what's loaded
    echo "blacklist i2c_hid" | sudo tee -a /etc/modprobe.d/blacklist.conf
    #apparently just blacklisting isn't good enough, for me it was also hiding in initramfs
    sudo depmod -a
    sudo update-initramfs -u

    9) Graphics will be weird and flaky. The Nvidia drivers in the standard repositories are also a bit too old and will be flaky. I found that the new graphics-driver PPA worked well. Didn't try downloading from Nvidia directly. Bumblebee didn't work for me, giving a black screen, so Nvidia PRIME is recommended.

    sudo apt-get purge nvida-*
    sudo add-apt-repository ppa:graphics-drivers/ppa
    sudo apt-get update
    sudo apt-get install nvidia-355 nvidia-prime
    sudo service lightdm restart

    10) Add an indicator so you can tell whether Intel or Nvidia is being used.

    sudo add-apt-repository ppa:nilarimogard/webupd8
    sudo apt-get update
    sudo apt-get install prime-indicator

    Tested and working:

    - webcam works seemlessly, good color and resolution, but HORRIBLE un-useable placement at bottom of screen
    - Cheese and Skype worked with webcam, Google Chrome PPA with Google Hangeouts didn't work
    - speakers are a big step up from my Lenovo T430s

    Remaining weird behavior not solved yet:

    - HDMI output not always detected with Intel or Nvidia, hopefully small bug that will be fixed soon (VGA dongle working fine)
    - laptop mic not detected by system, my headphone mic doesn't work either, probably a minor Ubuntu 15.10 bug and not a laptop driver issue
    ---- seems to work with Kernel v4.3
    - bluetooth doesn't detect my external speaker, driver bug that should be fixed soon, I think it's related to this:
    - suspend/resume results in black screen
    ---- @parallelo fixed by installing kernel v4.3
    - occasionally touchpad cursor jumps down/left because of using thumb for left-clicks, this shouldn't happen, probably some manual tweaks can fix this
    - slow touchpad acceleration, system settings insufficient, need some manual tweaks
    - login screen hangs until wifi connects
    - both Intel and Nvidia are tearing, system is useable though, hopefully will improve over time with driver updates
    - Sometimes switching graphics with 'nvidia-settings' doesn't work. Sometimes 'nvidia-select' works. My guess is that there is a minor Nvidia bug that will soon be fixed
    - boot takes a long time, 20 seconds (old Lenovo 430s only took 10 seconds), i think this is just the slow Dell post

    Otherwise the system seems to be woraking well. No crashing/freezing issues which is great. Hopefully this guide will save others a few hours (or days!) of pain. Please post your improvements/updates to this procedure to help us all out!
    Last edited by jchedstrom; November 11th, 2015 at 05:43 AM.

  3. #3
    Join Date
    Nov 2015

    Re: Ubuntu 15.10 on Dell Xps 15 9550 new Infinity display (i7 6gen 16gbr UHD 4k touch

    @jchedstrom - registered just to thank you This is exactly what I was looking for before deciding if I should buy that machine - exactly the configuration I'd go with too. Thank you for going through the work to figure things out - should be a real time saver.

    If it's not too much trouble, do you have any information on battery life, and does the laptop seem to run cool and quiet enough in Linux? I used to have a dual-graphics laptop before that ran cool in Windows, but would burn up in Linux no matter what power/processor/video settings I tried, but that those were AMD cards.

  4. #4
    Join Date
    Jul 2009

    Re: Ubuntu 15.10 on Dell Xps 15 9550 new Infinity display (i7 6gen 16gbr UHD 4k touch

    Many thanks jchedstrom. I'm still undecided. I currently have the Dell M3800 and can install Linux in around 30 minutes without any problems. I'm still leaning toward this XPS 9550 as I haven't seen any other Skylake laptops out there that are viable options.

  5. #5
    Join Date
    Jun 2010

    Re: Ubuntu 15.10 on Dell Xps 15 9550 new Infinity display (i7 6gen 16gbr UHD 4k touch

    Thanks for the fantastic info jchedstrom. It is really helpful. I am also still undecided. Did you try to connect the laptop to an external monitor / projector?

    Edit: BTW, did you have any problems with the wifi card?
    Last edited by astroman3001gt; November 2nd, 2015 at 12:18 PM.

  6. #6
    Join Date
    May 2010

    Re: Ubuntu 15.10 on Dell Xps 15 9550 new Infinity display (i7 6gen 16gbr UHD 4k touch

    I've been having a terrible time trying to get Dual Boot up and running. What I've done so far:

    1. Reinstalled Windows 10 using an OEM disk and resized partitions
    2. Set SATA mode to ACHI
    3. Turned off SecureBoot (but kept UEFI mode)
    4. Started the install of Xubuntu with nomodeset option
    5. sudo gparted /dev/nvme0n1 my partitions for custom /, /home, /var, etc (had to use GParted because the install would freeze when trying to format /home)
    6. Finally clicked install and it's stuck on "Saving installed packages..."

    Did you have to do anything special? How long did the install take? I'm waiting on 25 minutes and it's still just chilling. Running a separate terminal and nothing is really running in top...

    It looks like a lot of this is related to

    I did NOT mount a separate /var directory and I was able to move on. Just as an FYI, I had to set the Install Bootloader path to /dev/nvme0n1 since there's a known bug about the Ubuntu install not selecting the correct partition.
    Last edited by l1fe; November 2nd, 2015 at 05:38 PM.

  7. #7
    Join Date
    Sep 2008

    Re: Ubuntu 15.10 on Dell Xps 15 9550 new Infinity display (i7 6gen 16gbr UHD 4k touch

    Hi @jchedstrom

    Thanks for nice guide. I'm facing 2 problems right now.
    - Suspend doesn't work
    - If I reboot the computer the BIOS doesn't detect the SSD drive. Only If I do full power-off and power-on the SSD got detected

    Did you experience similar problems?

  8. #8
    Join Date
    Nov 2015

    Re: Ubuntu 15.10 on Dell Xps 15 9550 new Infinity display (i7 6gen 16gbr UHD 4k touch

    @jchedstrom and friends - Thanks to all for the very useful tips. Much appreciated!

    After going through those steps in a UEFI dual-boot setup, I'm hitting a couple issues. The main one is this:

    After the install, Ubuntu booted perfectly, once. But, every successive boot has given the "Dell SupportAssist Error Code: 2000-0151" that you mentioned in your post. I'm not able to ignore this error because it forces an immediate reboot after pressing "Continue." So, I have not been able to get back into Ubuntu.

    • Any idea what causes this?
    • Did it only happen to you once?
    • How did you get around it?

    Thanks again!

  9. #9
    Join Date
    Nov 2015

    Re: Ubuntu 15.10 on Dell Xps 15 9550 new Infinity display (i7 6gen 16gbr UHD 4k touch

    Just a quick update.. My guess is that the Dell error message simply means is that it couldn't find the .efi path that was specified in the BIOS. I just took another look and I can no longer find any \EFI\ubuntu\shimx64.efi. Still investigating...

  10. #10
    Join Date
    Nov 2015

    Re: Ubuntu 15.10 on Dell Xps 15 9550 new Infinity display (i7 6gen 16gbr UHD 4k touch

    Just wanted to thank @jchedstrom again for the really useful tips! Well done!

    I had to use boot-repair to get a functioning system, but now I'm writing this post from a Ubuntu 15.10 partition on a new XPS 15

Page 1 of 33 12311 ... LastLast

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts