Page 29 of 39 FirstFirst ... 192728293031 ... LastLast
Results 281 to 290 of 386

Thread: Re: Ubuntu on Dell Xps 15 9550 new Infinity display (i7 6gen 16gbr UHD 4k touch

  1. #281
    Join Date
    Dec 2015
    Beans
    9

    Re: Ubuntu 15.10 on Dell Xps 15 9550 new Infinity display (i7 6gen 16gbr UHD 4k touch

    @quickdry21, @william104 thanks for sharing your experience and status with Ubuntu Gnome 16.04 beta!!

    I'm waiting an "almost-stable" release of Ubuntu Gnome 16.04 and install it on my xps 15. It seems is going already better than the previous release!

  2. #282
    Join Date
    Mar 2016
    Beans
    5

    Re: Ubuntu 15.10 on Dell Xps 15 9550 new Infinity display (i7 6gen 16gbr UHD 4k touch

    Has anyone got suspend working properly? If so what steps are required? I'm on 15.10 and trying to resume from suspend I just get a lit power button but black screen and nothing responds (e.g. cannot toggle keyboard backlight). I have to hold the power button until the machine powers down and then do a normal power on. I've tried upgrading kernel to 4.3.4 but that hasn't helped

  3. #283
    Join Date
    Mar 2016
    Beans
    2

    Re: Ubuntu 15.10 on Dell Xps 15 9550 new Infinity display (i7 6gen 16gbr UHD 4k touch

    Hey guys,

    Thanks for the installation guide for this but I decided to install Ubuntu Mate 16.04 beta on my Dell XPS 15 (i7, 512gb SSD, GTX960m + Intel 530, 16gb RAM) and it is running smooth and no problems since then. Here's what I did:

    1.) Download and Prepare USB for Ubuntu Mate 16.04 under Windows.
    2.) Backup Windows, Just in case I screw up
    3.) Flashed the latest BIOS off Dell Website then after install I restored to BIOS Default then change the following:
    - ACHI Mode
    - Secure Boot OFF
    4.) Boot up the USB Live Preview ***No need to edit anything. Just hit Enter on GRUB
    5.) Whats working so far on Live USB?
    - Wifi
    - Bluetooth
    - Touchpad and Keyboard
    6.) Connect to internet via Wifi or USB-Ethernet
    7.) Start installation
    - I deleted my whole partition and created a new one like this:
    - EFI = 200MB
    - SWAP = 16GB (End of Partition)
    - System Drive = 50GB (mount point: /)
    - Home Drive = The rest of GBs (mount point: /home)
    8.) Point the bootloader on /nvme
    9.) Install as normal
    10.) Reboot
    11.) Install Nvidia using PPA (I used 358 because I had problems with 361 when running Steam) ***Don't reboot yet
    - I only installed nvidia-358 and nvidia-prime (prime-indicator doesnt work for me for some reason but its not a big deal for me)
    12.) Download Intel Graphics Linux (just google it and download the one for 64bit 15.10 version) and install it. ***Don't reboot yet
    13.) Trick the installer that you are running 15.10 by typing this command in the terminal:
    Code:
    sudo cp /etc/lsb-release /etc/lsb-release.backup
    sudo nano /etc/lsb-release
    - Edit the line where it says 16.04 to 15.10
    - Edit the line where it says xenial to wily
    - CTRL+X, CTRL+Y, Enter
    12.) Now run the Driver Installer for Intel Graphics ***Don't reboot yet
    13.) Copy the original lsb-release by:

    Code:
    sudo cp /etc/lsb-release.backup /etc/lsb-release
    14.) Restart
    15.) Enjoy a stable system, well I think it is.

    Let me know below if you have any issues and lets figure it out together.

    PS. Sorry if I am putting 16.04 installation into a 15.10 Installation Post.


    What's working:
    - Wifi
    - Bluetooth
    - Trackpad (need to tweak somehow to recognise palm when typing haha pretty sensitive)
    - Suspend/Sleep, Reboot, Shutdown
    - NVIDIA 960m and Intel 530 with HDMI either graphics works
    - Sound

    What's Annoying?
    - Ubuntu Mate doesnt support HiDPi yet (or I just don't know how to), my default resolution is 1920x1080 still looks great
    - prime-indicator (success on installation but everytime I select either NVIDIA or INTEL it doesn't log out automatically)


    What do I have installed at the moment?
    - Steam
    - DOTA 2
    - League of Legends via Play on Linux
    - CS:GO
    - MATLAB
    - VirtualBox (Running Windows 7 - with more DEV Tools installed)
    Last edited by Rommel_Lapuz; March 6th, 2016 at 12:29 PM.

  4. #284
    Join Date
    Aug 2009
    Beans
    46

    Re: Ubuntu 15.10 on Dell Xps 15 9550 new Infinity display (i7 6gen 16gbr UHD 4k touch

    I'm trying out Ubuntu 16.04 (daily build of feb 29) on my XPS 15/FHD, and am able to finally get some good energy consumption with intel graphics active. It's on a par with Window now.

    I installed to a separate partition, pointed bootloader installation to EFI partition, and 16.04 gets added to grub as a boot option.

    I set brightness to about 20%, and after optimizing power usage by running
    Code:
    $ sudo powertop --auto-tune
    $ sudo powertop
    And letting it idle for a minute, the consumption is about 6,5W (screen on, wifi on, BT on). On 15.10 I get around 15-18W with intel, and around 9-10W with nvidia in this case. There's a small glitch: the laptop display flashes every now and then (irregularly, about once every 20 sec).

    Disabling wifi and BT drops it further from 6.5W to slightlly over 5W. When doing light work (such as typing this post, consumption goes up to 8-9W.

    Can't get nvidia/prime to work properly yet (after logging in screen flashes black, then returns to login prompt. I have the same issue with 15.10 nonwadays, It used to work for me with different kernels/nvidia versions, not sure what changed.

    Anyway, definitely an improvement in power consumption with 16.04 compared to 15.10, good news for owners like myself with a modest 56Wh battery...

    Code:
    $ uname -a
    Linux xtest-XPS-15-9550 4.4.0-9-generic #24-Ubuntu SMP Mon Feb 29 19:33:19 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

  5. #285
    Join Date
    Feb 2016
    Beans
    11

    Re: Ubuntu 15.10 on Dell Xps 15 9550 new Infinity display (i7 6gen 16gbr UHD 4k touch

    Quote Originally Posted by bertusrex View Post
    I'm trying out Ubuntu 16.04 (daily build of feb 29) on my XPS 15/FHD, and am able to finally get some good energy consumption with intel graphics active. It's on a par with Window now.

    I installed to a separate partition, pointed bootloader installation to EFI partition, and 16.04 gets added to grub as a boot option.

    I set brightness to about 20%, and after optimizing power usage by running
    Code:
    $ sudo powertop --auto-tune
    $ sudo powertop
    And letting it idle for a minute, the consumption is about 6,5W (screen on, wifi on, BT on). On 15.10 I get around 15-18W with intel, and around 9-10W with nvidia in this case. There's a small glitch: the laptop display flashes every now and then (irregularly, about once every 20 sec).

    Disabling wifi and BT drops it further from 6.5W to slightlly over 5W. When doing light work (such as typing this post, consumption goes up to 8-9W.

    Can't get nvidia/prime to work properly yet (after logging in screen flashes black, then returns to login prompt. I have the same issue with 15.10 nonwadays, It used to work for me with different kernels/nvidia versions, not sure what changed.

    Anyway, definitely an improvement in power consumption with 16.04 compared to 15.10, good news for owners like myself with a modest 56Wh battery...

    Code:
    $ uname -a
    Linux xtest-XPS-15-9550 4.4.0-9-generic #24-Ubuntu SMP Mon Feb 29 19:33:19 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
    Hmm I tried 16.04 and it seems I downloaded the wrong version..it was in Chinese :/

    Anyway, glad to hear that 16.04 gives you better battery life. I may try it out myself now. On 15.10 I only got about 3+ hours of use with intel graphics, nvidia 358 drivers, using prime and 4.4 kernel. I also installed tlp and it did not seem to make a difference. I don't know why on windows I can get 7+ hours on the 56w battery but in Ubuntu it was nothing close.

  6. #286
    Join Date
    Feb 2008
    Beans
    30

    Re: Ubuntu 15.10 on Dell Xps 15 9550 new Infinity display (i7 6gen 16gbr UHD 4k touch

    Quote Originally Posted by Rob_Stevenson View Post
    Has anyone got suspend working properly? If so what steps are required? I'm on 15.10 and trying to resume from suspend I just get a lit power button but black screen and nothing responds (e.g. cannot toggle keyboard backlight). I have to hold the power button until the machine powers down and then do a normal power on. I've tried upgrading kernel to 4.3.4 but that hasn't helped
    It works for me, but only with intel or nouveau video drivers... nvidia and I haven't gotten along - not only has suspend/resume not work under nvidia, half the time my screensaver kicks in and I come back, I've got a black screen with no keyboard response (machine still running but I can't even switch to a text console to kill my session though).

    The intel driver has gotten much more stable, now if only I can get it to place nice with nvidia (I seem to be able to do 3 screens in nvidia vs 2 on intel). I've actually been able to play Pillars of Eternity at 1080p ok with the Intel driver now, so I've just been doing that for the time being.

  7. #287
    Join Date
    Feb 2008
    Beans
    30

    Re: Ubuntu 15.10 on Dell Xps 15 9550 new Infinity display (i7 6gen 16gbr UHD 4k touch

    Quote Originally Posted by sze5003 View Post
    Hmm I tried 16.04 and it seems I downloaded the wrong version..it was in Chinese :/

    Anyway, glad to hear that 16.04 gives you better battery life. I may try it out myself now. On 15.10 I only got about 3+ hours of use with intel graphics, nvidia 358 drivers, using prime and 4.4 kernel. I also installed tlp and it did not seem to make a difference. I don't know why on windows I can get 7+ hours on the 56w battery but in Ubuntu it was nothing close.
    haha I did the same, make sure it's the GNOME, Xfce, or MATE edition not kylin (That's the chinese one). It seems to boot up and run fine enough, it looks like a fresh install will be much easier and cleaner than 15.10. I didn't think to try bluetooth on it.

  8. #288
    Join Date
    Mar 2016
    Beans
    2

    Re: Ubuntu 15.10 on Dell Xps 15 9550 new Infinity display (i7 6gen 16gbr UHD 4k touch

    Quote Originally Posted by Cowlike View Post
    I just installed Xubuntu 16.04 beta1. Two issues:

    1. Reverse scroll doesn't work consistently. Very annoying. It works in Firefox, but not in Google Chrome or Terminator (in various settings windows).

    2. Laptop seems to run warm. The fans are consistently on. I used to run Xubuntu 15.10 on the XPS 13, and it was silent most of the time.

    Anyone come across these issues? Any suggested fixes?
    Just to follow-up on my issues:

    1. By chance, v49 and v50 of Chrome just happen to have a bug where reverse scroll doesn't work. See here.

    2. Mostly solved by upgrading to 16.04. As reported by bertusrex in #287, I see power usage of ~5.5W with BT off, screen at 20%. Much, much better than on 15.10, where I saw > 15W idle.


    A couple of new issues:

    3. Intel drivers cause flickering (rapidly varying brightness, like an old CRT with low refresh rate) at the very lowest brightness setting. This does not occur when using NVIDIA (although that bumps idle power to ~7.5W). (I'm on latest drivers per Rommel_Lapuz in #283.)

    4. Intel drivers also seem to cause "blinking" (screen going completely black for a fraction of a second; happens randomly in bursts of three or four times over a few seconds) after waking from suspend. Don't see this on NVIDIA either.

    5. Touchpad gestures: can't get touchegg to recognize three-finger gestures. It recognizes two fingers fine after disabling synclient for two fingers (although scroll speed is far too high), but can't get three fingers working. Worked just fine on my XPS 13.

    6. Under both Intel and NVIDIA, VLC videos are "on top" of all other windows and UI elements, and generally cause tearing or freezing when moving or resizing.

    Overall, looking very good. Video drivers need a bit more work though.

  9. #289
    Join Date
    Feb 2016
    Beans
    11

    Re: Ubuntu 15.10 on Dell Xps 15 9550 new Infinity display (i7 6gen 16gbr UHD 4k touch

    Quote Originally Posted by rvanderwerf View Post
    haha I did the same, make sure it's the GNOME, Xfce, or MATE edition not kylin (That's the chinese one). It seems to boot up and run fine enough, it looks like a fresh install will be much easier and cleaner than 15.10. I didn't think to try bluetooth on it.
    Yea I am trying the Mate version now. Going to see how my battery life turns out with this one. I would very much like to run Arch but I can't seem to get it to work when it comes to installing a desktop environment.

  10. #290
    Join Date
    Mar 2016
    Beans
    2

    Re: Ubuntu 15.10 on Dell Xps 15 9550 new Infinity display (i7 6gen 16gbr UHD 4k touch

    Quote Originally Posted by rvanderwerf View Post
    I think this bit me today for some reason. I upgraded to 32gb of ram which shouldn't matter at all but I couldn't log in anymore. I removed the intel and all nvidia, went back to nouveau, the re-installed intel and I'm back. I am about to add nvidia back into the mix. Is 361 the driver to run right now?


    update I re installed nvidia 352 drivers, and everything is hosed again. It seems latest intel drivers are not playing nice with the nvidia ones. If I just install the intel drivers, everything comes back to life (had to force purge all the nvidia* and reinstall ubuntu-desktop) to get everything back.

    Anyone here running 2 4k screens. I recently got a dell 4k 27" I'm using via usb-c-> displayport adapter because the panel can't do 60hz via hdmi. Is there a usb-c to dual DP that works in linux?

    I tried my laptop 4k screen + usb-c 4k screen + u2412m at 1920x1200 and intel drivers completely crash. Before latest update nvidia would work, but system would freeze when coming back from a screen timeout.
    Just had the same issue; intel-graphics (1.4.0) really doesn't play along with nvidia (both 358 and 361). I have now purged both drivers (working with the basic - nouveau), planning to go nvidia-only, but Unity is now lacking its dash and most of its features. I've reinstalled ubuntu-desktop and unity, but that didn't seem to work. Am I missing something? Any suggestions?

Page 29 of 39 FirstFirst ... 192728293031 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •