Page 12 of 39 FirstFirst ... 2101112131422 ... LastLast
Results 111 to 120 of 386

Thread: Re: Ubuntu on Dell Xps 15 9550 new Infinity display (i7 6gen 16gbr UHD 4k touch

  1. #111
    Join Date
    Feb 2010
    Beans
    24

    Re: Ubuntu 15.10 on Dell Xps 15 9550 new Infinity display (i7 6gen 16gbr UHD 4k touch

    In the process of trying out intel-drm-nightly 997 and still no HDMI - at least this time I'm getting new errors: *ERROR* 5.4 Gbps link rate without HBR2/TPS3 support. Screen flickers a bunch when plugging in HDMI then nothing, tried nvidia-352 and nvidia-358, no difference.

    Starting to give up hope on HDMI. I have a USB-C to DisplayPort cable in the mail right now, I'm hoping it will support DP 1.2 MST so I can use both of my external monitors, but at this point I would be happy to just get one going :/

  2. #112
    Join Date
    May 2007
    Beans
    126

    Re: Ubuntu 15.10 on Dell Xps 15 9550 new Infinity display (i7 6gen 16gbr UHD 4k touch

    Quote Originally Posted by quickdry21 View Post
    Starting to give up hope on HDMI. I have a USB-C to DisplayPort cable in the mail right now, I'm hoping it will support DP 1.2 MST so I can use both of my external monitors, but at this point I would be happy to just get one going :/
    I was told that USB-C to HDMI and Display port cables are not well supported by Linux in general, which product did you buy?

  3. #113
    Join Date
    Feb 2010
    Beans
    24

    Re: Ubuntu 15.10 on Dell Xps 15 9550 new Infinity display (i7 6gen 16gbr UHD 4k touc

    Quote Originally Posted by kjano View Post
    I was told that USB-C to HDMI and Display port cables are not well supported by Linux in general, which product did you buy?
    http://www.monoprice.com/product?p_id=12908

    Starting to worry this is HW related, can't switch to Intel graphics, HDMI refuses to work.
    Last edited by howefield; December 7th, 2015 at 11:06 AM.

  4. #114
    Join Date
    Dec 2015
    Beans
    4

    Re: Ubuntu 15.10 on Dell Xps 15 9550 new Infinity display (i7 6gen 16gbr UHD 4k touch

    Thought I would share my experience with this machine (4K display) and Kubuntu 15.10

    I followed jchedstrom instructions and everything worked fine. No problems with wireless or nvidia-355. I found that bumblebee did not work and had to boot into 'init 3' to fix that. The prime-select tool however worked very well. Of note, after install the system defaulted to running the nvidia drivers and battery life reported at 2 hours. When I switched to the intel drivers, battery life went up to 6 hours and the machine was very much cooler.

    Had some intermittent problem with the the graphics where the screen would get unstable (garbage appearing at top of screen). After a couple of reboots, this seems to have gone away. However, when using the intel drivers it was not possible to watch a video on full-screen; the frame rate drops to about 0.2fps and it looks more like a slideshow than a video. Works totally fine at smaller resolutions.

    Have not found a good solution for the DPI issues other than changing all the default font selections I can find. The tool bar at the bottom of the screen is incredibly small, but sharp as hell.

    Biggest issue was that the keyboard started acting weird. I would type a few characters and it would then puke out a whole bunch of garbage including non-printable characters. Thought at first this was a linux problem but it persisted even when running Windows 10. USB keyboard works fine. I note all the problems the XPS13 has had with keyboards and wonder if this is related. Contacted Dell Support and after diagnosing remotely they concluded the keyboard was bad. Certainly not a good thing on a three-day old $2K machine. They are sending another keyboard. If you are having keyboard issues, definitely check it with USB and bang Dell if that works.

    Will report more after keyboard is replaced.

  5. #115
    Join Date
    May 2007
    Beans
    126

    Re: Ubuntu 15.10 on Dell Xps 15 9550 new Infinity display (i7 6gen 16gbr UHD 4k touc

    Quote Originally Posted by quickdry21 View Post
    [...]can't switch to Intel graphics.
    And you are using prime to do so, right?

  6. #116
    Join Date
    Feb 2010
    Beans
    24

    Re: Ubuntu 15.10 on Dell Xps 15 9550 new Infinity display (i7 6gen 16gbr UHD 4k touc

    Quote Originally Posted by kjano View Post
    And you are using prime to do so, right?
    I tried using prime-indicator as well as NVIDIA settings. Both times I would get to the login screen, and attempts to login failed (brought me right back).

  7. #117
    Join Date
    Dec 2015
    Beans
    6

    Re: Ubuntu 15.10 on Dell Xps 15 9550 new Infinity display (i7 6gen 16gbr UHD 4k touch

    Quote Originally Posted by satcom66 View Post
    I found that bumblebee did not work and had to boot into 'init 3' to fix that.
    Can you elaborate on what you did in that runlevel to help with Bumblebee?

  8. #118
    Join Date
    Dec 2015
    Beans
    4

    Re: Ubuntu 15.10 on Dell Xps 15 9550 new Infinity display (i7 6gen 16gbr UHD 4k touch

    When I installed bumblebee and rebooted I got no graphics in init 5, so I rebooted and forced it to init 3. Once there I removed the bumblebee package and undid the blacklists. Then, rebooted to init 5 and graphics worked fine again. nvidea-prime seems to work just fine although the indicator is so small on my screen I can't see what it is doing.

  9. #119
    Join Date
    Dec 2015
    Beans
    9

    Re: Ubuntu 15.10 on Dell Xps 15 9550 new Infinity display (i7 6gen 16gbr UHD 4k touch

    Hello,

    firstly, thank you all for the very useful discussion and tips.

    I'll hopefully get my Dell XP 15 on January 6th, meanwhile I am following this discussion.

    Anyone will try to install Ubuntu 16.04 Alpha 1 (gnome or other) in the next month? I was wondering if we could get less issues with the new release.

  10. #120
    Join Date
    Dec 2015
    Beans
    4

    Re: Ubuntu 15.10 on Dell Xps 15 9550 new Infinity display (i7 6gen 16gbr UHD 4k touch

    Just tried daily build of 16.04 and it didn't work for beans. Black screen without 'nomodeset' argument; with the argument it gets a little further then starts compiaining it can't load i915. Shortly after that the screen starts flashing. All in all, not ready for prime time.

Page 12 of 39 FirstFirst ... 2101112131422 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •