Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Glitch with gnome-terminal

  1. #1
    Join Date
    Oct 2008
    Location
    ExodusHair<Čubura
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Glitch with gnome-terminal

    Code:
    :~$ gnome-terminal(process:2585): Gtk-WARNING **: Locale not supported by C library.
        Using the fallback 'C' locale.
    Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0: Error calling StartServiceByName for org.gnome.Terminal: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.gnome.Terminal exited with status 8
    Yes, local characterters (OK in other apps) are gone from terminal emulation (gnome-terminal (does not open as described above), xterm and guake (that do open and, aside absence of local characters, work OK)...)...
    Update1: While doing upgrade:
    Code:
    perl: warning: Setting locale failed.perl: warning: Please check that your locale settings:
        LANGUAGE = "en_US",
        LC_ALL = (unset),
        LC_TIME = "sr_RS",
        LC_MONETARY = "sr_RS",
        LC_ADDRESS = "sr_RS",
        LC_TELEPHONE = "sr_RS",
        LC_NAME = "sr_RS",
        LC_MEASUREMENT = "sr_RS",
        LC_IDENTIFICATION = "sr_RS",
        LC_NUMERIC = "sr_RS",
        LC_PAPER = "sr_RS",
        LANG = "en_US.UTF-8"
        are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    Update2: It seems that reinstall of locales is enough but (after some trials and errors) I can not promise that that is enough. But I do firmly think it is.

    Since there was no traffic in this thread moderators could, if they find it appropriate, remove this thread=message „of mine“...
    Last edited by zika; September 19th, 2015 at 08:07 PM.

  2. #2

    Re: Glitch with gnome-terminal

    purging the locales fix it for me.

    locale-gen --purge

  3. #3
    Join Date
    Oct 2008
    Location
    ExodusHair<Čubura
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Glitch with gnome-terminal

    Quote Originally Posted by tvboxspy View Post
    purging the locales fix it for me.
    locale-gen --purge
    That hammer was not big enough at my place...

  4. #4
    Join Date
    Oct 2009
    Beans
    560
    Distro
    Ubuntu Development Release

    Re: Glitch with gnome-terminal

    Have the same problem.

    In my case
    reinstall of locales didn't work.
    locale-gen --purge didn't work.

    For now I'm using LXTerminal

  5. #5
    Join Date
    Jun 2006
    Location
    Nux Jam
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Glitch with gnome-terminal

    i suppose you have libc6 2.22 installed : https://bugs.launchpad.net/ubuntu/+s...c/+bug/1497473

  6. #6
    Join Date
    Oct 2009
    Beans
    560
    Distro
    Ubuntu Development Release

    Re: Glitch with gnome-terminal

    Yes it's installed.
    I activated proposed some day back to enable installation of Kodi on Wily. USC is also broken on this system.

  7. #7
    Join Date
    Sep 2009
    Beans
    7

    Re: Glitch with gnome-terminal

    running locale-gen under my user account had no impact, but running as root worked for me !

    sudo locale-gen --purge

    Thanks

  8. #8

    Re: Glitch with gnome-terminal

    My exact log entries under sudo bash.

    locale-gen --purge
    dpkg-reconfigure locales

    gnome-terminal

    and reboot

  9. #9
    Join Date
    Oct 2009
    Beans
    560
    Distro
    Ubuntu Development Release

    Re: Glitch with gnome-terminal

    Thanks,
    sudo locale-gen --purge worked

  10. #10

    Re: Glitch with gnome-terminal

    Also the language selector doesn't appear to be fully installed. However, its doesn't prompt you for your password to make the changes.

    sudo gnome-language-selector

    in terminal to install it properly.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •