Results 1 to 3 of 3

Thread: Can't set Static IP Address on Beaglebone Black

  1. #1
    Join Date
    Aug 2010
    Beans
    73

    Can't set Static IP Address on Beaglebone Black

    All,
    I've tried changing dhcp to static in the "interfaces" file from dhcp to static as follows:

    Code:
    iface eth0 inet static     
    address 10.168.1.2     
    netmask 255.255.255.0     
    gateway 10.168.1.1
    However, after I reboot then original dhcp addresses stay configured. Are they other files that need to change?

    Your help is appreciated.

  2. #2
    Join Date
    Jul 2005
    Location
    I think I'm here! Maybe?
    Beans
    Hidden!

    Re: Can't set Static IP Address on Beaglebone Black

    DISTRO: Xubuntu 16.04-64bit --- Code-tags --- Boot-Repair --- Grub2 wiki & Grub2 Basics --- RootSudo --- Wireless-Info --- SolvedThreads

  3. #3
    Join Date
    Aug 2010
    Beans
    73

    Re: Can't set Static IP Address on Beaglebone Black

    In case some has the same issue here's the solution: Look at "am335x_evm.sh"

    I think I found the issue with the BeagleBone Black network configuration here: http://bugs.elinux.org/issues/91
    The fix is:
    Disable these 3 lines:
    /etc/init.d/udhcpd restart
    /sbin/ifconfig usb0 192.168.7.2 netmask 255.255.255.252
    /usr/sbin/udhcpd -S /etc/udhcpd.conf
    and comment out the stuff for usb0 in /etc/network/interfaces

    Now you should be able to configure static IPv4 addresses with interfaces.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •