Results 1 to 6 of 6

Thread: Stop screensaver when MPlayer is in fullscreen mode.

  1. #1
    Join Date
    Feb 2008
    Location
    Munster, Ireland
    Beans
    2,462
    Distro
    Ubuntu Mate

    Question Stop screensaver when MPlayer is in fullscreen mode.

    Hi.

    I use MPlayer sometimes to play videos at e.g. 1.21x speed. In full screen, the screen dims (screensaver). This never happens with VLC.

    I am using MATE.

    Is the best option to add line(s) to '~.mplayer/config'?

    Thanks.
    1st Distro used (live CD): Knoppix in early 2007 ¦ 1st Distro Installed: Ubuntu 7.10 in Feb 2008
    GNU/Linux User #470660 – Ubuntu User #28226
    Isaac Asimov: "I do not fear computers. I fear the lack of them."

  2. #2
    Join Date
    Feb 2009
    Location
    Dallas, TX
    Beans
    7,796
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Stop screensaver when MPlayer is in fullscreen mode.

    Hi Rytron.

    A few thoughts:

    If you use SMplayer, which is just a GUI for mplayer, you can disable by going to:
    Code:
    Opions -> Preferences -> General -> Video -> Disable screensaver
    (unless there a regression to a bug in 2010, the should work).

    If that's doesn't work, or you want to stick to plain mplayer, I've had success in the past by using the 'heartbeat-cmd' option on the mplayer config file.

    Either this:
    Code:
    heartbeat-cmd="gnome-screensaver-command -d"
    or this:
    Code:
    heartbeat-cmd="xscreensaver-command -deactivate"
    should work depending on the screen saver you are using.

    Hope it helps. Let us know how it goes.
    Regards.

    EDIT: apparently things have change since I did this. The gnome-scereensaver option now is -d not -p.
    Last edited by papibe; June 18th, 2015 at 10:53 PM. Reason: updated

  3. #3
    Join Date
    Feb 2008
    Location
    Munster, Ireland
    Beans
    2,462
    Distro
    Ubuntu Mate

    Re: Stop screensaver when MPlayer is in fullscreen mode.

    Hi papibe.

    I decided to add these 2 lines also to the mplayer config file:
    Code:
    heartbeat-cmd="mate-screensaver-command -d"
    heartbeat-cmd="mate-screensaver-command -deactivate"
    I'd use SMPlayer if it could play videos at speeds such as 1.25, etc.
    1st Distro used (live CD): Knoppix in early 2007 ¦ 1st Distro Installed: Ubuntu 7.10 in Feb 2008
    GNU/Linux User #470660 – Ubuntu User #28226
    Isaac Asimov: "I do not fear computers. I fear the lack of them."

  4. #4
    Join Date
    Feb 2008
    Location
    Munster, Ireland
    Beans
    2,462
    Distro
    Ubuntu Mate

    Unhappy Re: Stop screensaver when MPlayer is in fullscreen mode.

    @papibe

    Ok, last night I watched a movie to test this out. No joy. I even tried 'Caffeine Plus' but still no joy.

    By the way, I looked in Synaptic and it says I have mplayer2 installed. Would this matter that it is that and not mplayer installed?

    This is my mplayer config contents:

    Code:
    # Write your default config options here!
    zoom=yes
    vo=x11
    ao=alsa
    
    vf=screenshot
    
    #heartbeat-cmd="gnome-screensaver-command -d"
    
    heartbeat-cmd="mate-screensaver-command -d"
    
    heartbeat-cmd="mate-screensaver-command -deactivate"
    
    #heartbeat-cmd="xscreensaver-command -deactivate"
    
    # From Manjaro Wiki:
    [default]
    ao=pulse
    vo=vdpau
    dr=1
    use-filedir-conf=1
    noquiet=1
    msglevel=all=5
    noslices=1
    double=yes
    framedrop=0
    hardframedrop=0
    vsync=1
    ac=ffmpeg,ffmp3,mad,mp3acm,mpg321,
    srate=48000
    format=s16le
    channels=6
    cache=8192
    cache-min=50
    softvol=yes
    volstep=2
    volume=50
    softvol-max=50
    Last edited by Rytron; June 28th, 2015 at 10:30 AM.
    1st Distro used (live CD): Knoppix in early 2007 ¦ 1st Distro Installed: Ubuntu 7.10 in Feb 2008
    GNU/Linux User #470660 – Ubuntu User #28226
    Isaac Asimov: "I do not fear computers. I fear the lack of them."

  5. #5
    Join Date
    Jun 2007
    Beans
    17,337

    Re: Stop screensaver when MPlayer is in fullscreen mode.

    Quote Originally Posted by Rytron View Post

    I'd use SMPlayer if it could play videos at speeds such as 1.25, etc.
    It can play at any speed you wish, either thru the menu item Play > Speed or thru keyboard bindings
    (by default +- 10% is already set @ [ or ], other % bindings can be set (Options > Preferences > Keyboard & Mouse

  6. #6
    Join Date
    Feb 2008
    Location
    Munster, Ireland
    Beans
    2,462
    Distro
    Ubuntu Mate

    Thumbs up Re: Stop screensaver when MPlayer is in fullscreen mode.

    Quote Originally Posted by mc4man View Post
    It can play at any speed you wish, either thru the menu item Play > Speed or thru keyboard bindings
    (by default +- 10% is already set @ [ or ], other % bindings can be set (Options > Preferences > Keyboard & Mouse
    Ah, nice one. I stand corrected. Cheers mc4man. Kudos.
    1st Distro used (live CD): Knoppix in early 2007 ¦ 1st Distro Installed: Ubuntu 7.10 in Feb 2008
    GNU/Linux User #470660 – Ubuntu User #28226
    Isaac Asimov: "I do not fear computers. I fear the lack of them."

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •