Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Webcam on Lenovo Z510 does not work - Ubuntu GNOME 14.04.2

  1. #1
    Join Date
    Oct 2009
    Location
    Sydney
    Beans
    4,301
    Distro
    Ubuntu 20.04 Focal Fossa

    Question Webcam on Lenovo Z510 does not work - Ubuntu GNOME 14.04.2

    Hi everyone,

    On Ubuntu GNOME 14.04.2, the webcam on Lenovo Z510 does not work.

    Here is the output of "lsusb":

    Code:
    ~$ lsusb 
    Bus 002 Device 002: ID 8087:8000 Intel Corp. 
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 002: ID 8087:8008 Intel Corp. 
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 003 Device 002: ID 8087:07dc Intel Corp. 
    Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    I am not sure what should I do?
    Tried to search on the Internet for an hour or so but didn't find anything useful

    Thank you!

  2. #2
    Join Date
    Oct 2009
    Location
    Sydney
    Beans
    4,301
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Webcam on Lenovo Z510 does not work - Ubuntu GNOME 14.04.2

    Upgraded to 14.04.3 and the camera is working now.
    Last edited by amjjawad; September 9th, 2015 at 04:24 AM. Reason: back to "no device found"

  3. #3
    Join Date
    Oct 2009
    Location
    Sydney
    Beans
    4,301
    Distro
    Ubuntu 20.04 Focal Fossa

    Exclamation Re: Webcam on Lenovo Z510 does not work - Ubuntu GNOME 14.04.2

    I am not sure what is going on? it was working yesterday, it is NO longer working today

    Code:
    ~$ lsusb
    Bus 002 Device 002: ID 8087:8000 Intel Corp. 
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 002: ID 8087:8008 Intel Corp. 
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 003 Device 003: ID 8087:07dc Intel Corp. 
    Bus 003 Device 002: ID 0458:003a KYE Systems Corp. (Mouse Systems) NetScroll+ Mini Traveler / Genius NetScroll 120
    Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    I'm testing it using "Cheese" and while it worked yesterday, it says no: no device found.

    Can someone help?

    Thank you!

  4. #4
    Join Date
    Feb 2008
    Location
    Land of fire and drought
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: Webcam on Lenovo Z510 does not work - Ubuntu GNOME 14.04.2

    Restart the machine. Once stable at a desktop, plug the device in. Run this command immediately after plugging before doing anything else:

    Code:
    dmesg
    Post the output. You only give us the lsusb when it is not detected so we have no idea what the webcam is.

  5. #5
    Join Date
    Oct 2009
    Location
    Sydney
    Beans
    4,301
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Webcam on Lenovo Z510 does not work - Ubuntu GNOME 14.04.2

    Quote Originally Posted by Bucky Ball View Post
    Restart the machine. Once stable at a desktop, plug the device in. Run this command immediately after plugging before doing anything else:

    Code:
    dmesg
    Post the output. You only give us the lsusb when it is not detected so we have no idea what the webcam is.
    Thanks for your reply. The Camera is built-in with the laptop and it is already plugged since it has been built in and can't be attached nor unplugged.

    Do I still have to post the output of
    Code:
    dmesg
    Or there is another command?

    Thanks!

  6. #6
    Join Date
    Feb 2008
    Location
    Land of fire and drought
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: Webcam on Lenovo Z510 does not work - Ubuntu GNOME 14.04.2

    No. Just wondering why you are posting the results of a command that gives information about plugged in USB devices. I see now this has nothing to do with that.

    If it works one day and not the next and you haven't done anything to cause this, how old or young is the machine? Sounds like something odd happening with hardware.

  7. #7
    Join Date
    Oct 2009
    Location
    Sydney
    Beans
    4,301
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Webcam on Lenovo Z510 does not work - Ubuntu GNOME 14.04.2

    Quote Originally Posted by Bucky Ball View Post
    No. Just wondering why you are posting the results of a command that gives information about plugged in USB devices. I see now this has nothing to do with that.
    I don't know, I thought that was needed. Well, that is exactly why I posted here on the first place because I had no idea how to fix the issue

    If it works one day and not the next and you haven't done anything to cause this, how old or young is the machine? Sounds like something odd happening with hardware.
    The machine is one year old but never been used much .. maybe less than 10 times or so. So, it is really new.

    It is working on Windows 8 which is the default on this machine.
    I installed Ubuntu GNOME 14.04 last year but didn't use it.

    This year, I wanted to use it instead of sitting in the dark doing nothing. When I tried to check the camera, it didn't work

    After upgrading to 14.04.3, I noticed the camera started to work. That was yesterday.

    Today, it is back to not working again

    So, not sure what is going on?

    It is working on Windows 8 (sad but true) and it is not working on GNU/Linux.

    No, I will never use Windows so I need to fix it and use it under GNU/Linux.

    Thanks!

  8. #8
    Join Date
    Feb 2008
    Location
    Land of fire and drought
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: Webcam on Lenovo Z510 does not work - Ubuntu GNOME 14.04.2

    The fact it is working in Windows tells us there is nothing wrong with the hardware. That is all.

    Please try and update. Open a terminal and:

    Code:
    sudo apt-get autoremove
    sudo apt-get update
    sudo apt-get upgrade
    sudo apt-get dist-upgrade
    These commands will not upgrade your OS to a newer release. Post any and all errors between code tags (see the last link in my signature). Reboot and at the grub menu of kernels/OSs, go to the second one, Advanced Options, and on that screen choose the first kernel on the list.

    It sounds like it might be working on one kernel and not the other. Perhaps the kernel being booted into is changing. A shot in the dark, but possible.

  9. #9
    Join Date
    Jun 2007
    Location
    K-o-T,
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Webcam on Lenovo Z510 does not work - Ubuntu GNOME 14.04.2

    Also try guvcview as an alternative to cheese.

    Good luck
    Hypertension = Take with a pinch of salt
    | Psychocats | Ubuntu Documentation | Howto [Solved] | BBcode list | Brother Website |

  10. #10
    Join Date
    Oct 2009
    Location
    Sydney
    Beans
    4,301
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Webcam on Lenovo Z510 does not work - Ubuntu GNOME 14.04.2

    Quote Originally Posted by plucky View Post
    Also try guvcview as an alternative to cheese.

    Good luck
    Hi and thanks for posting.

    Screenshot from 2015-09-09 20:36:40.png

    Same, nothing changed.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •