Page 3 of 3 FirstFirst 123
Results 21 to 25 of 25

Thread: xfce Desktop not launching

  1. #21
    Join Date
    Sep 2009
    Location
    London
    Beans
    969

    xfce Desktop not launching properly

    So first of all, I created a thread to fix the LibreOffice problem - seems that i am not the only one with this, and found a website with the solution. So that is fixed, here
    http://ubuntuforums.org/showthread.php?t=2278818

    OK, this am, first boot up the 2nd screen would/does not allow the icons on it. Screenlets are all fine now and seem to work every time. So, hopefully in here somewhere there must be something that explains why it should be failing - the system log.


    Error messages I could find:
    HTML Code:
    May 19 07:20:14 Baroni-PC whoopsie[882]: [07:20:14] Could not get the Network Manager state:
    May 19 07:20:14 Baroni-PC whoopsie[882]: [07:20:14] GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.NetworkManager was not provided by any .service files
    HTML Code:
    May 19 07:20:15 Baroni-PC colord[950]: (colord:950): Cd-WARNING **: failed to get session [pid 863]: Unknown error -2
    HTML Code:
    May 19 07:20:17 Baroni-PC gpu-manager[878]: update-alternatives: error: no alternatives for x86_64-linux-gnu_gfxcore_conf
    HTML Code:
    May 19 07:20:18 Baroni-PC NetworkManager[873]: <error> [1432016418.988851] [dns-manager/nm-dns-dnsmasq.c:398] update(): dnsmasq owner not found on bus: Could not get owner of name 'org.freedesktop.NetworkManager.dnsmasq': no such name
    HTML Code:
    May 19 07:20:15 Baroni-PC colord[950]: (colord:950): Cd-WARNING **: failed to get session [pid 863]: Unknown error -2
    May 19 07:20:23 Baroni-PC colord[950]: (colord:950): Cd-WARNING **: failed to get session [pid 1005]: Unknown error -2
    HTML Code:
    May 19 07:20:51 Baroni-PC freshclam[875]: Downloading daily.cvd [100%]May 19 07:20:53 Baroni-PC ca.desrt.dconf[1297]: g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.May 19 07:20:53 Baroni-PC org.gtk.vfs.Daemon[1297]: A connection to the bus can't be madeMay 19 07:20:53 Baroni-PC org.gtk.vfs.Daemon[1297]: g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
    HTML Code:
    May 19 07:20:59 Baroni-PC freshclam[875]: ERROR: NotifyClamd: Can't find or parse configuration file /etc/clamav/clamd.conf
    HTML Code:
    May 19 07:21:20 Baroni-PC ureadahead[271]: ureadahead: /home/baronipc/Desktop/Documents/Documents/Dropbox/Images for appearence/Jonathan Harrison.JPG: Error retrieving chunk extents: Operation not supportedMay 19 07:21:20 Baroni-PC ureadahead[271]: ureadahead: /home/baronipc/Desktop/Documents/Documents/Dropbox/Images for appearence/Photos/IMG_20110904_154245.jpg: Error retrieving chunk extents: Operation not supportedMay 19 07:21:20 Baroni-PC ureadahead[271]: ureadahead: /home/baronipc/Desktop/Documents/Documents/Dropbox/Images for appearence/Photos/Jonathan & William: Error retrieving chunk extents: Operation not supportedMay 19 07:21:20 Baroni-PC ureadahead[271]: ureadahead:samba: Ignored relative pathMay 19 07:21:20 Baroni-PC ureadahead[271]: ureadahead:samba: Ignored relative pathMay 19 07:21:20 Baroni-PC ureadahead[271]: ureadahead:.xsession-errors: Ignored relative pathMay 19 07:21:20 Baroni-PC ureadahead[271]: ureadahead:.: Ignored relative pathMay 19 07:21:20 Baroni-PC ureadahead[271]: ureadahead:tracing_on: Ignored relative pathMay 19 07:21:20 Baroni-PC ureadahead[271]: ureadahead:events/fs/open_exec/enable: Ignored relative path
    and there are a lot of ureadahead lines....

    Warning messages:

    HTML Code:
    May 19 07:20:09 Baroni-PC kernel: [    6.920298] ACPI Warning: SystemIO range 0x0000000000000540-0x000000000000054f conflicts with OpRegion 0x0000000000000500-0x000000000000057f (\_SB_.PCI0.SBRG.GPBX) (20141107/utaddress-258)May 19 07:20:09 Baroni-PC kernel: [    6.920303] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driverMay 19 07:20:09 Baroni-PC kernel: [    6.920305] ACPI Warning: SystemIO range 0x0000000000000530-0x000000000000053f conflicts with OpRegion 0x0000000000000500-0x000000000000057f (\_SB_.PCI0.SBRG.GPBX) (20141107/utaddress-258)May 19 07:20:09 Baroni-PC kernel: [    6.920307] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driverMay 19 07:20:09 Baroni-PC kernel: [    6.920308] ACPI Warning: SystemIO range 0x0000000000000500-0x000000000000052f conflicts with OpRegion 0x0000000000000500-0x000000000000057f (\_SB_.PCI0.SBRG.GPBX) (20141107/utaddress-258)May 19 07:20:09 Baroni-PC kernel: [    6.920310] ACPI Warning: SystemIO range 0x0000000000000500-0x000000000000052f conflicts with OpRegion 0x0000000000000500-0x000000000000050f (\_GPE.GPIO) (20141107/utaddress-258)
    HTML Code:
    May 19 07:20:14 Baroni-PC freshclam[875]: WARNING: Can't query current.cvd.clamav.netMay 19 07:20:14 Baroni-PC freshclam[875]: WARNING: Invalid DNS reply. Falling back to HTTP mode.May 19 07:20:14 Baroni-PC freshclam[875]: WARNING: Can't get information about db.local.clamav.net: Temporary failure in name resolutionMay 19 07:20:14 Baroni-PC freshclam[875]: WARNING: Can't download main.cvd from db.local.clamav.netMay 19 07:20:14 Baroni-PC freshclam[875]: Trying again in 5 secs...
    HTML Code:
    May 19 07:20:15 Baroni-PC colord[950]: (colord:950): Cd-WARNING **: failed to get session [pid 863]: Unknown error -2
    HTML Code:
    May 19 07:20:16 Baroni-PC exportfs[1014]: exportfs: No options for /home/baronipc/Desktop/Documents : suggest (sync) to avoid warning
    HTML Code:
    May 19 07:20:19 Baroni-PC dnsmasq[1096]: warning: no upstream servers configured
    HTML Code:
    May 19 07:20:23 Baroni-PC colord-sane: io/hpmud/pp.c 627: unable to read device-id ret=-1May 19 07:20:15 Baroni-PC colord[950]: (colord:950): Cd-WARNING **: failed to get session [pid 863]: Unknown error -2May 19 07:20:23 Baroni-PC colord[950]: (colord:950): Cd-WARNING **: failed to get session [pid 1005]: Unknown error -2
    HTML Code:
    May 19 07:21:58 Baroni-PC rtkit-daemon[1454]: Supervising 1 threads of 1 processes of 1 users.
    May 19 07:22:00 Baroni-PC org.gnome.zeitgeist.Engine[1654]: ** (zeitgeist-datahub:2084): WARNING **: zeitgeist-datahub.vala:229: Unable to get name "org.gnome.zeitgeist.datahub" on the bus!
    I am not convinced the nVidia card sw is installed correctly, on the basis that the settings manager is not complete, like I have on other machines. Reinstalling can be quite a risk, especially on a hunch.

    Any ideas, please?
    Last edited by Jonners59; May 19th, 2015 at 11:32 AM.

  2. #22
    Join Date
    Feb 2007
    Location
    West Hills CA
    Beans
    10,048
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: xfce Desktop not launching

    Well colord is the daemon that manages color profiles for printers and monitors. It's possible that your video driver really is having problems.
    -------------------------------------
    Oooh Shiny: PopularPages

    Unumquodque potest reparantur. Patientia sit virtus.

  3. #23
    Join Date
    Sep 2009
    Location
    London
    Beans
    969

    Question Re: xfce Desktop not launching

    Quote Originally Posted by tgalati4 View Post
    Well colord is the daemon that manages color profiles for printers and monitors. It's possible that your video driver really is having problems.
    So you think it just might be this line
    HTML Code:
    May 19 07:20:15 Baroni-PC colord[950]: (colord:950): Cd-WARNING **: failed to get session [pid 863]: Unknown error -2 May 19 07:20:23 Baroni-PC colord[950]: (colord:950): Cd-WARNING **: failed to get session [pid 1005]: Unknown error -2 
    There have always been issues with nVidia cards, mostly blank screen after update/install, but I noticed that the manager was not complete when I opened it, which is something I have seen before and was advised by nVidia that it had not installed properly and to reinstall. Not an easy thing and fraught with possible dangers. But I will try and track down the lessons I had learnt and have a go. Shall feed back what i did and if it worked.

    Actually, on completing this reply, I was going to take a screen shot of it - before and after - but it has gone!!! Checked the Menu Editor too, and it has definetly GONE! ODD!

  4. #24
    Join Date
    Sep 2009
    Location
    London
    Beans
    969

    Re: xfce Desktop not launching

    Quote Originally Posted by Jonners59 View Post
    So you think it just might be this line
    HTML Code:
    May 19 07:20:15 Baroni-PC colord[950]: (colord:950): Cd-WARNING **: failed to get session [pid 863]: Unknown error -2 May 19 07:20:23 Baroni-PC colord[950]: (colord:950): Cd-WARNING **: failed to get session [pid 1005]: Unknown error -2 
    There have always been issues with nVidia cards, mostly blank screen after update/install, but I noticed that the manager was not complete when I opened it, which is something I have seen before and was advised by nVidia that it had not installed properly and to reinstall. Not an easy thing and fraught with possible dangers. But I will try and track down the lessons I had learnt and have a go. Shall feed back what i did and if it worked.

    Actually, on completing this reply, I was going to take a screen shot of it - before and after - but it has gone!!! Checked the Menu Editor too, and it has definitely GONE! ODD!
    OK, I think I have success.
    Simply I reinstalled the nVidia drivers.. As follows:

    First remind yourself which card you have:
    Code:
    lspci -vnn | grep -i VGA -A 12
    Then install the nVidia repository
    Code:
    sudo add-apt-repository ppa:xorg-edgers/ppa -y
    And quick update:
    Code:
    sudo apt-get update
    Then follow the link to the nVidia website, fill in the drop down questions to find the correct driver. No need to download it, just note the number.
    http://www.nvidia.com/Download/index...5pslvyvvsnosks

    Then enter the cmd as below with the correct number in terminal - mine was 346 - to download and install the driver
    Code:
    sudo apt-get install nvidia-346
    For safety and luck would have it, this worked better for me, I also did the following which installed a later version
    Code:
    sudo apt-get install nvidia-current
    Then go in to Synaptic package manager (if you do not have it yet, then this is a good time to install the vital app) and then in to Settings -> Repositories -> Additional Drivers
    Choose your driver and "Apply Changes".

    Thanks tgalati4 for helping identify the problem.

  5. #25
    Join Date
    Feb 2008
    Location
    Oblivion
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: xfce Desktop not launching

    Excellent news, great persistence and well done to all! Have been following with interest. Thanks for marking as solved as this thread could certainly help future fellow travelers. Enjoy.

Page 3 of 3 FirstFirst 123

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •