Results 1 to 4 of 4

Thread: No Root File System is defined

  1. #1
    Join Date
    May 2015
    Beans
    2

    No Root File System is defined

    During Installation attempted of UBUTU 14.04.2 I get this message " No root file system is defined please correct this from the partitioning menu"
    On the window "Installation Type" the partition table is empty and the line under "Device for boot loader installation:" shows: /dev/sda but I can't change anything.


    I have used GParted-live to format the HD :

    /dev/sda1 ntf ....................Window 7
    /dev/sda2 ext4 33GiB
    /dev/sda3 linux-swap 3GiB

    A Boot Flag is shown on the windows ntf partition.

    By the way I have gotten the same error message after wiping the HD clean without the windows installation.

    I also manually attached a Boot flag on the ext4 partition without success, same message: "No root file....."

    where do I go from here?

    Ubutu runs fine from the CD



    Thanks for your help
    John
    Last edited by flatfish2; May 11th, 2015 at 12:17 AM. Reason: Solved

  2. #2
    Join Date
    Jun 2014
    Beans
    5,486

    Re: No Root File System is defined

    If you have another operating system installed such as windows, you will be much better off selecting the "Something Else" option when installing Ubuntu. You should see a windows which lists whatever partitions/drives you have and since you have sda3 selected for Ubuntu, click the main windows to highlight that line then click the Change tab below You will get an Edit partition window and there is an option to set the Mount point, select the first option which is the forward slash ( / ) symbold for the root of the filesystem. This is all shown in the tutorial below, scroll about half way down the page.

    http://www.dedoimedo.com/computers/u...all-guide.html

  3. #3
    Join Date
    Mar 2011
    Location
    Idaho
    Beans
    293

    Re: No Root File System is defined

    Boot into the Live linux and in terminal run/ copy output and post
    Code:
    sudo parted -l
    Note: l is a small L

  4. #4
    Join Date
    May 2015
    Beans
    2

    Re: No Root File System is defined

    Thank you for your replies. Still working on my problem, I now understand about the need to set a Mount point but I couldn't even get to the something else menu, it goes right by it into the install menu.
    I will start from scratch at a later time and get back.
    Thank you

    John

    I found this post by darkod and it solved my issue. Must have run Raid some years back
    Thanks to all.

    darkod
    Staff Emeritus


    Join DateNov 2009LocationSegur De Calafell, SpainBeans11,824DistroUbuntu 12.04 Precise Pangolin


    Re: No root file system defined
    Is the partitions list empty like on that video? You never mentioned that, you just said you get the no root filesystem message.

    It is important information if the partitions list is empty.

    Usually that happens if the disk has been used in raid before. Meta data remains are left on the disk which windows ignores but ubuntu doesn't.

    If you ARE NOT running raid, boot into live mode with the ubuntu cd, open terminal and try:
    Code:
    sudo dmraid -E -r /dev/sda
    If it asks you to remove raid meta data just confirm. After that the install should work fine.

    Note that if you do the above and you ARE running raid, it will destroy your array and probably your data. You install on a raid system in different way. So, do NOT do the above if you are running raid.


    Last edited by howefield; November 21st, 2015 at 02:10 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •