Results 1 to 2 of 2

Thread: Issues when trying to install Starcraft 2

  1. #1
    Join Date
    Apr 2015
    Beans
    1

    Issues when trying to install Starcraft 2

    I'm using Linux Mint 17.1 Rebecca. My wine version is 1.7.38.

    I've already got Battlenet app installed and I've got Hearthstone and Heroes of the Storm working through it. When I try to install Stacraft 2 from the Battlenet app or the Starcraft-II-Setup-enGB.exe, I always get this error message:

    ERROR: The file "Blizzard Entertainment\StarCraft II\msvcr71.dll" could not be found.

    I've tried to install the game through POL and Wine, but in the case of POL, the already-installed Battlenet app seems to be a problem since it tries to install it. And if I choose not to install it, it doesn't install the game neither. I also tried to install the game through my DVD but it didn't start patching correctly when I linked the game to the Battlenet app. I tried the library override-thing for that .dll but it didn't seem to work. I got that .dll file manually but I'm wondering would it work with that if i would put it in the right directory. I have no understanding how those libraries work.

    So what is the proper way to install it through the dvd or how can I fix the error with msvcr71.dll? I think I'm doing something very wrong since SCII is marked as Platinum in WineHQ.
    Last edited by Henri_Huttunen; April 26th, 2015 at 11:06 AM. Reason: More information about system etc.

  2. #2
    Join Date
    May 2015
    Beans
    1

    Re: Issues when trying to install Starcraft 2

    I have Win 7 and I'm having the exact same problem with installing the StarCraft II via Battle.net.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •