Results 1 to 10 of 10

Thread: Installing Steam to Play Dota 2 on Ubuntu 14.04 (64bit)

  1. #1
    Join Date
    Apr 2015
    Beans
    4

    Installing Steam to Play Dota 2 on Ubuntu 14.04 (64bit)

    Ok first thing, I'm a regular dude who wants to play Dota 2 on ubuntu. I don't understand codes. so please speak to me as if i'm 10. I installed steam on the steam website. but an error occured. So i tried fixing it and now this is wat happens when i ran it, terminal popped with these text:
    Steam needs to install these additional packages:
    libgl1-mesa-dri:i386, libgl1-mesa-glx:i386, libc6:i386
    [sudo] password for jouzea:

    So when i enter my password these are the text:

    W: GPG error: http://bn.archive.ubuntu.com trusty Release: The following signatures were invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com>

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    libgl1-mesa-dri:i386 : Depends: libdrm-intel1:i386 (>= 2.4.48) but it is not going to be installed
    Depends: libexpat1:i386 (>= 2.0.1) but it is not installable
    Depends: libllvm3.4:i386 but it is not installable
    Depends: libstdc++6:i386 (>= 4.6) but it is not installable
    Recommends: libtxc-dxtn-s2tc0:i386 but it is not installable or
    libtxc-dxtn0:i386 but it is not installable
    libgl1-mesa-glx:i386 : Depends: libglapi-mesa:i386 (= 10.1.3-0ubuntu0.4)
    Depends: libx11-6:i386 (>= 2:1.4.99.1) but it is not installable
    Depends: libx11-xcb1:i386 but it is not installable
    Depends: libxcb-dri2-0:i386 (>= 1.8) but it is not installable
    Depends: libxcb-dri3-0:i386 but it is not installable
    Depends: libxcb-glx0:i386 (>= 1.8) but it is not installable
    Depends: libxcb-present0:i386 but it is not installable
    Depends: libxcb-sync1:i386 but it is not installable
    Depends: libxcb1:i386 (>= 1.9.2) but it is not installable
    Depends: libxdamage1:i386 (>= 1:1.1) but it is not installable
    Depends: libxext6:i386 but it is not installable
    Depends: libxfixes3:i386 but it is not installable
    Depends: libxshmfence1:i386 but it is not installable
    Depends: libxxf86vm1:i386 but it is not installable
    Depends: libudev1:i386 but it is not going to be installed or
    libudev0:i386 but it is not installable
    qtdeclarative5-qtfeedback-plugin : Depends: libqt5feedback5 but it is not going to be installed
    unity-control-center : Depends: libcheese-gtk23 (>= 3.4.0) but it is not going to be installed
    Depends: libcheese7 (>= 3.0.1) but it is not going to be installed
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
    Press return to continue:

    Can anyone help me please. T.T

  2. #2
    Join Date
    Apr 2015
    Beans
    4

    Re: Installing Steam to Play Dota 2 on Ubuntu 14.04 (64bit)

    Update:

    I followed the instructions here: http://ubuntuforums.org/showthread.php?t=2233005

  3. #3
    Join Date
    Jul 2005
    Location
    I think I'm here! Maybe?
    Beans
    Hidden!

    Re: Installing Steam to Play Dota 2 on Ubuntu 14.04 (64bit)

    So, please, if this is now solved, and it is not clear if that is so, can you use the Thread Tools menu at the top and mark it as such.
    DISTRO: Xubuntu 18.04-64bit --- Code-tags --- Boot-Repair --- Grub2 wiki & Grub2 Basics --- RootSudo --- Wireless-Info --- SolvedThreads

  4. #4
    Join Date
    Apr 2015
    Beans
    4

    Re: Installing Steam to Play Dota 2 on Ubuntu 14.04 (64bit)

    Aaand Nope it doesn't work.

  5. #5
    Join Date
    Apr 2015
    Beans
    4

    Re: Installing Steam to Play Dota 2 on Ubuntu 14.04 (64bit)

    Thought people will be helpful here.
    Additional info, i installed ubuntu in my External Hard Drive

  6. #6
    Join Date
    Jul 2008
    Location
    The Left Coast of the USA
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: Installing Steam to Play Dota 2 on Ubuntu 14.04 (64bit)

    Hello!

    We are neither conjurers of magical spells nor readers of crystal balls. Like you, we are "regular dudes" and "dudettes".

    Your initial post says:

    I installed steam on the steam website. but an error occured. So i tried fixing it and now this is wat happens when i ran it, terminal popped with these text:
    If you could tell us

    1. The initial error that occurred.

    2. What you did to try to "fix it".

    we might be able to start with some diagnosis rather than stabs in the dark.

    We would certainly like to help, but we can only work with the information given. If it is incomplete, we cannot even begin. There are a couple of fairly obvious things to try, but it would be nice to know what has gone on before.
    Last edited by QIII; April 13th, 2015 at 06:47 AM.
    Please read The Forum Rules and The Forum Posting Guidelines

    A thing discovered and kept to oneself must be discovered time and again by others. A thing discovered and shared with others need be discovered only the once.
    This universe is crazy. I'm going back to my own.

  7. #7
    Join Date
    Apr 2015
    Beans
    6

    Re: Installing Steam to Play Dota 2 on Ubuntu 14.04 (64bit)

    i have the same problem ... same errors .. so far nothing worked . Any luck on your side ?

  8. #8
    Join Date
    Dec 2010
    Beans
    Hidden!

    Re: Installing Steam to Play Dota 2 on Ubuntu 14.04 (64bit)


  9. #9
    Join Date
    Apr 2010
    Beans
    1

    Re: Installing Steam to Play Dota 2 on Ubuntu 14.04 (64bit)

    Same problem I ran thru and am also a newbie to Ubuntu and hardcore fan of Dota too... I fixed my issue with,

    "sudo apt-get install libgl1-mesa-glx-lts-utopic:i386"

  10. #10
    Join Date
    Feb 2016
    Beans
    2

    Re: Installing Steam to Play Dota 2 on Ubuntu 14.04 (64bit)

    I'm having a similar issue, however I just can't get Dota 2 to open...all other games are fine. what code do you all need to see to help me? I'm getting the Missing executable glitch...

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •