Results 1 to 2 of 2

Thread: [14.10] Sound Device Undetected?

  1. #1
    Join Date
    Mar 2015
    Beans
    1

    [14.10] Sound Device Undetected?

    Hello Peeps!!
    There's no sound device showing up in the audio settings, and and X showing in the volume indicator.
    I'm confident the error has something to do with permissions and may have been caused when I used fsab to mounting my home folder on another drive (which worked great).
    Oddly enough, sound itself works just fine.

    From searching the webs, I've tried the following suggestions..

    - re-installing pulsaudio
    - chmod 777 .config/pulse
    - sudo chown sgashepp:sgashepp ~/.config/pulse/

    Nothing has had any effect. Is probably obvious, I'm fairly new to linux,

    Some addittional info:

    Output of "ls -l ~/.config/pulse":
    total 1
    -rwxrwxrwx 1 root root 256 Mar 10 22:24 cookie
    Output of "sudo aplay -l":
    **** List of PLAYBACK Hardware Devices ****
    Failed to create secure directory (/home/sgahepp/.config/pulse): Permission denied
    card 0: PCH [HDA Intel PCH], device 0: ALC887-VD Analog [ALC887-VD Analog]
    Subdevices: 0/1
    Subdevice #0: subdevice #0
    card 0: PCH [HDA Intel PCH], device 1: ALC887-VD Digital [ALC887-VD Digital]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    card 1: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    card 1: NVidia [HDA NVidia], device 8: HDMI 2 [HDMI 2]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    Edit: I was rude enough to forget to express my gratitude for anyone gracious enough to offer assistance, so.. Thanks for your time everyone!
    Last edited by sgashepp-u; March 23rd, 2015 at 09:30 PM.

  2. #2
    Join Date
    Jun 2007
    Beans
    14,484

    Re: [14.10] Sound Device Undetected?

    Maybe you should use -R (recursive) flag with chmod and chown. Either that, or simply move/delete the directory and pulseaudio will generate a new config directory when restarted:
    Code:
    sudo mv /home/sgashepp/.config/pulse /home/sgashepp/
    pulseaudio -k

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •