Results 1 to 5 of 5

Thread: MediaInfo: Version `GLIBCXX_3.4.20' not found!

  1. #1
    Join Date
    Apr 2013
    Location
    /Earth/Bangladesh/Dhaka/
    Beans
    119
    Distro
    Ubuntu 14.04 Trusty Tahr

    MediaInfo: Version `GLIBCXX_3.4.20' not found!

    I have installed Mediainfo 0.7.72 on Ubuntu 14.04 64 Bit. But when I run MediaInfo I get following error -


    mediainfo-gui: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version GLIBCXX_3.4.20' not found (required by /usr/lib/libmediainfo.so.0)
    mediainfo-gui: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: versionGLIBCXX_3.4.20' not found (required by /usr/lib/libzen.so.0)


    What can I do?

    Thanks!

    MediaInfo: https://mediaarea.net/en/MediaInfo
    Last edited by Ashfaqur Rahman; January 27th, 2015 at 04:52 PM. Reason: changed prefix as solved
    Registered Linux User #560763

  2. #2
    Join Date
    Jun 2007
    Beans
    16,988

    Re: MediaInfo: Version `GLIBCXX_3.4.20' not found!

    I'm not sure what you installed but probably better you use a package built for 14.04

  3. #3
    Join Date
    Apr 2013
    Location
    /Earth/Bangladesh/Dhaka/
    Beans
    119
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: MediaInfo: Version `GLIBCXX_3.4.20' not found!

    What do you mean by "Package Built"? Are you suggesting to compile from source?
    Registered Linux User #560763

  4. #4
    Join Date
    Jun 2007
    Beans
    16,988

    Re: MediaInfo: Version `GLIBCXX_3.4.20' not found!

    Quote Originally Posted by Ashfaqur Rahman View Post
    What do you mean by "Package Built"? Are you suggesting to compile from source?
    I mean a package (.deb) that has been built for 14.04
    You linked to the mediainfo page & said you installed 0.7.72 by some unmentioned, by you, means. I'm not inclined to guess what that was.

  5. #5
    Join Date
    Apr 2013
    Location
    /Earth/Bangladesh/Dhaka/
    Beans
    119
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: MediaInfo: Version `GLIBCXX_3.4.20' not found!

    I have found that libstdc++.so.6 is actually a symbolic link to libstdc++.so.6.0.19 . I thought may be libstdc++.so.6.0.20 would solve my problem as the required version is GLIBCXX_3.4.20 . So I searched a little to know which version of GCC contains libstdc++.so.6.0.20 . Found this document which is indicating GCC 4.9.0 contains it. So I add this ppa and install GCC 4.9.0 which solved my problem.

    Thanks by the way.
    Registered Linux User #560763

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •