Page 1 of 4 123 ... LastLast
Results 1 to 10 of 38

Thread: 12.04 Update Manager is Recommending Updates Related to 12.10

  1. #1
    Join Date
    Mar 2013
    Beans
    62

    12.04 Update Manager is Recommending Updates Related to 12.10

    I'm running 12.04 and my kernel version is 3.5.0-23. I occasionally get kernel-related updates that I can't install, or, I can install them but I can't use them, because they "depend on the latest generic 12.10 kernel image and header packages available," as indicated in the descriptions. What happens is that after I boot up I get a broken package error, and synaptic tells me of the dependency, so just delete the package and go my merry way with 3.5.0-23.

    Now Update Manager wants me to install:
    • linux-headers-3.13.0-44 and linux-headers-3.13.0-44 generic, which I'm sure will depend on a 12.10 kernel, and
    • linux-headers-generic-lts-trusty, which says that it "will always depend on the latest generic 14.04 LTS kernel headers available."


    So I have two questions about this:

    How can I get Update Manager to stop recommending updates that I can't use? ; )

    Also, I'm running 12.04 because my humble machine (Toshiba Portege r100) can't run 12.10 (or beyond, of course). Is this... Ok? Meaning, should I be running Lubuntu or something more lightweight, but more current? Like, Lubuntu 14? Is it bad to be stuck on 3.5.0-23, from a security perspective? I mean, I like the OS, and everything works well, except for these baffling update suggestions.

    Thanks much!



  2. #2
    Join Date
    Feb 2008
    Location
    Oblivion
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: 12.04 Update Manager is Recommending Updates Related to 12.10

    12.04 LTS is fine. It is supported until April 2017.

    What I'm stumped about is that it is not offering 12.10 updates, it is offering 14.04 LTS updates. 3.13.0.44 is in the most recent updates for it.

    Have you installed any third-party Trusty repositories by mistake? Have you installed anything that might be asking for the 14.04 kernel?

  3. #3
    Join Date
    Apr 2011
    Location
    Mystletainn Kick!
    Beans
    9,706
    Distro
    Ubuntu

    Re: 12.04 Update Manager is Recommending Updates Related to 12.10

    the 3.5 kernel hit end of life in the summer of 2014 sometime, I forget when exactly, but that's the gist of it.
    The kernel series for 12.10, 13.04 and 13.10 were discontinued and users who are running those version, which came with ubuntu 12.04's four previous point releases 12.04.2, .3 and .4, were informed via the update manager, that they would need to install the newer hardware stacks.
    3.5 came with Ubuntu 12.04.2.

    So overall this is normal and expected.
    Splat Double Splat Triple Splat
    Earn Your Keep
    Don't mind me, I'm only passing through.
    Once in a blue moon, I'm actually helpful
    .

  4. #4
    Join Date
    Feb 2008
    Location
    Oblivion
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: 12.04 Update Manager is Recommending Updates Related to 12.10

    Quote Originally Posted by deadflowr View Post
    the 3.5 kernel hit end of life in the summer of 2014 sometime, I forget when exactly, but that's the gist of it.
    The kernel series for 12.10, 13.04 and 13.10 were discontinued and users who are running those version, which came with ubuntu 12.04's four previous point releases 12.04.2, .3 and .4, were informed via the update manager, that they would need to install the newer hardware stacks.
    3.5 came with Ubuntu 12.04.2.

    So overall this is normal and expected.
    Thanks deadflowr. Presuming it will install all that's needed, and correct me if I'm wrong, I suggest opening a terminal and:

    Code:
    sudo apt-get autoremove
    sudo apt-get update
    sudo apt-get upgrade
    sudo apt-get dist-upgrade
    Agree to install what it offers. Report any and all errors. Good luck.

  5. #5
    Join Date
    Apr 2011
    Location
    Mystletainn Kick!
    Beans
    9,706
    Distro
    Ubuntu

    Re: 12.04 Update Manager is Recommending Updates Related to 12.10

    Splat Double Splat Triple Splat
    Earn Your Keep
    Don't mind me, I'm only passing through.
    Once in a blue moon, I'm actually helpful
    .

  6. #6
    Join Date
    Mar 2013
    Beans
    62

    Re: 12.04 Update Manager is Recommending Updates Related to 12.10

    Thanks all! deadflowr, I believe I need to upgrade to 12.04.5 HWE (Trusty kernel/graphics), but I'll take a careful read of both of your links, do what seems sensible, and report back.

  7. #7
    Join Date
    Mar 2013
    Beans
    62

    Re: 12.04 Update Manager is Recommending Updates Related to 12.10

    Ok, from deadflowr's first link, indeed I want to do that first option: install 12.04.5 HWE (Trusty kernel/graphics). The next step says "The hwe-support-status tool will tell you what you need to do," but for me, that only told me:
    Code:
    Your current Hardware Enablement Stack (HWE) is no longer supported
    since 2014-08-07.  Security updates for critical parts (kernel
    and graphics stack) of your system are no longer available.
    
    For more information, please see:
    http://wiki.ubuntu.com/1204_HWE_EOL
    
    There is a graphics stack installed on this system. An upgrade to a 
    supported (or longer supported) configuration will become available
    on 2014-07-16 and can be invoked by running 'update-manager' in the
    Dash.
    Note that a few weeks ago I DID see a message, at the top, above the normal updates, about updating the HWE, and I tried that, but it said that it failed, because it couldn’t find 3.13.0-43. So now that option no longer appears in update manager.

    deadflowr, would you suggest the best path to take, I suspect in the terminal? I tried to follow your second link, but I'm over my head here, not being sure exactly what to install (quantal, raring, and saucy?).

    Thanks much!

  8. #8
    Join Date
    Apr 2008
    Beans
    11,630

    Re: 12.04 Update Manager is Recommending Updates Related to 12.10

    it said that it failed, because it couldn’t find 3.13.0-43
    It's probably best that we gather some info to figure out exactly where we're at and why the update mangler failed, so please start by posting the full output of:

    Code:
    sudo apt-get update
    Code:
    sudo apt-get -f install
    Code:
    cat /etc/apt/sources.list
    Code:
    ls /etc/apt/sources.list.d
    All of the above will provide some info about the state of the package manager, but lets also look at space limitations, the contents of /boot, and current kernel in use:

    Code:
    df -H
    Code:
    ls /boot
    Code:
    uname -a
    That will hopefully give us a clue where to start.

  9. #9
    Join Date
    Mar 2013
    Beans
    62

    Re: 12.04 Update Manager is Recommending Updates Related to 12.10

    Thanks kansasnoob, here you go:

    sudo apt-get update:
    http://paste.ubuntu.com/9737495/

    sudo apt-get -f install:
    Code:
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following packages were automatically installed and are no longer required:
      thunderbird-globalmenu libxrandr-ltsq2 gir1.2-ubuntuoneui-3.0
      firefox-globalmenu libubuntuoneui-3.0-1 libdrm-nouveau2 libxvmc1
      libxcb-dri2-0 libllvm3.1
    Use 'apt-get autoremove' to remove them.
    0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
    cat /etc/apt/sources.list:
    http://paste.ubuntu.com/9737562/


    ls /etc/apt/sources.list.d: No output (returned to command line)





    df -H:
    Code:
    Filesystem      Size  Used Avail Use% Mounted on
    /dev/sda1        37G  3.9G   31G  12% /
    udev            651M  4.1k  651M   1% /dev
    tmpfs           132M  820k  131M   1% /run
    none            5.3M     0  5.3M   0% /run/lock
    none            659M   78k  659M   1% /run/shm
    ls /boot:
    Code:
    abi-3.5.0-23-generic         memtest86+.bin
    config-3.5.0-23-generic      memtest86+_multiboot.bin
    grub                         System.map-3.5.0-23-generic
    initrd.img-3.5.0-23-generic  vmlinuz-3.5.0-23-generic
    uname -a:
    Code:
    Linux Tosh 3.5.0-23-generic #35~precise1-Ubuntu SMP Fri Jan 25 17:15:33 UTC 2013 i686 i686 i386 GNU/Linux

  10. #10
    Join Date
    Apr 2008
    Beans
    11,630

    Re: 12.04 Update Manager is Recommending Updates Related to 12.10

    Hmmmm, 3.5.0-23-generic is the original kernel that shipped with 12.04.2 so it's never received a kernel update. The 3.5 series kernel was up to 3.5.0-54 when it stopped receiving updates last July. So lets see what those two held/upgradeable packages are:

    Code:
    sudo apt-get dist-upgrade -s
    Note: the -s at the end means it will only simulate what would happen so we can look at that output and see if it tells us anything. Otherwise nothing just jumps out at me as being wrong. But it's possible that those kernel updates are now only available thru an "old/release" repo - I'm not sure about that but I can boot a box with Precise installed and see if need be.

Page 1 of 4 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •