Results 1 to 10 of 10

Thread: Slow graphics since upgrading to 14.10

Hybrid View

  1. #1
    Join Date
    Oct 2011
    Beans
    39

    Slow graphics since upgrading to 14.10

    I upgraded my machine from 14.04 to 14.10 over the weekend. I have had no issues apart from one which is pretty major from my point of view. The graphics are working horribly ever since the upgrade. I can watch Youtube videos all right but as soon as I make them full screen they become choppy. Playing videos (on VLC) is equally choppy no matter what, to the extent where they're unwatchable.

    I see that a similar issue has been raised by other posters but there are no definitive answers. Can anyone help? My graphics card is NVidia GeForce GT 540M

  2. #2
    ibjsb4 is offline Ubuntu addict and loving it
    Join Date
    Sep 2012
    Beans
    4,993

    Re: Slow graphics since upgrading to 14.10

    What video driver are you running?

  3. #3
    Join Date
    Oct 2011
    Beans
    39

    Re: Slow graphics since upgrading to 14.10

    Quote Originally Posted by ibjsb4 View Post
    What video driver are you running?
    X.Org X server - Nouveau display driver from xserver-xorg-video-nouveau

    The 'Additional Drivers' tab on Software & Updates suggests a few NVIDIA binary / legacy binary drivers but I struggle to know which one would be best

  4. #4
    ibjsb4 is offline Ubuntu addict and loving it
    Join Date
    Sep 2012
    Beans
    4,993

    Re: Slow graphics since upgrading to 14.10

    The 331 driver works for me. Maybe worth a try.

  5. #5
    Join Date
    Oct 2011
    Beans
    39

    Re: Slow graphics since upgrading to 14.10

    Quote Originally Posted by ibjsb4 View Post
    The 331 driver works for me. Maybe worth a try.
    I'll give it a try, thanks.

    I see two different 331 drivers: one is open source, one is proprietary. In your experience, is there any practical difference between those?

  6. #6
    ibjsb4 is offline Ubuntu addict and loving it
    Join Date
    Sep 2012
    Beans
    4,993

    Re: Slow graphics since upgrading to 14.10

    I run the proprietary driver. I did not know there was a open source driver. Could it be not open source, but source code?

  7. #7
    Join Date
    Oct 2011
    Beans
    39

    Re: Slow graphics since upgrading to 14.10

    No, it does say open source. Only difference is that the proprietary one is 331-updates, whereas the open source one is just 331. I'll try with the proprietary one and see how it goes. Thanks again!

  8. #8
    Join Date
    Oct 2013
    Beans
    70
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Slow graphics since upgrading to 14.10

    I had a graphic issue in both Lubuntu and Xubuntu 14.10, in my case it was the splashboot screen who did not show up at all. My graphic card is an NVIDIA Geforce as well. Here's the topic: http://ubuntuforums.org/showthread.php?t=2263521 In my case, installing the non-legacy, NVIDIA proprietary driver did not help.

    My suggestion would be to fall back on 14.04.1 LTS by doing a clean installation. There seems to be a kernel issue with some NVIDIA graphic cards in 14.10. It's just not worth the trouble for a short-term release and one can only hope that this will be fixed in 15.04 (to be expected in April.)

    From now on I've made the decision to stick only to the LTS releases.. More stability and less issues.
    Last edited by Tar_Ni; February 2nd, 2015 at 10:17 PM.

  9. #9
    Join Date
    Oct 2011
    Beans
    39

    Re: Slow graphics since upgrading to 14.10

    Quote Originally Posted by Tar_Ni View Post
    I had a graphic issue in both Lubuntu and Xubuntu 14.10, in my case it was the splashboot screen who did not show up at all. My graphic card is an NVIDIA Geforce as well. Here's the topic: http://ubuntuforums.org/showthread.php?t=2263521 In my case, installing the non-legacy, NVIDIA proprietary driver did not help.

    My suggestion would be to fall back on 14.04.1 LTS by doing a clean installation. There seems to be a kernel issue with some NVIDIA graphic cards in 14.10. It's just not worth the trouble for a short-term release and one can only hope that this will be fixed in 15.04 (to be expected in April.)

    From now on I've made the decision to stick to the LTS releases.. More stability and less issues.
    I have considered going back to 14.04, but downgrading is so much more time-consuming than upgrading so I decided against it.

    I did what ibjsb4 helpfully suggested and it's now working like a charm. Full screen videos play smoothly, no over-heating, just what I was looking for. I think some damage may have been done to the splash boot (it looks very small and ugly for a few seconds, then goes back to normal) but I can live with it

  10. #10
    ibjsb4 is offline Ubuntu addict and loving it
    Join Date
    Sep 2012
    Beans
    4,993

    Re: Slow graphics since upgrading to 14.10


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •