Results 1 to 4 of 4

Thread: 13.04 laptop with EFI but cannot enter BIOS

  1. #1
    Join Date
    Apr 2007
    Beans
    9

    13.04 laptop with EFI but cannot enter BIOS

    hi folks - i've been searching high and low for months now and found no luck with this problem.

    laptop - fujitsu lifebook LH532
    OS - originally 12.04 (IIRC). now after upgrades 13.04 apparently.

    this laptop came with no OS and the first thing i did a couple of years ago was to install the latest version (then - jan 2013) of ubuntu.

    now the situation is that when i put in a bootable CD/DVD or USB drive, the laptop will not boot in to that. pressing on F2 which should bring up the BIOS or UEFI or whatever you want to refer to it so i can modify the boot order. BUT it doesn't - i go back in to ubuntu.

    from what i gather, this has something to do with UEFI, but i'm unable to resolve it.

    please suggest some way i could rectify this situation - for now i can neither install a new OS using apt-get upgrade nor can i boot in to a new installer for any distro. furthermore, 13.04 is now EOL so it looks like software is going to be limited... in short, this laptop is bricked unless i figure out a way to get on something more up to date! help is much appreciated

  2. #2
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: 13.04 laptop with EFI but cannot enter BIOS

    Not sure how you upgraded to 13.04 as it is end of life. It should have offered to update to 14.04 as that is the newer LTS version.

    And you will not be able to run any updates on 13.04 or fix any issues that require downloading corrected packages as repository is closed.

    Some systems need a total cold boot to reset internals so you can get into UEFI or use one time boot key. If laptop also remove battery and hold power key for 10 sec to remove any residual power. Then see if you can boot into UEFI/BIOS.

    Some systems require password to turn off UEFI
    Fujitsu lifebook ah512. Secure boot options blocked in bios - UEFI password required
    http://ubuntuforums.org/showthread.php?t=2171114
    Fujitsu Lifebook A512 [SOLVED] Dualboot pre-installed win 8.1 and Ubuntu 14.04.1
    http://ubuntuforums.org/showthread.php?t=2254442

    If you set a password, which Fujitsu seem to require for UEFI, I hope you remembered it. Otherwise you may have a brick. With desktops you often can totally reset by removing the battery on motherboard and jumpering a couple of pins, not sure if possible on your system or not.
    UEFI boot install & repair info - Regularly Updated :
    https://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  3. #3
    Join Date
    Apr 2007
    Beans
    9

    Re: 13.04 laptop with EFI but cannot enter BIOS

    yea - i don't quite recall how i got to a point where i could upgrade.

    but anyway, here's a positive update - i found another user with the same laptop and the same issue. we exchanged emails and i believe i have the solution to at least prevent the laptop from being bricked altogether - i will post in more detail about it later so hopefully it can help someone.


    *** UPDATE ***

    ok so as promised, here's the update of how this problem is partially solved.

    firstly, this is reported as a bug here (this is the correct laptop model - Fujitsu LH532).
    https://bugs.launchpad.net/ubuntu/+s...x/+bug/1273060

    so as i mentioned, i came across someone else through the community with the same model and the same issue - got his email, exchanged a few mails and got back the ability to choose my boot device. NOTE - neither of us have the ability to enter BIOS but at least we can do this little bit which in my case helps me get out of the state i was in - a slightly working brick (working OS/software but stuck on a version that can be upgraded no further).

    so the technique used is as follows:
    1) open up laptop with battery in, but not connected to AC mains.
    2) locate and short a couple of pads on the motherboard using a screw driver (i will attempt to post a pic which will explain this better).
    3) close up the laptop panel. hit the power button.
    4) at this point you should get a menu to select from all devices which could be used to boot from (provided they have a bootable media). if you don't, restart and press F12 to get the menu.
    5) from here you should be able to boot to DVD/USB or whatever you wish to - booting from my HDD did not work (not that i wanted it to since i later formatted, repartitioned and did a clean OS install after saving my data to an external disk having booted from a live DVD).

    that's pretty much it - i have now installed Elementary OS to try out for now.
    Attached Images Attached Images
    Last edited by silver_shadow; December 26th, 2014 at 05:27 AM. Reason: update

  4. #4
    Join Date
    Sep 2017
    Beans
    6

    Re: 13.04 laptop with EFI but cannot enter BIOS

    I've recently looked into fixing this issue, and came up with a consistent way of restoring the laptop to full operation.

    The boot menu entries can be partially restored by bridging the "CL1_CL2" test point that is located under or next to the RAM slots.
    It may be required to have the laptop powered (or even powered on) while bridging the contacts for the test points to have any effect.
    This brings back the device-based boot menu entries, but does not yet restore access to the BIOS Setup menu.
    For that, a USB stick with Fujitsu's BIOS update tool (search by serial number to make sure you find the correct hardware revision) needs to be prepared, booted from, and run.
    This restores most BIOS settings to their default, including the missing BIOS Setup menu.

    Alternatively, if the currently installed Linux system is still bootable, one can use this tool to restore all entries without having to go through a BIOS update and reset.
    This works by manually rewriting all broken EFI variables with their expected content.
    Please do make note of the list of supported configurations and of the disclaimer (and let me know in case the tool does or doesn't work on some previously untested configuration).
    In case you want to know more about this works, there is a post explaining the underlying details.

    Lastly, a workaround for the issue has been merged into the Linux kernel, which should keep this from occurring on any new installations.
    This patch already ended up in the current installation media for the Ubuntu 24.04 beta (which I have confirmed to be not affected), and it will presumably be included in all installation media going forward.
    Last edited by coffeecat; April 23rd, 2024 at 12:05 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •