Page 34 of 206 FirstFirst ... 2432333435364484134 ... LastLast
Results 331 to 340 of 2058

Thread: Asus X205TA hardware support in Ubuntu

  1. #331
    Join Date
    Dec 2015
    Beans
    28

    Re: Asus X205TA hardware support in Ubuntu

    Hey

    I'm soon going to get this laptop and was wondering what was the state of the current support for it Linux wise? It seems like a really cool portable laptopt that I can use to ssh to my home server and work.

  2. #332
    Join Date
    Jul 2007
    Beans
    2

    Re: Asus X205TA hardware support in Ubuntu

    Hi,

    please could someone resume what is the state of the art to get best results installing (k/l)ubuntu on the Asus x205ta?!

    I allready succeeded installing kubuntu 14 on this little devil, but I would like to try the actual lubuntu instead of it. Yet when trying to install it, my newly built pendrive (with actual lubuntu) is still not able to start out from the UEFI-Bios. So I suppose that it is still necessary to compile a 32-bit UEFI Bootloader - is this correct? I wonder why it is so, because the actual debian distribution seems to facilitate the installation out of the box.

    I am a little confused by the ongoing discussion of that thread... And I think, it would be great to have the actual installation recomendations e.g. at the beginning of it.

    Thank you very much in advance!

    Markus

  3. #333
    Join Date
    Dec 2015
    Beans
    1

    Re: Asus X205TA hardware support in Ubuntu

    Thank you very much KemyLand for your post, its really detailed and interesting.

  4. #334
    Join Date
    Dec 2015
    Beans
    146

    Exclamation Re: Asus X205TA hardware support in Ubuntu

    Distro-Agnostic Installation Guide for the X205TA and apparently works on F205TAs, too!
    Edit: I've left further development of this guide in hiatus for a few months as of this edit. It should still work, but it won't explain to you how to get new, fancy features (such as Bluetooth) working. Please post in this same thread and you should get a good update on the matter.

    Edit: With "distro-agnostic" I mean it doesn't follows a single distro's installation procedure, and not that it lacks distro-specific details. Rather, it gets distro-detail intense at some points. See the Warning of warnings below.


    I've noticed that there're actually quite a few users who just want to get their (holy and sacred) Linux laptop working. This post will be for that purpose, and will try to explain it in non-technical terms. The reason is that most existent tutorials have already been outdated with the lastest quirks and fixes we've found out.

    First of all, why all this hassle? (GNU/)Linux can perfectly run on most computing devices, even your toaster! Now, the last year or so, some random genius from Asus decided that their new and shiny X205TA netbook would break the rules, and for no good reason. What are those rules, you may ask? Well...


    • 64-bit EFIs for 64-bit CPUs: UEFI (Unified Extensible Firmware Interface) is a piece of software that is responsible for bootstrapping your computer. It handles the power-on process, and ultimately loads a operating system. Almost all 32-bit systems have a (much) older firmware interface known as the BIOS (Basic Input/Output System) for the purposes of compatibility. Those BIOSes are strictly 32-bit. And, almost all the time, 64-bit systems have a 64-bit UEFI, as it's simply the appropiate firmware for them. Anyway, as we all already know, Asus decided to incorporated a 32-bit UEFI in a 64-bit system! Finding a 32-bit UEFI is already strange enough by itself, but this is just hilarious.
    • Broadcom hates Linux: Some may remember the days when we had to download propietary drivers to be able to use our Broadcom WiFi cards, until (apparently) Broadcom yielded control of (part of) its source code. However, yet again, we've faced quite some issues with Broadcom!
    • Use the f*cking correct device ID for the sound card: The RT5648, a.k.a the sound card of the X205TA, has no driver in the sources of the Linux kernel, yet it uses the same device ID as the RT5645, another (apparently) unrelated chip. (Note: apparently, some X205TAs have a different sound card)
    • Don't get into that "Secure boot" crap: Thanks to this, plus reason #1, we've had complications with the installation process.


    Understanding ourselves: History, basic conventions, and guide update system
    This guide is based upon a number of several different sources, see the References section. Although hidden under page 34 of this thread, this guide is intended as a means to have a common place for X205TA-related installation instructions and quirks. Before it, we had to find our way through the several available guides, whereas some details were burden under specific guides, and thus were ultimately unaccessible to some people. Check from time to time for updates!

    Also, this thread itself works as the day-to-day discussion place for X205TA stuff. Important information found in there will ultimately be reformatted and merged into this guide. To avoid misunderstandings, all existent X205TA-related threads in this or other forums are better off redirected here.

    With respect to commands, this guide presents them inside nice boxes, courtesy of Ubuntu Forums. When a command starts with a $ sign, it must be ran as a non-root user. When a command starts with a # sign, it must be ran as root, usually be means of sudo. If there's a # sign somewhere along a command, then the command ends just before the sign, and the rest of the line, including the sign, are considered a comment, and shall not be typed, but you must read it.

    The installation process will require a USB drive. There's no way around it, or do you see a DVD drive in your X205TA? I don't.

    This guide is divided in sections, which are identified by a large-size title. In most cases, you must follow the guide strictly in a linear fashion. However, some distros have special needs, and thus you'll do some section jumps while installing those. You'll be instructed to jump to another section under certain conditions at certain points.

    If anything, absolutely anything, goes wrong, in any sense of the word, even if you suspect it, inmediately stop whatever you're doing and contact us inmediately. That can be done by sending a PM to someone, usually me for being the guide's writer, or the community as a whole by means of posting in this thread. Be warned, the Ubuntu Forums' registration process is awful!

    The good, the bad, and the ugly: What's working and what's not
    What works 100%:
    • WiFi
    • SD card reader
    • Battery status
    • Touchpad with two-finger scrolling and all that funky stuff
    • Bluetooth
    • Everything else not mentioned on the other lists (since January 1st, 1970)


    What half-works

    • Hibernation


    What doesn't work

    • SounD


    You can get more information and details regarding what's not working (or half-working) in the discussion posts of this thread. Anyway, we'll always have the Protocol of Protocols, otherwise known as USB, which allows you to temporarily solve the sound and Bluetooth issues by connecting a USB sound card or USB Bluetooth card, respectively. Currently, we're working on a driver for sound. There's yet absolutely no information regarding Bluetooth. The X205TA has a pretty lasting battery, about 8 hours in use, so don't worry with respect to hibernation.

    Warning of warnings: This is Sparta!
    Most distributions have not been tested with the X205TA, and so far Debian and Arch Linux, excluding derivatives, are the only ones known to support the X205TA at 100% in both their boot and installation processes. Ubuntu and derivates are known to work with some minor tweaking at boot (TODO: update the Ubuntu-specific installation instructions). Manjaro, ironically enough derived from Arch, is only recommended if you have more than three lives to waste. The distro's automated installation procedure forces us to do a lot of tweaking, and we've yet to get that distro working 100%. If you want to contribute a little, trying out a random distro on the X205TA and then reporting your progress is a great way to waste a weekend.

    So far, this guide supports the following distros:

    • Arch Linux
    • Debian
    • Manjaro
    • Ubuntu and derivatives


    If you'ld like me to add support for another one, please PM me.

    The X205TA is a SoC (System-on-Chip). For practical purposes, this means that if something catches in fire, odds tell that everything else will. For instance, while testing parts of the audio driver, harryharryharry's speakers were known to, well, smell like burnt metal. Fortunately nothing bad happened to his machine. Although all of this guide's instructions have already been tested, and are completely safe, the discussion posts, specially the technical ones, do contain dangerous testing code and commands.
    You have been warned!


    Now that you've been warned, it's a good time to get a supported distro's ISO.

    Writing the ISO to the USB: How to do it TheRightWay(TM)

    Important: Don't even attempt to use dd, unetbootin, or any other funky stuff to do the following steps. It's known not to work.

    Now, with your distro's ISO in hand, assuming it's in a file called MyDistro.iso, and assuming you USB drive is at /dev/sdx (don't use /dev/sdx1 unless you're explicitly told to!) do...
    Code:
    # umount /dev/sdx # Some (most?) distros mount it automagically, but we need format it later on
    # fdisk /dev/sdx
    > o # Erase everything in the USB
    > n # Create new partition table
    > p # Primary partition
    > 1 # Partition number
    > <ENTER> # Don't type that literally!
    > <ENTER> # The partition get's all disk space
    > t # Change the partition type
    > 1 # Select partition #1
    > 12 # FAT32 partition type
    > x # Enter advanced mode
    > A # Make partition bootable
    > 1 # Select partition #1
    > r # Return to non-advanced mode
    > w # Write everything and exit
    Remove and reinsert the USB, then...
    Code:
    # mkdosfs -F32 /dev/sdx1 # Don't forget the "1"!
    # mlabel -i /dev/sdx1 ::THE_LABEL # Change "THE_LABEL" for the label of your distro's ISO. This is specially important for Arch and derivates!
    # mkdir /mnt/usb # Or use any other mountpoint you like
    # mount /dev/sdx1 /mnt/usb
    # 7z x -o/mnt/usb /path/to/MyDistro.iso # No space should go between "-o" and the path, BTW.
    bootia32.efi: Some voodoo with GRUB
    Important: If you're installing Debian, skip this section. Debian is the only known distro to come with the bootia32.efi hack out of the box.

    Get the bootia32.efi file and do...
    Code:
    # mkdir -p /mnt/usb/EFI/boot
    # cp /path/to/bootia32.efi /mnt/usb/EFI/boot
    Now, you may ask what is this bootia32.efi stuff, no? It's (sort of) a hack to get the bootloader around Asus' geniuses who decided to have a 32-bit UEFI + 64-bit CPU in the X205TA. Now, you need to remaster your ISO, a.k.a rebuilding it. This is distro-specific and is covered in the respective distro's documentation. Shall you give it the same label as the original ISO!

    Attacking the BIOS: This battle defines the war, and I'm not kiddin'!
    Get the USB out and put in the X205TA, if it's not already in there.

    If you haven't already disabled "secure boot", shut down the computer, and while turning it on, hold and press the shift key. A menu should appear. Navigate into something like "Advanced Settings" -> "Boot" -> "Enter the BIOS/firmware" (this may be/is wrong, I've not used Windows in a long time!)

    Once in the Holy Setup, go to the "Security" tab and disable secure boot. Now that you're here, you may want to change to time and date. It is not possible to do it outside the BIOS. To get the UTC time, take your timezone, and, if negative (such as GMT-08:00), forget about the sign and just add the number of hours to your local time. If it's possitive (such as GMT+06:00), subtract the given hours from your local time instead. The result is known as UTC, or Universal Coordinated Time in French. Put that data in the BIOS, then save and exit.

    Now, insert your USB in the device and shut it down. Here are some strategies to get the USB booting. One of them should work:
    1. Power the PC up and inmediately press the escape button. If this goes fine, the UEFI will ask you for a device to boot.
    2. Enter on Windows Rescue Whatever with the same shift combination again, and enter into "Advanced settings" -> "Boot" -> "Boot into another device" or something of the like.
    3. Fight with F2.
    4. Pray to systemd-kerneld, systemd-bootloaderd, and systemd-godd (it worked for me!)


    GRUB sucks it: Don't worry, it will do it (yet) again later on
    You will probably be dropped to a grub-rescue prompt. If you're not, and you're dropped into a usual GRUB menu, or otherwise can easily enter into your distro's installer, then skip this section. Otherwise, the way to get into your distro's installer is distro dependent.

    If you're installing Arch Linux...
    Code:
    > set root=(hd0,msdos1)
    > linux /arch/boot/x86_64/vmlinuz archisobasedir=arch archisolabel=ARCH_LABEL # Change ARCH_LABEL with the  label of your Arch ISO!
    > initrd /arch/boot/x86_64/archiso.img
    > boot
    If you're installing Manjaro...
    Code:
    > set root=(hd0,msdos1)
    > linux /manjaro/boot/x86_64/manjaro  archisobasedir=arch archisolabel=ARCH_LABEL # Change ARCH_LABEL with the  label of your Arch ISO!
    > initrd /manjaro/boot/x86_64/manjaro.img
    > boot
    If you're installing Debian, Ubuntu, and derivates such as Kubuntu, Lubuntu, Xubuntu, ElementaryOS, etc...:
    You, lucky one, don't have to do anything at all . It happens that Debian and derivates prepare everything for you!

    The installation itself: Time to pray to systemd/freakingd-godd this is!
    Once you've got into your distro's installation wizard, install as normal.
    Important: If you're installing Manjaro, the installation will fail. Jump to the Special case: Manjaro section.
    Important: If you're installing Ubuntu and derivatives (but not all Debian derivates, just Ubuntu derivates), the installation will fail. Jump to the Special case: Ubuntu derivates section.

    You may wipe out all existing partitions if you want to, or dual-boot. Be wise while partitioning, as this machine comes with 32GB of flash memory! Once installation is complete for whatever you love most, don't boot into the new installation! Do you remember I said you GRUB would suck it again? Well, that's why you must not enter into the new installation. Instead, boot again into the USB. For this part, we'll need Internet, so take an Android phone and connect it by USB to the computer, so to do Android tethering. Now that you have Internet, do...
    Code:
    # mount /dev/your-root-partition /mnt
    Mount all other partitions were they belong, such as /dev/your-boot-partition into /mnt/boot.Now, if you're installing Arch or derivates...
    Code:
    # arch-root /mnt /bin/bash
    Otherwise...
    Code:
    # mount -t proc proc /mnt/proc
    # mount -t sysfs sys /mnt/sys
    # mount -o bind /dev /mnt/dev # Notice the '/' in /dev!
    # mount -t devpts pts /mnt/dev/pts # We don't actually need this line, but it's there for completeness sake
    # modprobe efivarfs
    # chroot /mnt
    Now, install the packages grub and efibootmgr using your distro's package manager. Important: For Ubuntu and derivates, install efibootmgr, grub-efi-ia32, and grub-efi-ia32-bin instead. Then...
    Code:
    # mount -t efivarfs efivarfs /sys/firmware/efi/efivars # This goes *after* the chroot!
    # grub-install --target=i386-efi --efi-directory=/boot --bootloader-id=grub_uefi --recheck # Finally, install a non-brain-dead GRUB
    # grub-mkconfig -o /boot/grub/grub.cfg # We need this one, no?
    Important: Ubuntu and derivates may fail to boot into the actual installation. See the Special case: Ubuntu and derivatives section.
    Now, reboot into the fresh installation. Do tethering again.

    Foobar Mitzvah: TheSacredRitual(TM); do it wrong and you're screwed!
    Good news, you'll be compiling the Linux kernel right now! If you prefer so, get the 4.4.2 kernel, as I'll provide an already-optimized .config file for the X205TA in the attachments below. It's preferable that you run make menuconfig and then exit, saving changes (although you modified nothing), because otherwise you may get a command-not-found error right at the end of compilation (apparently a problem that originates from pastebin).
    Important: If you're using a F205TA instead of a X205TA, get harryharryharry's .config instead of mine; it's in the attachments, too, and is intended for 4.5-rc4.
    Important: This assumes a kernel >= 4.4.2 but <= 4.5, preferabily 4.4-rc8. The original 4.4 release is known not to boot, and the 4.5 series have a number of random issues.

    Notes from the past: Kernel compilation used to be an optional step of this guide, but is now required due to the high number of useful patches we've worked out.

    Get the sources directly from heaven and do this...
    Code:
    $ tar xf linux.tar.xz # Remember that your downloaded tar will have a different filename...
    $ cd linux # And this directory will have a different name, too!
    $ curl *******.us/HdeH | tr -d '\r\n' | base64 -d | patch -p1 # This patch gives you WiFi and touchpad support, and fixes some minor issues.
    $ cp /path/to/the-config-file-you-were-supposed-to-download .config # If you use one of the .configs provided below. Otherwise, find the right options yourself!
    $ make -j 6 bzImage # '-j 6' seems appropiate for compiling under the X205TA
    $ make -j 6 modules
    # make modules_install
    # cp arch/x86/boot/bzImage /boot/vmlinuz-your-kernel-version-x205ta # This *must* be done that way; example: "vmlinuz-4.4.0-rc3-x205ta"
    AlternatIvely, you can compile in a faster machine if you know how to (not explained here), then pass over the binaries to the X205TA.

    Lastly, we need to generate the initial RAM disk (initrd).
    If you use Arch and derivates:
    Code:
    # mkinitcpio -k your-kernel-version-x205ta -g /boot/initramfs-your-kernel-version-x205ta.img
    Otherwise:
    Code:
    # update-initramfs -k your-kernel-version-x205ta
    Then reboot into the new kernel. If you did it right, you should have full touchpad support (but not WiFi). You may now remove the old kernel if you want to.

    Quirks: This time pray to Saint IGNUcius of the Church of Emacs, you, mere mortal!
    We need to add some parameters to the kernel command line and update GRUB. With root privileges, add the following, separated by spaces, to the field GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub:
    • relative_sleep_states=1: Necessary to get suspension working later on.
    • reboot=acpi: Helps solve some minor issues while rebooting/shutting down, including having to press the "off" button in order to proceed.


    Notes from the past
    : We used to have an intel_idle.max_cstate=1 trick for a long time to avoid random freezes. This was properly solved by the C7 patch and is no longer needed.

    Now...
    Code:
    # grub-mkconfig -o /boot/grub/grub.cfg
    And reboot.

    You should boot up in an (almost) working Linux distro! Now, let's get WiFi working, so that we can disconnect that phone that's sucking our battery! Do...
    Code:
    $ wget https://android.googlesource.com/platform/hardware/broadcom/wlan/+archive/master/bcmdhd/firmware/bcm43341.tar.gz
    $ tar xf bcm43341.tar.gz
    # cp fw_bcm43341.bin /lib/firmware/brcm/brcmfmac43340-sdio.bin # The '1' to '0' change is *not* a typo!
    # cp /sys/firmware/efi/efivars/nvram-74b00bd9-805a-4d61-b51f-43268123d113 /lib/firmware/brcm/brcmfmac43340-sdio.txt # Type this right or you're screwed!
    Important: If the /sys/firmware/efi/efivars/nvram-74b00bd9-805a-4d61-b51f-43268123d113 file does not exist in your system, you happen to got a special kind of X205TA. In such a case, try out this command instead of the last line (see page 54 for details)...
    Code:
    # curl http://pastebin.com/raw/68wbW4jU | tr -d '\n\r' | base64 -d >/lib/firmware/brcm/brcmfmac43340-sdio.txt
    If it still doesn't works, even after a reboot, then please contact us.

    Now, one last thing, the microSD card reader. Do...
    Code:
    # cat >/etc/modprobe.d//sdhci.conf <<EOF
    options sdhci debug_quirks=0x8000
    EOF
    We need to regenerate the initrd again.
    If you use Arch and derivates:
    Code:
    # mkinitcpio -k your-kernel-version-x205ta -g /boot/initramfs-your-kernel-version-x205ta.img
    Otherwise:
    Code:
    # update-initramfs -k your-kernel-version-x205ta
    Finally, at least on some machines, the touchpad won't work at boot. To fix this, add these commands to be run by either SysVInit or Systemd at boot...
    Code:
    # rmmod elan_i2c
    # modprobe elan_i2c
    You'll also need to do that after resume from suspend-to-RAM. And, to get WiFi working after resume, you have to blacklist the btsdio module. To do that, do...
    Code:
    # cat >/etc/modprobe.d/goodbye-btsdio.conf <<EOF
    blacklist btsdio
    EOF
    And reboot, of course. This is the last one, promise!

    Attachments et al that crap

    Notes from the past
    : I used to have a .config series of my own. The the last of them was for 4.4-rc8. Those .configs were big and bloated. Don't used them unless for experimentation.

    Kernel 4.5-rc4 .config
    Code:
    $ curl http://pastebin.com/raw/eM7SbhNg >.config

    Kernel 4.6.0 .config
    Code:
    $ curl http://*******.us/LAEd | base64 -d > .config

    Important: Please note that all .configs have been stripped down to a bare level. If you find that you need support for a driver that's not present in any of the provided .configs, either enable support yourself or contact the respective .config author.

    Special case: Manjaro
    The X205TA has sort of a... ahem... peculiar hardware clock (the one that keeps running even if your computer is off). As stated above, you should change it from the BIOS. However, Manjaro's installer will attempt to change it, resulting the failure of the whole installation. Don't worry. At this point, everything has been installed, with the exception of GRUB and the kernel. So, you enter immediately into chroot to install the bootloader as described above. Then, you'll have to compile the kernel from inside the Live USB, as described above, too. If you do it inside chroot, then the instructions are exactly the same as if you were doing it from inside the actual OS. Once you've done with that, regenerate GRUB's configuration, and you should be able to enter the installed OS. Don't attempt to pacman -S linux! pacman will get confused because of the mess that the installer leaved, and as a consecuence, no initramfs will be installed. This will result a pretty kernel panic if you attempt to boot such a kernel.

    Special case: Ubuntu and derivates

    Notes from the past
    : This is no longer happens since 16.04. Still useful if you're installing something older.

    : The Ubuntu installer, and the installer of its derivates, will fail, because of it being unable to install the bootloader. Although it has not been tested yet, you may try to do the same as Manjaro, that is, continue with the installation yourself. The Ubuntu installer is detailed enough as to say that the bootloader is the last thing to get installed. This means that most of the system is already installed. So, install the bootloader manually from the installation media manually, and it should work. Upon boot, if you're dropped into the GRUB rescue command line, type this...
    Code:
    > set root=(hd0,gptX) # Where gptX is to the /dev/mmcblk0pX of your root partition
    > linux /vmlinuz root=/dev/mmcblk0pX # Same "X" as for your root partition 
    > initrd /initrd.img
    > boot

    We're working on an automated solution for this.

    References and credits

    • harryharryharry: He is the author of the F205TA .config. He discovered the btsdio module that made WiFi work after suspend (no longer a problem since Bluetooth began working). Author of the easy-install script and remix ISOs.
    • KemyLand: Me, no? I wrote this guide and found out the relative_sleep_states workaround that made suspension work on all X205TAs. Also wrote the C7 patch.
    • aleck2: He found out TheRightWay(TM) to install ElementaryOS, and thus Ubuntu and derivates, correctly on the X205TA.
    • KernelAshmead: Has helped out to test out quirks and has found out a number of minor bugs and errors in them, as well as in this guide.
    • Kuci and michael348: They have found out important information about the sound card, and have participated in the development of the yet-to-work audio driver.
    • ifran: The original author of the first working guide, over which this one was primarily based on, however, it's not maintained anymore, so this one was written. It was based on lopaka's.
    • lopaka: Wrote the original guide, thought it was very unstable and barely worked. If I'm correct, it doesn't even works now.
    • Jon Bradury: We haven't seen him in a long time, but he's responsible for starting this thread that's now more than fifty pages long!
    • Michele Curti: He bootstrapped the development of the audio driver. We have not heard of him in several months, so we took over on the driver's development.
    • Intel: So far, they have helped into getting audio working along with Curti, and are the best company we've dealt with so far with respect to the X205TA.
    • Several other people whose usernames I don't know/remember. They're the ones who participated in the first posts of this thread, and the ones who got the X205TA to work in the first place.
    • All the non-hacker users, such as gustaprana and pablo-gonzales-padilla: They have motivated us to continue in this community work, and have pointed out several typos in this guide.
    • The forum administrators who have maintained this gigantic thread. There even appears to be a few of them who have X205TAs and want them working!
    • Lots (and lots) of morons from Asus, Realtek and Micro$oft: We're here having that much fun thanks to their great ideas!
    Last edited by KemyLand; January 1st, 2017 at 06:03 PM. Reason: Minor fixes

  5. #335
    Join Date
    Oct 2009
    Beans
    579

    Re: Asus X205TA hardware support in Ubuntu

    Nice howto!, might want to change RT6548 to RT5648

  6. #336
    Join Date
    Dec 2015
    Beans
    146

    Re: Asus X205TA hardware support in Ubuntu

    Thanks, fixed.

  7. #337
    Join Date
    Dec 2015
    Beans
    28

    Re: Asus X205TA hardware support in Ubuntu

    Quote Originally Posted by KemyLand View Post
    ...
    Thank you so much KemyLand, going to get my laptop tomorrow.

    A question: I heard that sound doesn't work only through speakers, but that it works through external device (i.e. speakers or headphones): is that true ? Thanks again for the guide

  8. #338
    Join Date
    Dec 2015
    Beans
    146

    Re: Asus X205TA hardware support in Ubuntu

    Quote Originally Posted by bithon View Post
    Thank you so much KemyLand, going to get my laptop tomorrow.

    A question: I heard that sound doesn't work only through speakers, but that it works through external device (i.e. speakers or headphones): is that true ? Thanks again for the guide
    There're three (usual) ways to get play audio on this PC:
    1. Through the internal speakers. There's no driver for the sound card, so this won't work.
    2. Through the 3.5mm output. There's no driver for the sound card (which controls those ports), so this won't work.
    3. Through a Bluetooth-connected speaker. Again, no driver for the internal Bluetooth card. Does anyone know the status of this?
    4. Through a USB headset. The audio will (probably) be crappy but it'll work.


    BTW, this is not the first time that USB has saved our life with this machine (e.g: Android tethering). So far, the problems that we've not been able to solve has been due to companies like Asus, Realtek, and Whoever-made-the-Bluetooth-card, Inc not colaborating. No programmer is able to write a driver without a specification, and the one that do is because their reverse-engineer sort of a specification in the first place. Reverse engineering is a hard work, and it's usually a response to a high demand (e.g: the Nouveau driver for Nvidia graphic cards), and we're not in that situation with the X205TA. And, if someone asks, the firmware of the WiFI driver we're using right now is propietary. Being it free, suspend/resume would already work 100% by now.

    Anyway, no matter what, we're here, improving slowly but constantly. I'm sure we'll eventually win the war and get GPL'd drivers for the X205TA .

  9. #339
    Join Date
    Dec 2015
    Beans
    22

    Re: Asus X205TA hardware support in Ubuntu

    In regards to sound I just found this: http://www.spinics.net/lists/alsa-devel/msg44368.html

  10. #340
    Join Date
    Oct 2009
    Beans
    579

    Re: Asus X205TA hardware support in Ubuntu

    Is that applicable to the x205ta ? I thought the x205ta had an rt5648 (or according to some an rt5645). Not the rt5640 ...

    Good news everyone!
    I found that unloading the btsdio module before suspending will prevent wifi from breaking when suspending.

    Since bluetooth is not yet functional (which could be why wifi breaks on suspend), I chose to blacklist the btsdio module altogether. With btsdio disabled I can suspend and resume without losing wifi (and with the systemd elan-fix incorporated, touchpad also keeps working).
    Last edited by howefield; January 1st, 2016 at 10:51 PM.

Page 34 of 206 FirstFirst ... 2432333435364484134 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •