Page 217 of 218 FirstFirst ... 117167207215216217218 LastLast
Results 2,161 to 2,170 of 2179

Thread: Asus X205TA hardware support in Ubuntu

  1. #2161
    Join Date
    Mar 2010
    Beans
    4

    Re: Asus X205TA hardware support in Ubuntu

    A couple years back, I installed ubuntu 16 and used a kernel provided by harryharryharry. As I recall the wifi didn't work until I installed it and then updated the kernel. It worked great but I was at a busy point in my life and didn't get around to the fixes for freezing especially when closing and opening the top I would just reboot it and mostly avoid closing it, so one day I spilled a glass of water on it. I immediately turned it upside down to let it run off and wiped it off with a towel and turned it off and gave it a good while until I tried again and it still worked minus the a and 4 keys.

    So a few weeks later I had left the room and came back to it and it was frozen and I restarted it and it would go to the ubuntu boot screen and then go to the blank but lit screen that it usually does during boot and then just freeze right there, I don't think it was necessarily the water that did it, it also has been dropped several times, mostly due to toddlers.

    I tried using the recovery kernels from the grub boot screens and there was one that would work but without any X or gui. So at this point I decide to make a bootable stick to recover it. Couldn't get the harry script to work but I was able to make a bootable usb stick again and can boot up live and access the files, but I want to copy them over to my other comp before installing ubuntu again and can't get wifi to work to do so and don't want to risk installing over old installation until I back up the home files and also don't have an extra usb stick to do so either and won't be able to get one until payday + tied up in bills is done.

    Is there a way to run a live usb stick that will have wifi? As before it won't work from the live usb stick but will likely work after install and kernel or if there is a kernel on a livecd that works. Maybe a way to have a working kernel on live usb that will work, whether it's an older version or not? I have tried 18.04 and 16.04.6 and even used the directions for copying the nvram text file. I mostly just want to get the files back, if this little laptop is done, so be it, but it be nice if I can get to work again
    Last edited by guitarjerry; November 14th, 2020 at 03:41 PM.

  2. #2162
    Join Date
    Feb 2018
    Beans
    20

    Re: Asus X205TA hardware support in Ubuntu

    Could someone maybe upload an image of the latest LTS Xubuntu?

    I'm on 19.04 Disco Dingo, APT is broken and I can't get the script to run to build my own image.
    Since Harry's server is down, I really don't know how to upgrade. I've tried but nothing I do seems to go anywhere.

    Edit: Nevermind, I was able to build the ISO with your script. Thanks again Harry for your amazing work!

    I added the following line to '/etc/apt/sources.list'
    deb http://old-releases.ubuntu.com/ubuntu disco main universe multiverse restricted
    Then ran:
    sudo apt-get install -y xorriso p7zip-full fakeroot binutils isolinux syslinux
    sudo ./x205ta-create-iso.sh xubuntu-20.04.1-desktop-amd64.iso
    Last edited by denn1s-r; November 16th, 2020 at 08:47 PM.

  3. #2163
    Join Date
    Jun 2020
    Beans
    3

    Re: Asus X205TA hardware support in Ubuntu

    Hi Harry,

    Thanks for your new script. It's great to see your continuing support for the handful of people still using their ASUS x205ta.

    I tried to run your script on an MX Linux 19.3_x64 ISO and got the following error message:

    Code:
    mount: /tmp/x205ta-mount-tIfxw1OwKA: WARNING: device write-protected, mounted read-only.
    15+0 records in
    15+0 records out
    15728640 bytes (16 MB, 15 MiB) copied, 0.231904 s, 67.8 MB/s
    mkfs.fat 4.1 (2017-01-24)
    /tmp/x205ta-work-NaG2NwbSAb /home/hiro/Downloads
    xorriso 1.5.2 : RockRidge filesystem manipulator, libburnia project.
    
    Drive current: -outdev 'stdio:/home/hiro/Downloads/x205ta-MX-19.3_x64.iso'
    Media current: stdio file, overwriteable
    Media status : is blank
    Media summary: 0 sessions, 0 data blocks, 0 data, 15.2g free
    xorriso : WARNING : -volid text does not comply to ISO 9660 / ECMA 119 rules
    Added to ISO image: directory '/'='/tmp/x205ta-work-NaG2NwbSAb'
    xorriso : UPDATE :     931 files added in 1 seconds
    xorriso : FAILURE : Cannot find in ISO image: -boot_image ... bin_path='/isolinux/isolinux.bin'
    xorriso : UPDATE :     931 files added in 1 seconds
    xorriso : aborting : -abort_on 'FAILURE' encountered 'FAILURE'
    umount: /tmp/x205ta-efi-dvplHHWtMt: not mounted.
    umount: /tmp/x205ta-efi-original-VXHIQJEpS2: not mounted.
    I'm not sure what the problem is as a Linux newbie (I'd guess that xorriso can't find isolinux.bin?), and have no clue as how to solve this. Hope that someone can help me out!

  4. #2164
    Join Date
    Oct 2009
    Beans
    601

    Re: Asus X205TA hardware support in Ubuntu

    @guitarjerry
    I'm not really clear on what your current situation is, but if it's only a live usb that can connect to wifi you're after: that's not really a big deal anymore. I'd suggest you try out a recent ubuntu iso and create an iso with my script to make it bootable on the x205ta. Wifi should work out of the box.

    @denn1s-r (and maybe others)
    It may be useful to know you can run my script on any computer/linux distro, provided you have the right packages installed. Doesn't necessarily need to be the x205ta.

    @tesshu
    My script tries to recognize the linux iso by its label, because many different distros need a slightly different xorriso command to ultimately build the iso. The script didn't recognize the label correctly and chose a wrong xorriso command (it's the ugliest part of my script ). Luckily a different variation of the xorriso command already in my script does work for MX Linux. I updated the script so you can use it for MX Linux too. Be aware that MX Linux doesn't seem to have working wifi out of the box. You can fix that by placing a copy of brcmfmac43340-sdio.txt in /lib/firmware/brcm:
    https://raw.githubusercontent.com/ha...43340-sdio.txt

    and run
    Code:
    sudo rmmod brcmfmac; sudo modprobe brcmfmac
    (or reboot the laptop)



    Last edited by harryharryharry; November 18th, 2020 at 06:32 PM.
    Script to create bootable usb-stick for the X205TA. Guide to compile a kernel for the X205TA. Guides to install linux to X205TA: general or ubuntu

  5. #2165
    Join Date
    Mar 2010
    Beans
    4

    Re: Asus X205TA hardware support in Ubuntu

    I did get it working using the brcmfmac stdio.txt file thing but I used the command from your link guide to install to x205ta ubuntu. This was on 18.05 bionic beaver. It didn't work the first time, guess I missed an 'a' having a non working 'a' key and using the on screen keyboard to type stuff. Then I was able to copy all my home files to my other laptop with scp which was what I wanted before trying to restore the system by reinstalling. So I then installed it without formatting and my home files were still there anyway, but I had to be sure.

    Now it works and I have sound and everything, but it still freezes sometimes. Is there a fix for that? building a non stock kernel? I haven't built one since 2.6 or so and there are SO many kernel options I have no idea haha

    And what about sound over hdmi? did anyone figure that one out? since I black listed the hdmi lpe sound to get the regular sound to work, maybe there's away to get it to not use that by default instead and then one could switch back and forth?

    Would it be easier to just install a newer ubuntu? I used 18 bc I only have a 2g usb stick atm my other one broke and I have bills for awhile until I can spare a few bucks for another one

    Also would it be possible for a wiki to be created that has the relevant links? combing through this 217 page thread for the pertinent information is a bit of a task, even when you can find the links.. just a thought

    Thanks for your help Harryharryharry

    Update: used software updater to update to 20.04 so far no more freezing and had to remove the 50-xt205ta.conf file as it worked for 18.04 but on 20.04 makes the headphone jack work in reverse
    Last edited by guitarjerry; November 23rd, 2020 at 01:21 AM.

  6. #2166
    Join Date
    Jul 2019
    Beans
    17

    Re: Asus X205TA hardware support in Ubuntu

    Quote Originally Posted by harryharryharry View Post
    You shouldn't try to extract it. Write the iso to a usb with an image writer (dd, rufus, Win32 Disk Imager or something like that) like you would normally do with any linux iso.
    Rufus did the trick. I am able to boot in to Ubuntu 20.04.1 sound, wifi etc is working. Havent installed it yet will do that later but all looks perfectly fine.

  7. #2167
    Join Date
    Nov 2020
    Beans
    1

    Re: Asus X205TA hardware support in Ubuntu

    Hi,
    Thanks Harry³ for everything you've done so far to let us use this computer on Ubuntu.
    Since 2016 with ubuntu 16, I had every thing functioning (execept hibernate), With Ubuntu 18.04, it was a disaster the PC was slow as hell and I was just able to make wifi functioning.
    Yesterday I updated my laptop on focal fossa and It's way better :
    -No freeze, (except after a 1 hour sleep mode)
    - Sound and wireless working properly
    - The laptop runs as if it was new

    But ...
    I cant' figure out how to activate Bluetooth and headphones detection (or at least how to use them)

    Here is my Kernel version (since I believe this is where I should do some modification):

    Linux version 5.4.0-54-generic (buildd@lcy01-amd64-024) (gcc version 9.3.0 (Ubuntu 9.3.0-17ubuntu1~20.04)) #60-Ubuntu SMP Fri Nov 6 10:37:59 UTC 2020

    I will be gratefull for any help letting me enjoy one or another of the remaining nonfunctional features.

    Thanks a lot

  8. #2168
    Join Date
    Aug 2013
    Beans
    1

    Re: Asus X205TA hardware support in Ubuntu

    This is the correct reason why Bluetooth works for me on 4.19 kernel but not any 5.x! My fix is to add a systemd service to set the Bluetooth device address. It works for me on Debian bullseye but I believe it also works for Ubuntu:

    Add a file /etc/systemd/system/bluetooth-addr.service:

    Code:
    [Unit]
    Description=Set Bluetooth device address
    After=bluetooth.service
    Requires=bluetooth.service
    
    [Service]
    ExecStart=/usr/bin/btmgmt -i hci0 public-addr {YOUR_BLUETOOTH_MAC_ADDRESS}
    Restart=on-failure
    
    [Install]
    WantedBy=bluetooth.target
    Then:
    Code:
    $ sudo systemctl enable bluetooth-addr.service
    $ sudo systemctl start bluetooth-addr.service
    Quote Originally Posted by harryharryharry View Post
    @joshua123456 Hmm, looks like a config issue then, since otherwise anyone without a micro hdmi (like myself) should experience no audio on boot. Maybe try standard 'audio doesn't work' debugging steps like looking at aplay/dmesg outputs etc. while no audio devices are found, or see if the issue also occurs when booting a live usb (I’ve uploaded a some isos with my 5.3.7 kernel here, which you could use to test). As a last resort, you could consider a clean install.

    @diegoandre That's strange, blacklisting snd_hdmi_lpe_audio in grub on a xubuntu live usb with my kernel fixes audio for me, so there must be something else going on with you setup…

    @akashp21 I see the same bluetooth issue you describe (on v42 only). I looked into it and the bug appears to be introduced in 5.0.20, due to this commit.

    (Feel free to skip to the TL;DR if you don’t care about the background. The next part is partly intended as a memory aid )
    If I understand the commit message correctly this is 'not a bug, but a feature' in that our bluetooth card gets assigned a default macaddress (43:34:1B:00:1F:AC, 43341B being part of our bluetooth chip's name) which obviously causes problems when 2 such devices with identical addresses try to communicate with eachother.
    The commit was merged to let the kernel block usage of this default macaddress to prevent these kinds of communications issues. I’ve tried to do as the message instructs and change the macaddress but sadly the tools (btmgmt/bdaddr) that can do this aren’t part of (at least) Fedora’s package repository. This would mean people would have to compile their own software to get bluetooth working. Because the sole goal of my kernel was to make linux easier to use on the x205ta, this doesn’t seem like an option.
    I might create a kernel bugtracker for this issue later on (on the other hand, if reverting this commit makes bluetooth work; it seems rather pointless): I found out that the default macaddress only gets assigned when /lib/firmware/brcm/BCM43341B0.hcd is present, without this file dmesg complains about firmware not being found; but the bluetooth chip gets initialized anyway, WITH a seemingly valid macaddress. Bluetooth managers fail to find any devices though.

    TL;DR: This is why I've 'semi-temporarily' reversed the problem-introducing commit and made a new (5.3.7 v43) build. This should make bluetooth work again.
    (you can disable the btattach service, the command hasn't been necessary for a while
    )
    Last edited by yau-albert; March 2nd, 2021 at 07:45 AM.

  9. #2169
    Join Date
    Jun 2015
    Beans
    4

    Re: Asus X205TA hardware support in Ubuntu

    Is there anybody who gets the headphones working? This was working for me with harry's kernel in the past, but can't get it to work now.

    I tried:
    - Kernel 5.10.x
    - Kernel 5.4.x (LTS)
    - Kernel 4.19.x (LTS) -> no wifi with this kernel

    All without succes

  10. #2170
    Join Date
    Feb 2021
    Beans
    7

    Re: Asus X205TA hardware support in Ubuntu

    Hi RObin,

    In my case I get them to work just adding a file and a line of code

    Sound

    There has recently been some success in getting the x205ta's Realtek RT5648 sound card working, including microphone support. The relevant patches are in Linux release 4.11 and later. Updated Alsa-lib's UCM files are available in alsa-lib-x205taAUR.
    In order to have working headphone jack (as of kernel 4.14) is it required to add an "options" line in any modprobe file
    /etc/modprobe.d/50-x205ta.conf options snd_soc_rt5645 quirk=0x31


    Tested with manjaro kernel 5.9.16-1 and with linux Mx kernel 4.somethig

Page 217 of 218 FirstFirst ... 117167207215216217218 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •