Results 1 to 10 of 10

Thread: 3.18-rc6

  1. #1
    Join Date
    Oct 2008
    Location
    ExodusHair<Čubura
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

  2. #2
    Join Date
    Aug 2013
    Beans
    39

    Re: 3.18-rc6

    There seems to be a regression since RC4 that causes "lock-ups". Kernel bisection is ongoing.

    http://lkml.iu.edu/hypermail/linux/k...1.2/05503.html

  3. #3
    Join Date
    Feb 2011
    Location
    Coquitlam, B.C. Canada
    Beans
    3,041
    Distro
    Ubuntu Development Release

    Re: 3.18-rc6

    I never did get around to trying 3.18RC5. Kernel 3.18RC6 seems to be working fine for me, but I haven't done much with it yet.
    Any follow-up information on your issue would be appreciated. Please have the courtesy to report back.

  4. #4
    Join Date
    Feb 2011
    Location
    Coquitlam, B.C. Canada
    Beans
    3,041
    Distro
    Ubuntu Development Release

    Re: 3.18-rc6

    It seems I can no longer change the scheduler or view which one I m currently using. Does anybody know when this changed?
    Example from my older 12.04 server:
    Code:
    doug@doug-64:~$ uname -a
    Linux doug-64 3.2.0-70-generic #105-Ubuntu SMP Wed Sep 24 19:49:16 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
    doug@doug-64:~$ cat /sys/block/sda/queue/scheduler
    noop deadline [cfq]
    Example from my test server running 14.04:
    Code:
    doug@s15:~/temp2$ uname -a
    Linux s15 3.13.0-40-generic #69-Ubuntu SMP Thu Nov 13 17:53:56 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
    doug@s15:~/temp2$ cat /sys/block/sda/queue/scheduler
    noop [deadline] cfq
    Example from my test server running 14.04 and kernel 3.18RC6:
    Code:
    doug@s15:~$ uname -a
    Linux s15 3.18.0-031800rc6-generic #201411231935 SMP Mon Nov 24 00:36:20 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
    doug@s15:~$ cat /sys/block/sda/queue/scheduler
    none      <<< Huh?
    As yet I haven't been able to figure out a kernel config file difference reason. These are the same in both:
    Code:
    # IO Schedulers
    CONFIG_IOSCHED_NOOP=y
    CONFIG_IOSCHED_DEADLINE=y
    CONFIG_IOSCHED_CFQ=y
    CONFIG_CFQ_GROUP_IOSCHED=y
    CONFIG_DEFAULT_IOSCHED="deadline"
    Edit 1: I have it narrowed down to being introduced between 3.18RC1 and 3.18RC2. Recall all the excitement with 3.18RC2, perhaps this is another issue.
    Edit 2: Back on 3.18RC2, one test I did was:
    Kernel 3.18RC2 Kernel.org version.
    . Compiled using the Ubuntu config file from kernel 3.18RC1, and accepting defaults for new stuff.
    . Boots fine. Seems to run fine, but haven't done much yet.
    That kernel works fine in terms of showing and allowing me to change the scheduler:
    Code:
    doug@s15:~$ uname -a
    Linux s15 3.18.0-rc2-250 #167 SMP Mon Oct 27 21:46:56 PDT 2014 x86_64 x86_64 x86_64 GNU/Linux
    doug@s15:~$ cat /sys/block/sda/queue/scheduler
    noop [deadline] cfq
    I will now pick away at the config file changes in an attempt to isolate the one that gives the issue.
    Last edited by Doug S; November 27th, 2014 at 12:53 AM.
    Any follow-up information on your issue would be appreciated. Please have the courtesy to report back.

  5. #5
    Join Date
    Jan 2007
    Location
    Connecticut
    Beans
    1,649
    Distro
    Ubuntu Development Release

    Re: 3.18-rc6

    compiled my own, if that makes any difference....but seems to work here:

    Code:
    ~$ uname -a
    Linux GA-990FXA-UD5 3.18.0-rc6-foomans-custom-kernel #1 SMP Mon Nov 24 06:50:37 EST 2014 x86_64 x86_64 x86_64 GNU/Linux
    
    ~$ cat /sys/block/sda/queue/scheduler
    noop [deadline] cfq




  6. #6
    Join Date
    Feb 2011
    Location
    Coquitlam, B.C. Canada
    Beans
    3,041
    Distro
    Ubuntu Development Release

    Re: 3.18-rc6

    The difference seems to be:
    Code:
    doug@s15:~/temp-k-git-3.10rc4/linux$ diff .config_3.18rc6_cfg04 .config_3.18rc6_250
    1995c1995
    < # CONFIG_SCSI_MQ_DEFAULT is not set
    ---
    > CONFIG_SCSI_MQ_DEFAULT=y
    @fooman: can you confirm or deny that your kernel config file contains:
    Code:
    # CONFIG_SCSI_MQ_DEFAULT is not set
    Any follow-up information on your issue would be appreciated. Please have the courtesy to report back.

  7. #7
    Join Date
    Jan 2007
    Location
    Connecticut
    Beans
    1,649
    Distro
    Ubuntu Development Release

    Re: 3.18-rc6

    Quote Originally Posted by Doug S View Post
    The difference seems to be:
    Code:
    doug@s15:~/temp-k-git-3.10rc4/linux$ diff .config_3.18rc6_cfg04 .config_3.18rc6_250
    1995c1995
    < # CONFIG_SCSI_MQ_DEFAULT is not set
    ---
    > CONFIG_SCSI_MQ_DEFAULT=y
    @fooman: can you confirm or deny that your kernel config file contains:
    Code:
    # CONFIG_SCSI_MQ_DEFAULT is not set
    confirmed Doug...it does indeed.

    Code:
    #
    # SCSI device support
    #
    CONFIG_SCSI_MOD=y
    # CONFIG_RAID_ATTRS is not set
    CONFIG_SCSI=y
    CONFIG_SCSI_DMA=y
    # CONFIG_SCSI_NETLINK is not set
    # CONFIG_SCSI_MQ_DEFAULT is not set
    CONFIG_SCSI_PROC_FS=y




  8. #8
    Join Date
    Feb 2011
    Location
    Coquitlam, B.C. Canada
    Beans
    3,041
    Distro
    Ubuntu Development Release

    Re: 3.18-rc6

    The kernel configuration parameter, CONFIG_SCSI_MQ_DEFAULT, will be put back to "is not set" in the next upload. Reference.
    Any follow-up information on your issue would be appreciated. Please have the courtesy to report back.

  9. #9
    Join Date
    Oct 2008
    Location
    ExodusHair<Čubura
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: 3.18-rc6

    Code:
    elevator=cfq
    should work in kernel boot-line.
    Update₁: No, it does not, even though I thought it would. Tested on 999 & 994.
    Upsate₂: It works now, both in 999 and in 994. Both from kernel boot line and afterwards from CLI.
    Last edited by zika; November 29th, 2014 at 08:28 AM.

  10. #10
    Join Date
    Feb 2011
    Location
    Coquitlam, B.C. Canada
    Beans
    3,041
    Distro
    Ubuntu Development Release

    Re: 3.18-rc6

    Quote Originally Posted by zika View Post
    Code:
    elevator=cfq
    should work in kernel boot-line.
    Update₁: No, it does not, even though I thought it would. Tested on 999 & 994.
    Upsate₂: It works now, both in 999 and in 994. Both from kernel boot line and afterwards from CLI.
    I see that the daily build has the config file difference(s) added:
    Code:
    doug@s15:~/temp-k-git-3.10rc4/linux$ diff .config-3.18.0-031800rc6-generic .config-3.18.0-999-generic
    3c3
    < # Linux/x86_64 3.18.0-031800rc6-generic Kernel Configuration
    ---
    > # Linux/x86_64 3.18.0-999-generic Kernel Configuration
    1995c1995
    < CONFIG_SCSI_MQ_DEFAULT=y
    ---
    > # CONFIG_SCSI_MQ_DEFAULT is not set
    7039c7039
    < # CONFIG_OVERLAY_FS is not set
    ---
    > CONFIG_OVERLAY_FS=m
    Users with significant system load should not use Ubuntu Kernels 3.18RC2 - 3.18RC6, as things tend to fall apart when the load is high enough that IO scheduling is required. Why? Because there isn't any IO scheduler. At least if you are experiencing oddities and system lag under high loads, this is a possible explanation. For example, I had a simple "ls -l" command that didn't complete in over 1/2 an hour (I had extreme disk IO load going from several tasks at the time). Anyway, 3.18RC7 should be out in a day or two.
    Any follow-up information on your issue would be appreciated. Please have the courtesy to report back.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •