Page 10 of 12 FirstFirst ... 89101112 LastLast
Results 91 to 100 of 118

Thread: HOWTO: Apple Wireless Keyboard (Bluetooth)

  1. #91
    Join Date
    May 2005
    Location
    Asia
    Beans
    248
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: HOWTO: Apple Wireless Keyboard (Bluetooth)

    My Apple bluetooth keyboard is up and working in Lucid thanks to this thread (and the great Ubuntu developers.)
    Just follow previous post instructions

  2. #92
    Join Date
    May 2009
    Location
    Kansas, USA
    Beans
    66
    Distro
    Ubuntu Studio 12.10 Quantal Quetzal

    Re: HOWTO: Apple Wireless Keyboard (Bluetooth)

    I'm so glad all you people can read whatever directions and get this thing working. I've not been able to get my computer to recognize my keyboard at all. NOW I can't get the bluetooth services to come back on so I can use my mouse again.

    What do I need to do to get bluetooth re enabled again?

    Can someone rewrite this thread for v9.10?


    Ok, this is annoying me. Now I've lost the mouse again, and never can get the computer to pair with the computer.

    I've reinstalled Ubuntu 10.04 from a live CD and everything is working out of the box. I find it odd, but hell it's working. Even the mouse is working. Now if I could assume I could close my Mac's lid, and just run off the external monitor, I might start switching more.
    Last edited by untmdsprt; May 20th, 2010 at 11:05 AM.

  3. #93
    Join Date
    May 2005
    Location
    Asia
    Beans
    248
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: HOWTO: Apple Wireless Keyboard (Bluetooth)

    Keep the faith.
    Desktop
    Just add: add "hid_apple" in /etc/modules.conf
    as mentioned.
    I'm using Gnome Bluetooth manager. (not Blueman)
    Go through it's configuration. (setup new device)
    9.10 same as 10.04 setup.

  4. #94
    Join Date
    Mar 2009
    Beans
    7

    Re: HOWTO: Apple Wireless Keyboard (Bluetooth)

    Quote Originally Posted by vickoxy View Post
    Be careful, you have to repeat connecting procedure at least 2 times to actually connect keyboard to computer. After that it should work...
    I'm not sure if you're referring to the same problem I have. Actually it's more of a minor annoyance than a problem.

    After upgrading to Lucid I find that at the login screen when I turn my keyboard on I cannot get a connection. I have to turn the keyboard off and then on again to get it to work. Seems slightly strange why it only connects on the 2nd attempt!

  5. #95
    Join Date
    May 2005
    Location
    Asia
    Beans
    248
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: HOWTO: Apple Wireless Keyboard (Bluetooth)

    Quote Originally Posted by Gemba View Post
    After upgrading to Lucid I find that at the login screen when I turn my keyboard on I cannot get a connection. I have to turn the keyboard off and then on again to get it to work.
    Mine works on Lucid with no such issue. When I arrive at the login screen the keyboard is ready to go. No power cycling on/off hassle.

  6. #96
    Join Date
    Dec 2008
    Beans
    1

    Re: HOWTO: Apple Wireless Keyboard (Bluetooth)

    Quote Originally Posted by Gemba View Post
    After upgrading to Lucid I find that at the login screen when I turn my keyboard on I cannot get a connection. I have to turn the keyboard off and then on again to get it to work. Seems slightly strange why it only connects on the 2nd attempt!
    I have the same problem here...very strange...
    Anyone an idea what could cause this problem?

    Thanks a lot for any input...

    DoubleX

  7. #97
    Join Date
    May 2005
    Location
    Asia
    Beans
    248
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: HOWTO: Apple Wireless Keyboard (Bluetooth)

    Not sure if this will help.

    Clean install of 10.04 (64 bit)

    Gnome Bluetooth manager

    My Keyboard is latest model with (2 batteries).

    At login screen there is a slight 1-2 second lag with indicator light showing progress.

    $ lsusb
    Bus 002 Device 002: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)

    Follow other thread config instructions

  8. #98
    Join Date
    Sep 2010
    Beans
    1

    Re: HOWTO: Apple Wireless Keyboard (Bluetooth)

    Just solved a nasty bug with the Apple Wireless Keyboard (Bluetooth): It works to log-in, but after log-in it shows very strange behaviour: Most keys do not work and only some few keys on the right side produce numbers.

    Reason: Numlock is switched on after log-in which disables most keys and some alpahnumeric keys get numeric (even if the keyboard does not have a numpad).

    Solution: Press fn-F6 twice to disable numlock. To switch numlock off permanently after log-in go to System -> Preferences -> Keyboard -> Layout -> Layout Options -> Miscellaneous compatibility options -> turn on "Default numeric keypad keys"

    This setting takes effect after logging in and does not affect the graphical login screen or local consoles.

  9. #99
    Join Date
    Jul 2007
    Beans
    36

    Re: HOWTO: Apple Wireless Keyboard (Bluetooth)

    After fresh install of Ubuntu 10.04 64-Bit I can use the default gnome blue-tooth manager to pair with my apple wireless keyboard. I successfully enter in the PIN with the Apple keyboard and press enter and it reports that it paired successfully. However when i go to use the keyboard after that nothing happens when i press any of the keys.

    Am i missing something here? of course i also tried that hid_apple trick but that didn't do anything and several reboots and repairing don't do anything either.

    It's strange to me that i can type in the PIN with the Apple wireless keyboard during the pair and then immediately after i can't type any numbers/letters in a text document.

    Help please

  10. #100
    Join Date
    Jul 2007
    Beans
    36

    Re: HOWTO: Apple Wireless Keyboard (Bluetooth)

    ok I went over the entire posting again trying everything once more with SOME SUCCESS.

    I installed BLUEMAN and after i open up BLUEMAN and right click on my device and choose "Input Service" twice in a row very quickly it says "connecting" and is followed by "success" with a nicely working keyboard that i am typing on right now.

    However when i reboot i have to manually right click on "input services" twice in a row quickly before my keyboard will work again

    I have tried everything in this posting so far but nothing seems to do anything more.

Page 10 of 12 FirstFirst ... 89101112 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •