Page 1 of 6 123 ... LastLast
Results 1 to 10 of 54

Thread: RTL8723BE wifi dropping connection on Ubuntu 14.04

  1. #1
    Join Date
    Sep 2014
    Location
    Rybnik, Poland
    Beans
    13
    Distro
    Ubuntu 15.10 Wily Werewolf

    RTL8723BE wifi dropping connection on Ubuntu 14.04

    Hi. Just like i wrote in the title my wifi connection keeps dropping, but let me tell you the whole story.
    After 14.04.1 installation on my Lenovo G50-30 laptop, wifi was hardware blocked, but i've made it work by:
    Code:
    sudo modprobe -r ideapad-laptop
    sudo rfkill unblock all
    and the wifi was on. But when connection is dorpped I can't re-connect. I have to reboot to get my wifi work, but after some time i lose connection again.

    I download and ran wireless-script and these are the results:
    Code:
    ########## wireless info START ##########
    
    
    Report from: 12 Sep 2014 18:05 CEST +0200
    
    
    Script from: 05 Sep 2014 22:42 UTC +0000
    
    
    ##### release #####
    
    
    Distributor ID:    Ubuntu
    Description:    Ubuntu 14.04.1 LTS
    Release:    14.04
    Codename:    trusty
    
    
    ##### kernel #####
    
    
    Linux 3.13.0-35-generic #62-Ubuntu SMP Fri Aug 15 01:58:01 UTC 2014 i686 i686 i686 GNU/Linux
    
    
    Parameters: ro, quiet, splash, vt.handoff=7
    
    
    ##### desktop #####
    
    
    Ubuntu
    
    
    ##### lspci #####
    
    
    02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter [10ec:b723]
        Subsystem: Lenovo Device [17aa:b736]
        Kernel driver in use: rtl8723be
    
    
    03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 10)
        Subsystem: Lenovo Device [17aa:3816]
        Kernel driver in use: r8169
    
    
    ##### lsusb #####
    
    
    Bus 001 Device 006: ID 0bda:b728 Realtek Semiconductor Corp. 
    Bus 001 Device 005: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
    Bus 001 Device 004: ID 5986:0652 Acer, Inc 
    Bus 001 Device 003: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
    Bus 001 Device 002: ID 8087:07e6 Intel Corp. 
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    
    
    ##### PCMCIA card info #####
    
    
    ##### rfkill #####
    
    
    2: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
    3: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
    
    
    ##### lsmod #####
    
    
    rtl8723be              75735  0 
    btcoexist              49432  1 rtl8723be
    rtl8723_common         22417  1 rtl8723be
    rtl_pci                26314  1 rtl8723be
    rtlwifi                52835  2 rtl_pci,rtl8723be
    mac80211              546051  3 rtl_pci,rtlwifi,rtl8723be
    cfg80211              409394  2 mac80211,rtlwifi
    
    
    ##### interfaces #####
    
    
    auto lo
    iface lo inet loopback
    
    
    ##### ifconfig #####
    
    
    eth0      Link encap:Ethernet  HWaddr <MAC addr eth0>  
              inet addr:192.168.0.100  Bcast:192.168.0.255  Mask:255.255.255.0
              inet6 addr: fe80::2ad2:44ff:fe98:585b/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:13539 errors:0 dropped:0 overruns:0 frame:0
              TX packets:12056 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:8628678 (8.6 MB)  TX bytes:2451401 (2.4 MB)
    
    
    wlan0     Link encap:Ethernet  HWaddr <MAC addr wlan0>  
              inet6 addr: fe80::9248:9aff:fe1b:113d/64 Scope:Link
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:20263 errors:0 dropped:0 overruns:0 frame:0
              TX packets:10941 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:28213348 (28.2 MB)  TX bytes:1158074 (1.1 MB)
    
    
    ##### iwconfig #####
    
    
    lo        no wireless extensions.
    
    
    eth0      no wireless extensions.
    
    
    wlan0     IEEE 802.11bgn  ESSID:off/any  
              Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
              Retry  long limit:7   RTS thr=2347 B   Fragment thr:off
              Power Management:off
              
    
    
    ##### route #####
    
    
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    0.0.0.0         192.168.0.1     0.0.0.0         UG    0      0        0 eth0
    192.168.0.0     0.0.0.0         255.255.255.0   U     1      0        0 eth0
    
    
    ##### resolv.conf #####
    
    
    nameserver 127.0.1.1
    
    
    ##### nm-tool #####
    
    
    NetworkManager Tool
    
    
    State: connected (global)
    
    
    - Device: eth0  [Połączenie przewodowe 1] ------------------------------------
      Type:              Wired
      Driver:            r8169
      State:             connected
      Default:           yes
      HW Address:        <MAC addr eth0>
    
    
      Capabilities:
        Carrier Detect:  yes
        Speed:           100 Mb/s
    
    
      Wired Properties
        Carrier:         on
    
    
      IPv4 Settings:
        Address:         192.168.0.100
        Prefix:          24 (255.255.255.0)
        Gateway:         192.168.0.1
    
    
        DNS:             78.31.136.10
        DNS:             79.124.106.1
    
    
    - Device: wlan0 ----------------------------------------------------------------
      Type:              802.11 WiFi
      Driver:            rtl8723be
      State:             disconnected
      Default:           no
      HW Address:        <MAC addr wlan0>
    
    
      Capabilities:
    
    
      Wireless Properties
        WEP Encryption:  yes
        WPA Encryption:  yes
        WPA2 Encryption: yes
    
    
      Wireless Access Points 
        NETIASPOT-665F10:Infra, <MAC addr NETIASPOT-665F10>, Freq 2467 MHz, Rate 54 Mb/s, Strength 34 WPA WPA2
        FON_NETIA_FREE_INTERNET: Infra, <MAC addr FON_NETIA_FREE_INTERNET>, Freq 2467 MHz, Rate 54 Mb/s, Strength 34
        TP-LINK_EF5808:  Infra, <MAC addr TP-LINK_EF5808>, Freq 2437 MHz, Rate 54 Mb/s, Strength 34 WPA WPA2
        pawe3:           Infra, <MAC addr pawe3>, Freq 2437 MHz, Rate 54 Mb/s, Strength 78 WPA2
        dlink:           Infra, <MAC addr dlink>, Freq 2412 MHz, Rate 54 Mb/s, Strength 34 WPA2
    
    
    ##### NetworkManager.state #####
    
    
    [main]
    NetworkingEnabled=true
    WirelessEnabled=true
    WWANEnabled=true
    WimaxEnabled=true
    
    
    ##### NetworkManager.conf #####
    
    
    [main]
    plugins=ifupdown,keyfile,ofono
    dns=dnsmasq
    
    
    [ifupdown]
    managed=false
    
    
    ##### iw reg get #####
    
    
    country 00:
        (2402 - 2472 @ 40), (3, 20)
        (2457 - 2482 @ 40), (3, 20), PASSIVE-SCAN, NO-IBSS
        (2474 - 2494 @ 20), (3, 20), NO-OFDM, PASSIVE-SCAN, NO-IBSS
        (5170 - 5250 @ 40), (3, 20), PASSIVE-SCAN, NO-IBSS
        (5735 - 5835 @ 40), (3, 20), PASSIVE-SCAN, NO-IBSS
    
    
    ##### iwlist channels #####
    
    
    lo        no frequency information.
    
    
    eth0      no frequency information.
    
    
    wlan0     13 channels in total; available frequencies :
              Channel 01 : 2.412 GHz
              Channel 02 : 2.417 GHz
              Channel 03 : 2.422 GHz
              Channel 04 : 2.427 GHz
              Channel 05 : 2.432 GHz
              Channel 06 : 2.437 GHz
              Channel 07 : 2.442 GHz
              Channel 08 : 2.447 GHz
              Channel 09 : 2.452 GHz
              Channel 10 : 2.457 GHz
              Channel 11 : 2.462 GHz
              Channel 12 : 2.467 GHz
              Channel 13 : 2.472 GHz
    
    
    ##### iwlist scan #####
    
    
    Channel occupancy:
    
    
         1   WLAPs on   Frequency:2.412 GHz (Channel 1)
         2   WLAPs on   Frequency:2.437 GHz (Channel 6)
         2   WLAPs on   Frequency:2.467 GHz (Channel 12)
    
    
    wlan0     Scan completed :
              Cell 01 - Address: <MAC addr FON_NETIA_FREE_INTERNET>
                        Channel:12
                        Frequency:2.467 GHz (Channel 12)
                        Quality=42/70  Signal level=-68 dBm  
                        Encryption key:off
                        ESSID:"FON_NETIA_FREE_INTERNET"
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s
                        Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
                                  36 Mb/s; 48 Mb/s; 54 Mb/s
                        Mode:Master
                        Extra:tsf=00000000d79a1001
                        Extra: Last beacon: 104ms ago
              Cell 02 - Address: <MAC addr NETIASPOT-665F10>
                        Channel:12
                        Frequency:2.467 GHz (Channel 12)
                        Quality=42/70  Signal level=-68 dBm  
                        Encryption key:on
                        ESSID:"NETIASPOT-665F10"
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s
                        Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
                                  36 Mb/s; 48 Mb/s; 54 Mb/s
                        Mode:Master
                        Extra:tsf=00000000d79ba007
                        Extra: Last beacon: 40ms ago
                        IE: IEEE 802.11i/WPA2 Version 1
                            Group Cipher : TKIP
                            Pairwise Ciphers (2) : CCMP TKIP
                            Authentication Suites (1) : PSK
                        IE: WPA Version 1
                            Group Cipher : TKIP
                            Pairwise Ciphers (2) : CCMP TKIP
                            Authentication Suites (1) : PSK
              Cell 03 - Address: <MAC addr pawe3>
                        Channel:6
                        Frequency:2.437 GHz (Channel 6)
                        Quality=70/70  Signal level=-26 dBm  
                        Encryption key:on
                        ESSID:"pawe3"
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 9 Mb/s
                                  18 Mb/s; 36 Mb/s; 54 Mb/s
                        Bit Rates:6 Mb/s; 12 Mb/s; 24 Mb/s; 48 Mb/s
                        Mode:Master
                        Extra:tsf=00000000d90da165
                        Extra: Last beacon: 440ms ago
                        IE: IEEE 802.11i/WPA2 Version 1
                            Group Cipher : CCMP
                            Pairwise Ciphers (1) : CCMP
                            Authentication Suites (1) : PSK
              Cell 04 - Address: <MAC addr dlink>
                        Channel:1
                        Frequency:2.412 GHz (Channel 1)
                        Quality=30/70  Signal level=-80 dBm  
                        Encryption key:on
                        ESSID:"dlink"
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 9 Mb/s
                                  18 Mb/s; 36 Mb/s; 54 Mb/s
                        Bit Rates:6 Mb/s; 12 Mb/s; 24 Mb/s; 48 Mb/s
                        Mode:Master
                        Extra:tsf=00000000d772b15c
                        Extra: Last beacon: 16088ms ago
                        IE: IEEE 802.11i/WPA2 Version 1
                            Group Cipher : TKIP
                            Pairwise Ciphers (2) : TKIP CCMP
                            Authentication Suites (1) : PSK
              Cell 05 - Address: <MAC addr TP-LINK_EF5808>
                        Channel:6
                        Frequency:2.437 GHz (Channel 6)
                        Quality=22/70  Signal level=-88 dBm  
                        Encryption key:on
                        ESSID:"TP-LINK_EF5808"
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                                  12 Mb/s; 24 Mb/s; 36 Mb/s
                        Bit Rates:9 Mb/s; 18 Mb/s; 48 Mb/s; 54 Mb/s
                        Mode:Master
                        Extra:tsf=00000000d91571e9
                        Extra: Last beacon: 3056ms ago
                        IE: IEEE 802.11i/WPA2 Version 1
                            Group Cipher : TKIP
                            Pairwise lo        Interface doesn't support scanning.
    
    
    eth0      Interface doesn't support scanning.
    
    
    Ciphers (2) : TKIP CCMP
                            Authentication Suites (1) : PSK
                           Preauthentication Supported
                        IE: WPA Version 1
                            Group Cipher : TKIP
                            Pairwise Ciphers (2) : TKIP CCMP
                            Authentication Suites (1) : PSK
    
    
    ##### module infos #####
    
    
    [rtl8723be]
    filename:       /lib/modules/3.13.0-35-generic/kernel/drivers/net/wireless/rtlwifi/rtl8723be/rtl8723be.ko
    firmware:       rtlwifi/rtl8723befw.bin
    description:    Realtek 8723BE 802.11n PCI wireless
    license:        GPL
    author:         Realtek WlanFAE    <wlanfae@realtek.com>
    author:         PageHe    <page_he@realsil.com.cn>
    srcversion:     0D59E0301AAA6E5A93400BB
    depends:        rtlwifi,rtl8723-common,rtl_pci,btcoexist,mac80211
    intree:         Y
    vermagic:       3.13.0-35-generic SMP mod_unload modversions 686 
    signer:         Magrathea: Glacier signing key
    sig_key:        A2:8D:B5:FD:6E:29:9C:CE:49:47:DA:CA:A6:6F:45:9D:B4:AC:CE:24
    sig_hashalgo:   sha512
    parm:           swlps:bool
    parm:           swenc:using hardware crypto (default 0 [hardware])
     (bool)
    parm:           ips:using no link power save (default 1 is open)
     (bool)
    parm:           fwlps:using linked fw control power save (default 1 is open)
     (bool)
    parm:           msi:Set to 1 to use MSI interrupts mode (default 0)
     (bool)
    parm:           debug:Set debug level (0-5) (default 0) (int)
    
    
    [rtl8723_common]
    filename:       /lib/modules/3.13.0-35-generic/kernel/drivers/net/wireless/rtlwifi/rtl8723com/rtl8723-common.ko
    description:    Realtek RTL8723AE/RTL8723BE 802.11n PCI wireless common routines
    license:        GPL
    author:         Larry Finger    <Larry.Finger@lwfinger.net>
    author:         Realtek WlanFAE    <wlanfae@realtek.com>
    srcversion:     D1807280DBDC9B8A7EBDAB7
    depends:        
    intree:         Y
    vermagic:       3.13.0-35-generic SMP mod_unload modversions 686 
    signer:         Magrathea: Glacier signing key
    sig_key:        A2:8D:B5:FD:6E:29:9C:CE:49:47:DA:CA:A6:6F:45:9D:B4:AC:CE:24
    sig_hashalgo:   sha512
    
    
    [rtl_pci]
    filename:       /lib/modules/3.13.0-35-generic/kernel/drivers/net/wireless/rtlwifi/rtl_pci.ko
    description:    PCI basic driver for rtlwifi
    license:        GPL
    author:         Larry Finger    <Larry.FInger@lwfinger.net>
    author:         Realtek WlanFAE    <wlanfae@realtek.com>
    author:         lizhaoming    <chaoming_li@realsil.com.cn>
    srcversion:     D5E4890DC428FA5A1BF92DF
    depends:        mac80211,rtlwifi
    intree:         Y
    vermagic:       3.13.0-35-generic SMP mod_unload modversions 686 
    signer:         Magrathea: Glacier signing key
    sig_key:        A2:8D:B5:FD:6E:29:9C:CE:49:47:DA:CA:A6:6F:45:9D:B4:AC:CE:24
    sig_hashalgo:   sha512
    
    
    [rtlwifi]
    filename:       /lib/modules/3.13.0-35-generic/kernel/drivers/net/wireless/rtlwifi/rtlwifi.ko
    description:    Realtek 802.11n PCI wireless core
    license:        GPL
    author:         Larry Finger    <Larry.FInger@lwfinger.net>
    author:         Realtek WlanFAE    <wlanfae@realtek.com>
    author:         lizhaoming    <chaoming_li@realsil.com.cn>
    srcversion:     E1F4663325225EE8DBA54CA
    depends:        mac80211,cfg80211
    intree:         Y
    vermagic:       3.13.0-35-generic SMP mod_unload modversions 686 
    signer:         Magrathea: Glacier signing key
    sig_key:        A2:8D:B5:FD:6E:29:9C:CE:49:47:DA:CA:A6:6F:45:9D:B4:AC:CE:24
    sig_hashalgo:   sha512
    
    
    ##### module parameters #####
    
    
    [rtl8723be]
    debug: 0
    fwlps: Y
    ips: Y
    msi: N
    swenc: N
    swlps: N
    
    
    ##### /etc/modules #####
    
    
    lp
    
    
    ##### blacklists #####
    
    
    [/etc/modprobe.d/blacklist-ath_pci.conf]
    blacklist ath_pci
    
    
    [/etc/modprobe.d/blacklist.conf]
    blacklist evbug
    blacklist usbmouse
    blacklist usbkbd
    blacklist eepro100
    blacklist de4x5
    blacklist eth1394
    blacklist snd_intel8x0m
    blacklist snd_aw2
    blacklist i2c_i801
    blacklist prism54
    blacklist bcm43xx
    blacklist garmin_gps
    blacklist asus_acpi
    blacklist snd_pcsp
    blacklist pcspkr
    blacklist amd76x_edac
    
    
    ##### rc.local #####
    
    
    exit 0
    
    
    ##### udev rules #####
    
    
    [/etc/udev/rules.d/70-persistent-net.rules]
    # PCI device 0x10ec:0x8168 (r8169)
    SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC addr eth0>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
    # PCI device 0x10ec:0xb723 (rtl8723be)
    SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC addr wlan0>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"
    
    
    ##### dmesg #####
    
    
    [   13.677060] rtl8723be: Using firmware rtlwifi/rtl8723befw.bin
    [   13.917015] ieee80211 phy0: Selected rate control algorithm 'rtl_rc'
    [   13.917362] rtlwifi: wireless switch is on
    [   15.810781] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready (repeated 2 times)
    [  849.896156] wlan0: authenticate with <MAC addr pawe3>
    [  849.916156] wlan0: send auth to <MAC addr pawe3> (try 1/3)
    [  849.917691] wlan0: authenticated
    [  849.919081] wlan0: associate with <MAC addr pawe3> (try 1/3)
    [  849.922575] wlan0: RX AssocResp from <MAC addr pawe3> (capab=0x411 status=0 aid=1)
    [  849.922764] wlan0: associated
    [  849.922777] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
    [ 1108.124011] wlan0: deauthenticating from <MAC addr pawe3> by local choice (reason=3)
    [ 1133.053540] wlan0: authenticate with <MAC addr pawe3>
    [ 1137.876454] wlan0: send auth to <MAC addr pawe3> (try 1/3)
    [ 1137.878912] wlan0: authenticated
    [ 1137.882259] wlan0: associate with <MAC addr pawe3> (try 1/3)
    [ 1139.051752] wlan0: associate with <MAC addr pawe3> (try 2/3)
    [ 1140.065084] wlan0: associate with <MAC addr pawe3> (try 3/3)
    [ 1141.066398] wlan0: association with <MAC addr pawe3> timed out
    [ 1145.900781] wlan0: deauthenticating from <MAC addr pawe3> by local choice (reason=3)
    [ 1156.454616] wlan0: authenticate with <MAC addr pawe3>
    [ 1161.275158] wlan0: direct probe to <MAC addr pawe3> (try 1/3)
    [ 1161.275517] wlan0: deauthenticating from <MAC addr pawe3> by local choice (reason=3)
    [ 1191.843256] wlan0: authenticate with <MAC addr pawe3>
    [ 1196.665626] wlan0: direct probe to <MAC addr pawe3> (try 1/3)
    [ 1196.867637] wlan0: direct probe to <MAC addr pawe3> (try 2/3)
    [ 1197.071947] wlan0: direct probe to <MAC addr pawe3> (try 3/3)
    [ 1197.276172] wlan0: authentication with <MAC addr pawe3> timed out
    [ 1202.110593] wlan0: deauthenticating from <MAC addr pawe3> by local choice (reason=3)
    [ 1213.061628] wlan0: authenticate with <MAC addr pawe3>
    [ 1217.885472] wlan0: direct probe to <MAC addr pawe3> (try 1/3)
    [ 1217.886256] wlan0: deauthenticating from <MAC addr pawe3> by local choice (reason=3)
    [ 1233.156099] wlan0: authenticate with <MAC addr pawe3>
    [ 1237.984260] wlan0: direct probe to <MAC addr pawe3> (try 1/3)
    [ 1238.185850] wlan0: direct probe to <MAC addr pawe3> (try 2/3)
    [ 1238.390176] wlan0: direct probe to <MAC addr pawe3> (try 3/3)
    [ 1238.594405] wlan0: authentication with <MAC addr pawe3> timed out
    [ 1243.420828] wlan0: deauthenticating from <MAC addr pawe3> by local choice (reason=3)
    [ 1254.868619] wlan0: authenticate with <MAC addr pawe3>
    [ 1259.696326] wlan0: direct probe to <MAC addr pawe3> (try 1/3)
    [ 1259.697590] wlan0: deauthenticating from <MAC addr pawe3> by local choice (reason=3)
    [ 1274.962984] wlan0: authenticate with <MAC addr pawe3>
    [ 1279.786775] wlan0: direct probe to <MAC addr pawe3> (try 1/3)
    [ 1279.988706] wlan0: direct probe to <MAC addr pawe3> (try 2/3)
    [ 1280.193038] wlan0: direct probe to <MAC addr pawe3> (try 3/3)
    [ 1280.397251] wlan0: authentication with <MAC addr pawe3> timed out
    [ 1285.227661] wlan0: deauthenticating from <MAC addr pawe3> by local choice (reason=3)
    [ 1302.324682] wlan0: authenticate with <MAC addr pawe3>
    [ 1305.520477] wlan0: direct probe to <MAC addr pawe3> (try 1/3)
    [ 1305.722479] wlan0: direct probe to <MAC addr pawe3> (try 2/3)
    [ 1305.926745] wlan0: direct probe to <MAC addr pawe3> (try 3/3)
    [ 1306.131014] wlan0: authentication with <MAC addr pawe3> timed out
    [ 1310.961422] wlan0: deauthenticating from <MAC addr pawe3> by local choice (reason=3)
    [ 1627.775056] wlan0: authenticate with <MAC addr pawe3>
    [ 1627.959806] wlan0: direct probe to <MAC addr pawe3> (try 1/3)
    [ 1628.161829] wlan0: direct probe to <MAC addr pawe3> (try 2/3)
    [ 1628.365987] wlan0: direct probe to <MAC addr pawe3> (try 3/3)
    [ 1628.570216] wlan0: authentication with <MAC addr pawe3> timed out
    [ 1633.400732] wlan0: deauthenticating from <MAC addr pawe3> by local choice (reason=3)
    [ 1655.804185] wlan0: authenticate with <MAC addr pawe3>
    [ 1658.688704] wlan0: direct probe to <MAC addr pawe3> (try 1/3)
    [ 1658.890112] wlan0: direct probe to <MAC addr pawe3> (try 2/3)
    [ 1659.094326] wlan0: direct probe to <MAC addr pawe3> (try 3/3)
    [ 1659.298802] wlan0: authentication with <MAC addr pawe3> timed out
    [ 1664.136995] wlan0: deauthenticating from <MAC addr pawe3> by local choice (reason=3)
    [ 1684.597931] wlan0: authenticate with <MAC addr pawe3>
    [ 1689.424560] wlan0: direct probe to <MAC addr pawe3> (try 1/3)
    [ 1689.626428] wlan0: direct probe to <MAC addr pawe3> (try 2/3)
    [ 1689.830723] wlan0: direct probe to <MAC addr pawe3> (try 3/3)
    [ 1690.034981] wlan0: authentication with <MAC addr pawe3> timed out
    [ 1694.869446] wlan0: deauthenticating from <MAC addr pawe3> by local choice (reason=3)
    [ 1715.334388] wlan0: authenticate with <MAC addr pawe3>
    [ 1720.157971] wlan0: direct probe to <MAC addr pawe3> (try 1/3)
    [ 1720.358662] wlan0: direct probe to <MAC addr pawe3> (try 2/3)
    [ 1720.563713] wlan0: direct probe to <MAC addr pawe3> (try 3/3)
    [ 1720.767196] wlan0: authentication with <MAC addr pawe3> timed out
    [ 1725.601606] wlan0: deauthenticating from <MAC addr pawe3> by local choice (reason=3)
    [ 2040.179121] wlan0: authenticate with <MAC addr pawe3>
    [ 2042.396672] wlan0: direct probe to <MAC addr pawe3> (try 1/3)
    [ 2042.598570] wlan0: direct probe to <MAC addr pawe3> (try 2/3)
    [ 2042.802754] wlan0: direct probe to <MAC addr pawe3> (try 3/3)
    [ 2043.006968] wlan0: authentication with <MAC addr pawe3> timed out
    [ 2047.835254] wlan0: deauthenticating from <MAC addr pawe3> by local choice (reason=3)
    [ 2068.289474] wlan0: authenticate with <MAC addr pawe3>
    [ 2073.110255] wlan0: direct probe to <MAC addr pawe3> (try 1/3)
    [ 2073.311769] wlan0: direct probe to <MAC addr pawe3> (try 2/3)
    [ 2073.515903] wlan0: direct probe to <MAC addr pawe3> (try 3/3)
    [ 2073.719883] wlan0: authentication with <MAC addr pawe3> timed out
    [ 2078.556275] wlan0: deauthenticating from <MAC addr pawe3> by local choice (reason=3)
    [ 2099.016636] wlan0: authenticate with <MAC addr pawe3>
    [ 2103.839171] wlan0: direct probe to <MAC addr pawe3> (try 1/3)
    [ 2104.040733] wlan0: direct probe to <MAC addr pawe3> (try 2/3)
    [ 2104.244726] wlan0: direct probe to <MAC addr pawe3> (try 3/3)
    [ 2104.448949] wlan0: authentication with <MAC addr pawe3> timed out
    [ 2109.284873] wlan0: deauthenticating from <MAC addr pawe3> by local choice (reason=3)
    [ 2129.734145] wlan0: authenticate with <MAC addr pawe3>
    [ 2134.555636] wlan0: direct probe to <MAC addr pawe3> (try 1/3)
    [ 2134.757421] wlan0: direct probe to <MAC addr pawe3> (try 2/3)
    [ 2134.961619] wlan0: direct probe to <MAC addr pawe3> (try 3/3)
    [ 2135.165745] wlan0: authentication with <MAC addr pawe3> timed out
    [ 2139.993772] wlan0: deauthenticating from <MAC addr pawe3> by local choice (reason=3)
    [ 2454.541941] wlan0: authenticate with <MAC addr pawe3>
    [ 2456.725534] wlan0: direct probe to <MAC addr pawe3> (try 1/3)
    [ 2456.927289] wlan0: direct probe to <MAC addr pawe3> (try 2/3)
    [ 2457.131420] wlan0: direct probe to <MAC addr pawe3> (try 3/3)
    [ 2457.335624] wlan0: authentication with <MAC addr pawe3> timed out
    [ 2462.163577] wlan0: deauthenticating from <MAC addr pawe3> by local choice (reason=3)
    [ 2482.622810] wlan0: authenticate with <MAC addr pawe3>
    [ 2487.442398] wlan0: direct probe to <MAC addr pawe3> (try 1/3)
    [ 2487.644234] wlan0: direct probe to <MAC addr pawe3> (try 2/3)
    [ 2487.848447] wlan0: direct probe to <MAC addr pawe3> (try 3/3)
    [ 2488.052606] wlan0: authentication with <MAC addr pawe3> timed out
    [ 2492.880542] wlan0: deauthenticating from <MAC addr pawe3> by local choice (reason=3)
    [ 2513.334388] wlan0: authenticate with <MAC addr pawe3>
    [ 2518.155323] wlan0: direct probe to <MAC addr pawe3> (try 1/3)
    [ 2518.357206] wlan0: direct probe to <MAC addr pawe3> (try 2/3)
    [ 2518.561438] wlan0: direct probe to <MAC addr pawe3> (try 3/3)
    [ 2518.765569] wlan0: authentication with <MAC addr pawe3> timed out
    [ 2523.597535] wlan0: deauthenticating from <MAC addr pawe3> by local choice (reason=3)
    [ 2544.050906] wlan0: authenticate with <MAC addr pawe3>
    [ 2548.878411] wlan0: direct probe to <MAC addr pawe3> (try 1/3)
    [ 2549.082172] wlan0: direct probe to <MAC addr pawe3> (try 2/3)
    [ 2549.286411] wlan0: direct probe to <MAC addr pawe3> (try 3/3)
    [ 2549.490584] wlan0: authentication with <MAC addr pawe3> timed out
    [ 2554.317355] wlan0: deauthenticating from <MAC addr pawe3> by local choice (reason=3)
    [ 2868.845016] wlan0: authenticate with <MAC addr pawe3>
    [ 2871.062532] wlan0: direct probe to <MAC addr pawe3> (try 1/3)
    [ 2871.264117] wlan0: direct probe to <MAC addr pawe3> (try 2/3)
    [ 2871.468224] wlan0: direct probe to <MAC addr pawe3> (try 3/3)
    [ 2871.672438] wlan0: authentication with <MAC addr pawe3> timed out
    [ 2876.492515] wlan0: deauthenticating from <MAC addr pawe3> by local choice (reason=3)
    [ 2896.941543] wlan0: authenticate with <MAC addr pawe3>
    [ 2901.771108] wlan0: direct probe to <MAC addr pawe3> (try 1/3)
    [ 2901.973028] wlan0: direct probe to <MAC addr pawe3> (try 2/3)
    [ 2902.177181] wlan0: direct probe to <MAC addr pawe3> (try 3/3)
    [ 2902.381323] wlan0: authentication with <MAC addr pawe3> timed out
    [ 2907.217320] wlan0: deauthenticating from <MAC addr pawe3> by local choice (reason=3)
    [ 2927.667371] wlan0: authenticate with <MAC addr pawe3>
    [ 2932.488083] wlan0: direct probe to <MAC addr pawe3> (try 1/3)
    [ 2932.689954] wlan0: direct probe to <MAC addr pawe3> (try 2/3)
    [ 2932.894148] wlan0: direct probe to <MAC addr pawe3> (try 3/3)
    [ 2933.098294] wlan0: authentication with <MAC addr pawe3> timed out
    [ 2937.926257] wlan0: deauthenticating from <MAC addr pawe3> by local choice (reason=3)
    [ 2958.393736] wlan0: authenticate with <MAC addr pawe3>
    [ 2963.205166] wlan0: direct probe to <MAC addr pawe3> (try 1/3)
    [ 2963.406941] wlan0: direct probe to <MAC addr pawe3> (try 2/3)
    [ 2963.611236] wlan0: direct probe to <MAC addr pawe3> (try 3/3)
    [ 2963.815291] wlan0: authentication with <MAC addr pawe3> timed out
    [ 2968.643295] wlan0: deauthenticating from <MAC addr pawe3> by local choice (reason=3)
    [ 3283.190562] wlan0: authenticate with <MAC addr pawe3>
    [ 3285.399489] wlan0: direct probe to <MAC addr pawe3> (try 1/3)
    [ 3285.600873] wlan0: direct probe to <MAC addr pawe3> (try 2/3)
    [ 3285.804990] wlan0: direct probe to <MAC addr pawe3> (try 3/3)
    [ 3286.009163] wlan0: authentication with <MAC addr pawe3> timed out
    [ 3290.837144] wlan0: deauthenticating from <MAC addr pawe3> by local choice (reason=3)
    [ 3311.296646] wlan0: authenticate with <MAC addr pawe3>
    [ 3316.108562] wlan0: direct probe to <MAC addr pawe3> (try 1/3)
    [ 3316.309784] wlan0: direct probe to <MAC addr pawe3> (try 2/3)
    [ 3316.513976] wlan0: direct probe to <MAC addr pawe3> (try 3/3)
    [ 3316.718124] wlan0: authentication with <MAC addr pawe3> timed out
    [ 3321.547202] wlan0: deauthenticating from <MAC addr pawe3> by local choice (reason=3)
    [ 3352.147925] wlan0: authenticate with <MAC addr pawe3>
    [ 3356.969130] wlan0: direct probe to <MAC addr pawe3> (try 1/3)
    [ 3357.171004] wlan0: direct probe to <MAC addr pawe3> (try 2/3)
    [ 3357.375163] wlan0: direct probe to <MAC addr pawe3> (try 3/3)
    [ 3357.579330] wlan0: authentication with <MAC addr pawe3> timed out
    [ 3362.411304] wlan0: deauthenticating from <MAC addr pawe3> by local choice (reason=3)
    [ 3382.860371] wlan0: authenticate with <MAC addr pawe3>
    [ 3387.682048] wlan0: direct probe to <MAC addr pawe3> (try 1/3)
    [ 3387.883955] wlan0: direct probe to <MAC addr pawe3> (try 2/3)
    [ 3388.088117] wlan0: direct probe to <MAC addr pawe3> (try 3/3)
    [ 3388.292289] wlan0: authentication with <MAC addr pawe3> timed out
    [ 3393.116549] wlan0: deauthenticating from <MAC addr pawe3> by local choice (reason=3)
    
    
    ########## wireless info END ############
    Sorry for my bad english. It is not my native language. I looke forward to your help and advice.
    Last edited by pawe3pl; September 14th, 2014 at 02:51 PM.

  2. #2
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,149
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: RTL8723BE wifi dropping connection on Ubuntu 14.04

    Hello pawel-juchnowski, Welcome to the forums!

    Please try a couple of driver parameters available for your driver. In a terminal (can be opened with Ctrl-Alt-T), please run this code (you may copy-paste) to try them -
    Code:
    echo "options rtl8723be fwlps=N ips=N" | sudo tee /etc/modprobe.d/rtl8723be.conf
    Reboot and reconnect. Does it make the connection stable?

    And which country you are in? We may have to explicitly set your country code for regdomain settings.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  3. #3
    Join Date
    Sep 2014
    Location
    Rybnik, Poland
    Beans
    13
    Distro
    Ubuntu 15.10 Wily Werewolf

    Re: RTL8723BE wifi dropping connection on Ubuntu 14.04

    Quote Originally Posted by varunendra View Post
    Code:
    echo "options rtl8723be fwlps=N ips=N" | sudo tee /etc/modprobe.d/rtl8723be.conf
    I ran this comman yesterday and connection is stable so far. I can disconnect manually and reconnect without any problem. So I think that this problem is solved for now. Thanks for help, I appreciate it.

  4. #4
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,149
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: RTL8723BE wifi dropping connection on Ubuntu 14.04

    Thanks for the precious feedback, it makes for two solved threads for this driver so far.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  5. #5
    Join Date
    Sep 2014
    Location
    Rybnik, Poland
    Beans
    13
    Distro
    Ubuntu 15.10 Wily Werewolf

    Re: RTL8723BE wifi dropping connection on Ubuntu 14.04

    I've got another issue. My download transfers are sometimes very high, and sometimes very-very low. On speedtest.net one time my dl speed is at 35mb, and another time is 0.45mb/s. My wifi security settings are WPA2 Personal with AES.

    Code:
    ########## wireless info START ##########
    
    
    Report from: 15 Sep 2014 17:32 CEST +0200
    
    
    Booted last: 15 Sep 2014 17:17 CEST +0200
    
    
    Script from: 15 Sep 2014 03:40 UTC +0000
    
    
    ##### release #####
    
    
    Distributor ID:	Ubuntu
    Description:	Ubuntu 14.04.1 LTS
    Release:	14.04
    Codename:	trusty
    
    
    ##### kernel #####
    
    
    Linux 3.13.0-35-generic #62-Ubuntu SMP Fri Aug 15 01:58:01 UTC 2014 i686 i686 i686 GNU/Linux
    
    
    Parameters: ro, quiet, splash, vt.handoff=7
    
    
    ##### desktop #####
    
    
    Ubuntu
    
    
    ##### lspci #####
    
    
    02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter [10ec:b723]
    	Subsystem: Lenovo Device [17aa:b736]
    	Kernel driver in use: rtl8723be
    
    
    03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 10)
    	Subsystem: Lenovo Device [17aa:3816]
    	Kernel driver in use: r8169
    
    
    ##### lsusb #####
    
    
    Bus 001 Device 006: ID 0bda:b728 Realtek Semiconductor Corp. 
    Bus 001 Device 005: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
    Bus 001 Device 004: ID 5986:0652 Acer, Inc 
    Bus 001 Device 003: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
    Bus 001 Device 002: ID 8087:07e6 Intel Corp. 
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    
    
    ##### PCMCIA card info #####
    
    
    ##### rfkill #####
    
    
    0: hci0: Bluetooth
    	Soft blocked: no
    	Hard blocked: no
    1: phy0: Wireless LAN
    	Soft blocked: no
    	Hard blocked: no
    
    
    ##### lsmod #####
    
    
    rtl8723be              75735  0 
    btcoexist              49432  1 rtl8723be
    rtl8723_common         22417  1 rtl8723be
    rtl_pci                26314  1 rtl8723be
    rtlwifi                52835  2 rtl_pci,rtl8723be
    mac80211              546051  3 rtl_pci,rtlwifi,rtl8723be
    cfg80211              409394  2 mac80211,rtlwifi
    
    
    ##### interfaces #####
    
    
    auto lo
    iface lo inet loopback
    
    
    ##### ifconfig #####
    
    
    eth0      Link encap:Ethernet  HWaddr <MAC 'eth0' [IF]>  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
    
    
    wlan0     Link encap:Ethernet  HWaddr <MAC 'wlan0' [IF]>  
              inet addr:192.168.0.101  Bcast:192.168.0.255  Mask:255.255.255.0
              inet6 addr: fe80::9248:9aff:fe1b:113d/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:493694 errors:0 dropped:0 overruns:0 frame:0
              TX packets:303134 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:616922929 (616.9 MB)  TX bytes:123115749 (123.1 MB)
    
    
    ##### iwconfig #####
    
    
    lo        no wireless extensions.
    
    
    eth0      no wireless extensions.
    
    
    wlan0     IEEE 802.11bgn  ESSID:"pawe3"  
              Mode:Managed  Frequency:2.437 GHz  Access Point: <MAC 'pawe3' [AP4]>   
              Bit Rate=150 Mb/s   Tx-Power=20 dBm   
              Retry  long limit:7   RTS thr=2347 B   Fragment thr:off
              Power Management:off
              Link Quality=64/70  Signal level=-46 dBm  
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:25   Missed beacon:0
    
    
    ##### route #####
    
    
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    0.0.0.0         192.168.0.1     0.0.0.0         UG    0      0        0 wlan0
    192.168.0.0     0.0.0.0         255.255.255.0   U     9      0        0 wlan0
    
    
    ##### resolv.conf #####
    
    
    nameserver 127.0.1.1
    
    
    ##### nm-tool #####
    
    
    NetworkManager Tool
    
    
    State: connected (global)
    
    
    - Device: eth0 -----------------------------------------------------------------
      Type:              Wired
      Driver:            r8169
      State:             unavailable
      Default:           no
      HW Address:        <MAC 'eth0' [IF]>
    
    
      Capabilities:
        Carrier Detect:  yes
    
    
      Wired Properties
        Carrier:         off
    
    
    - Device: wlan0  [pawe3] -------------------------------------------------------
      Type:              802.11 WiFi
      Driver:            rtl8723be
      State:             connected
      Default:           yes
      HW Address:        <MAC 'wlan0' [IF]>
    
    
      Capabilities:
        Speed:           150 Mb/s
    
    
      Wireless Properties
        WEP Encryption:  yes
        WPA Encryption:  yes
        WPA2 Encryption: yes
    
    
      Wireless Access Points (* = current AP)
        NETIASPOT-665F10:Infra, <MAC 'NETIASPOT-665F10' [AP1]>, Freq 2467 MHz, Rate 54 Mb/s, Strength 47 WPA WPA2
        jmj:             Infra, <MAC 'jmj' [AP2]>, Freq 2437 MHz, Rate 54 Mb/s, Strength 40 WPA2
        FON_NETIA_FREE_INTERNET: Infra, <MAC 'FON_NETIA_FREE_INTERNET' [AP3]>, Freq 2467 MHz, Rate 54 Mb/s, Strength 40
        *pawe3:          Infra, <MAC 'pawe3' [AP4]>, Freq 2437 MHz, Rate 54 Mb/s, Strength 74 WPA2
        TP-LINK_F455BE:  Infra, <MAC 'TP-LINK_F455BE' [AP5]>, Freq 2427 MHz, Rate 54 Mb/s, Strength 34 WPA WPA2
        ShiDek:          Infra, <MAC 'ShiDek' [AP6]>, Freq 2437 MHz, Rate 54 Mb/s, Strength 17 WPA WPA2
        Del siec:        Infra, <MAC 'Del siec' [AP7]>, Freq 2437 MHz, Rate 54 Mb/s, Strength 34 WPA2
        barton-net.pl_0: Infra, <MAC 'barton-net.pl_0' [AP8]>, Freq 2437 MHz, Rate 54 Mb/s, Strength 20
        TP-LINK:         Infra, <MAC 'TP-LINK' [AP9]>, Freq 2437 MHz, Rate 11 Mb/s, Strength 34 WEP
        Marcin:          Infra, <MAC 'Marcin' [AP10]>, Freq 2457 MHz, Rate 54 Mb/s, Strength 27 WPA WPA2
    
    
      IPv4 Settings:
        Address:         192.168.0.101
        Prefix:          24 (255.255.255.0)
        Gateway:         192.168.0.1
    
    
        DNS:             78.31.136.10
        DNS:             79.124.106.1
    
    
    ##### NetworkManager.state #####
    
    
    [main]
    NetworkingEnabled=true
    WirelessEnabled=true
    WWANEnabled=true
    WimaxEnabled=true
    
    
    ##### NetworkManager.conf #####
    
    
    [main]
    plugins=ifupdown,keyfile,ofono
    dns=dnsmasq
    
    
    [ifupdown]
    managed=false
    
    
    ##### NetworkManager profiles #####
    
    
    ##### iw reg get #####
    
    
    Region: Europe/Warsaw (based on set timezone)
    
    
    country CN:
    	(2402 - 2482 @ 40), (N/A, 20)
    	(5735 - 5835 @ 40), (N/A, 30)
    	(57240 - 59400 @ 2160), (N/A, 28)
    	(59400 - 63720 @ 2160), (N/A, 44)
    	(63720 - 65880 @ 2160), (N/A, 28)
    
    
    ##### iwlist channels #####
    
    
    lo        no frequency information.
    
    
    eth0      no frequency information.
    
    
    wlan0     13 channels in total; available frequencies :
              Channel 01 : 2.412 GHz
              Channel 02 : 2.417 GHz
              Channel 03 : 2.422 GHz
              Channel 04 : 2.427 GHz
              Channel 05 : 2.432 GHz
              Channel 06 : 2.437 GHz
              Channel 07 : 2.442 GHz
              Channel 08 : 2.447 GHz
              Channel 09 : 2.452 GHz
              Channel 10 : 2.457 GHz
              Channel 11 : 2.462 GHz
              Channel 12 : 2.467 GHz
              Channel 13 : 2.472 GHz
              Current Frequency=2.437 GHz (Channel 6)
    
    
    ##### iwlist scan #####
    
    
    wlan0     Interface doesn't support scanning : Device or resource busy
    
    
    lo        Interface doesn't support scanning.
    
    
    eth0      Interface doesn't support scanning.
    
    
    ##### module infos #####
    
    
    [rtl8723be]
    filename:       /lib/modules/3.13.0-35-generic/kernel/drivers/net/wireless/rtlwifi/rtl8723be/rtl8723be.ko
    firmware:       rtlwifi/rtl8723befw.bin
    description:    Realtek 8723BE 802.11n PCI wireless
    license:        GPL
    author:         Realtek WlanFAE	<wlanfae@realtek.com>
    author:         PageHe	<page_he@realsil.com.cn>
    srcversion:     0D59E0301AAA6E5A93400BB
    depends:        rtlwifi,rtl8723-common,rtl_pci,btcoexist,mac80211
    intree:         Y
    vermagic:       3.13.0-35-generic SMP mod_unload modversions 686 
    signer:         Magrathea: Glacier signing key
    sig_key:        A2:8D:B5:FD:6E:29:9C:CE:49:47:DA:CA:A6:6F:45:9D:B4:AC:CE:24
    sig_hashalgo:   sha512
    parm:           swlps:bool
    parm:           swenc:using hardware crypto (default 0 [hardware])
     (bool)
    parm:           ips:using no link power save (default 1 is open)
     (bool)
    parm:           fwlps:using linked fw control power save (default 1 is open)
     (bool)
    parm:           msi:Set to 1 to use MSI interrupts mode (default 0)
     (bool)
    parm:           debug:Set debug level (0-5) (default 0) (int)
    
    
    [rtl8723_common]
    filename:       /lib/modules/3.13.0-35-generic/kernel/drivers/net/wireless/rtlwifi/rtl8723com/rtl8723-common.ko
    description:    Realtek RTL8723AE/RTL8723BE 802.11n PCI wireless common routines
    license:        GPL
    author:         Larry Finger	<Larry.Finger@lwfinger.net>
    author:         Realtek WlanFAE	<wlanfae@realtek.com>
    srcversion:     D1807280DBDC9B8A7EBDAB7
    depends:        
    intree:         Y
    vermagic:       3.13.0-35-generic SMP mod_unload modversions 686 
    signer:         Magrathea: Glacier signing key
    sig_key:        A2:8D:B5:FD:6E:29:9C:CE:49:47:DA:CA:A6:6F:45:9D:B4:AC:CE:24
    sig_hashalgo:   sha512
    
    
    [rtl_pci]
    filename:       /lib/modules/3.13.0-35-generic/kernel/drivers/net/wireless/rtlwifi/rtl_pci.ko
    description:    PCI basic driver for rtlwifi
    license:        GPL
    author:         Larry Finger	<Larry.FInger@lwfinger.net>
    author:         Realtek WlanFAE	<wlanfae@realtek.com>
    author:         lizhaoming	<chaoming_li@realsil.com.cn>
    srcversion:     D5E4890DC428FA5A1BF92DF
    depends:        mac80211,rtlwifi
    intree:         Y
    vermagic:       3.13.0-35-generic SMP mod_unload modversions 686 
    signer:         Magrathea: Glacier signing key
    sig_key:        A2:8D:B5:FD:6E:29:9C:CE:49:47:DA:CA:A6:6F:45:9D:B4:AC:CE:24
    sig_hashalgo:   sha512
    
    
    [rtlwifi]
    filename:       /lib/modules/3.13.0-35-generic/kernel/drivers/net/wireless/rtlwifi/rtlwifi.ko
    description:    Realtek 802.11n PCI wireless core
    license:        GPL
    author:         Larry Finger	<Larry.FInger@lwfinger.net>
    author:         Realtek WlanFAE	<wlanfae@realtek.com>
    author:         lizhaoming	<chaoming_li@realsil.com.cn>
    srcversion:     E1F4663325225EE8DBA54CA
    depends:        mac80211,cfg80211
    intree:         Y
    vermagic:       3.13.0-35-generic SMP mod_unload modversions 686 
    signer:         Magrathea: Glacier signing key
    sig_key:        A2:8D:B5:FD:6E:29:9C:CE:49:47:DA:CA:A6:6F:45:9D:B4:AC:CE:24
    sig_hashalgo:   sha512
    
    
    [mac80211]
    filename:       /lib/modules/3.13.0-35-generic/kernel/net/mac80211/mac80211.ko
    license:        GPL
    description:    IEEE 802.11 subsystem
    srcversion:     D491AB7C521706DA5F4BE7C
    depends:        cfg80211
    intree:         Y
    vermagic:       3.13.0-35-generic SMP mod_unload modversions 686 
    signer:         Magrathea: Glacier signing key
    sig_key:        A2:8D:B5:FD:6E:29:9C:CE:49:47:DA:CA:A6:6F:45:9D:B4:AC:CE:24
    sig_hashalgo:   sha512
    parm:           max_nullfunc_tries:Maximum nullfunc tx tries before disconnecting (reason 4). (int)
    parm:           max_probe_tries:Maximum probe tries before disconnecting (reason 4). (int)
    parm:           beacon_loss_count:Number of beacon intervals before we decide beacon was lost. (int)
    parm:           probe_wait_ms:Maximum time(ms) to wait for probe response before disconnecting (reason 4). (int)
    parm:           ieee80211_default_rc_algo:Default rate control algorithm for mac80211 to use (charp)
    
    
    [cfg80211]
    filename:       /lib/modules/3.13.0-35-generic/kernel/net/wireless/cfg80211.ko
    description:    wireless configuration support
    license:        GPL
    author:         Johannes Berg
    srcversion:     C2478077E22138832B71659
    depends:        
    intree:         Y
    vermagic:       3.13.0-35-generic SMP mod_unload modversions 686 
    signer:         Magrathea: Glacier signing key
    sig_key:        A2:8D:B5:FD:6E:29:9C:CE:49:47:DA:CA:A6:6F:45:9D:B4:AC:CE:24
    sig_hashalgo:   sha512
    parm:           ieee80211_regdom:IEEE 802.11 regulatory domain code (charp)
    parm:           cfg80211_disable_40mhz_24ghz:Disable 40MHz support in the 2.4GHz band (bool)
    
    
    ##### module parameters #####
    
    
    [rtl8723be]
    debug: 0
    fwlps: N
    ips: N
    msi: N
    swenc: N
    swlps: N
    
    
    [mac80211]
    beacon_loss_count: 7
    ieee80211_default_rc_algo: minstrel_ht
    max_nullfunc_tries: 2
    max_probe_tries: 5
    probe_wait_ms: 500
    
    
    [cfg80211]
    cfg80211_disable_40mhz_24ghz: N
    ieee80211_regdom: 00
    
    
    ##### /etc/modules #####
    
    
    lp
    
    
    ##### modprobe options #####
    
    
    [/etc/modprobe.d/blacklist-ath_pci.conf]
    blacklist ath_pci
    
    
    [/etc/modprobe.d/blacklist.conf]
    blacklist evbug
    blacklist usbmouse
    blacklist usbkbd
    blacklist eepro100
    blacklist de4x5
    blacklist eth1394
    blacklist snd_intel8x0m
    blacklist snd_aw2
    blacklist i2c_i801
    blacklist prism54
    blacklist bcm43xx
    blacklist garmin_gps
    blacklist asus_acpi
    blacklist snd_pcsp
    blacklist pcspkr
    blacklist amd76x_edac
    
    
    [/etc/modprobe.d/blacklist-ideapad.conf]
    blacklist ideapad_laptop
    
    
    [/etc/modprobe.d/blacklist-rare-network.conf]
    alias net-pf-3 off
    alias net-pf-6 off
    alias net-pf-9 off
    alias net-pf-11 off
    alias net-pf-12 off
    alias net-pf-19 off
    alias net-pf-21 off
    alias net-pf-36 off
    
    
    [/etc/modprobe.d/iwlwifi.conf]
    remove iwlwifi \
    (/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
    && /sbin/modprobe -r mac80211
    
    
    [/etc/modprobe.d/mlx4.conf]
    softdep mlx4_core post: mlx4_en
    
    
    [/etc/modprobe.d/rtl8723be.conf]
    options rtl8723be fwlps=N ips=N
    
    
    ##### rc.local #####
    
    
    exit 0
    
    
    ##### pm-utils #####
    
    
    ##### udev rules #####
    
    
    [/etc/udev/rules.d/70-persistent-net.rules]
    # PCI device 0x10ec:0x8168 (r8169)
    SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC 'eth0' [IF]>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
    # PCI device 0x10ec:0xb723 (rtl8723be)
    SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC 'wlan0' [IF]>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"
    
    
    ##### dmesg #####
    
    
    [   13.850672] rtl8723be: Using firmware rtlwifi/rtl8723befw.bin
    [   14.042039] ieee80211 phy0: Selected rate control algorithm 'rtl_rc'
    [   14.042364] rtlwifi: wireless switch is on
    [   16.946401] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready (repeated 2 times)
    [   18.760495] wlan0: authenticate with <MAC 'pawe3' [AP4]>
    [   18.780049] wlan0: send auth to <MAC 'pawe3' [AP4]> (try 1/3)
    [   18.782142] wlan0: authenticated
    [   18.783582] wlan0: associate with <MAC 'pawe3' [AP4]> (try 1/3)
    [   18.787181] wlan0: RX AssocResp from <MAC 'pawe3' [AP4]> (capab=0x411 status=0 aid=1)
    [   18.787273] wlan0: associated
    [   18.787309] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
    [   19.140449] wlan0: authenticate with <MAC 'TP-LINK_F455BE' [AP5]>
    [   19.151660] wlan0: send auth to <MAC 'TP-LINK_F455BE' [AP5]> (try 1/3)
    [   19.153124] wlan0: authenticated
    [   19.155895] wlan0: associate with <MAC 'TP-LINK_F455BE' [AP5]> (try 1/3)
    [   19.161350] wlan0: RX AssocResp from <MAC 'TP-LINK_F455BE' [AP5]> (capab=0x431 status=0 aid=1)
    [   19.161444] wlan0: associated
    [   22.168848] wlan0: deauthenticated from <MAC 'TP-LINK_F455BE' [AP5]> (Reason: 2)
    [   23.144150] wlan0: authenticate with <MAC 'pawe3' [AP4]>
    [   23.164737] wlan0: send auth to <MAC 'pawe3' [AP4]> (try 1/3)
    [   23.168262] wlan0: authenticated
    [   23.171155] wlan0: associate with <MAC 'pawe3' [AP4]> (try 1/3)
    [   23.174735] wlan0: RX AssocResp from <MAC 'pawe3' [AP4]> (capab=0x411 status=0 aid=1)
    [   23.174832] wlan0: associated
    
    
    ########## wireless info END ############
    Last edited by pawe3pl; September 15th, 2014 at 04:34 PM.

  6. #6
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,149
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: RTL8723BE wifi dropping connection on Ubuntu 14.04

    Since signal strength and encryption type both are good, power-management also doesn't seem to be an issue anymore, I think there are only two things that may help improving the speed -

    1) Make sure "IPv6" is set to "Ignore" in Network Manager.

    2) Try 'swenc=Y' parameter, appending it with the existing ones -
    Code:
    sudo sed -i 's/^options.*/& swenc=Y/' /etc/modprobe.d/rtl8723be.conf
    Some people have reported that the 'swenc' type options actually made their connection worse. So if that happens with you too, remove it with -
    Code:
    sudo sed -i 's/ swenc=Y//' /etc/modprobe.d/rtl8723be.conf
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  7. #7
    Join Date
    Sep 2014
    Location
    Rybnik, Poland
    Beans
    13
    Distro
    Ubuntu 15.10 Wily Werewolf

    Re: RTL8723BE wifi dropping connection on Ubuntu 14.04

    Quote Originally Posted by varunendra View Post
    Since signal strength and encryption type both are good, power-management also doesn't seem to be an issue anymore, I think there are only two things that may help improving the speed -

    1) Make sure "IPv6" is set to "Ignore" in Network Manager.

    2) Try 'swenc=Y' parameter, appending it with the existing ones -
    Code:
    sudo sed -i 's/^options.*/& swenc=Y/' /etc/modprobe.d/rtl8723be.conf
    Some people have reported that the 'swenc' type options actually made their connection worse. So if that happens with you too, remove it with -
    Code:
    sudo sed -i 's/ swenc=Y//' /etc/modprobe.d/rtl8723be.conf
    1) It did not help.
    2) Just like You said, it made my connection worse.

  8. #8
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,149
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: RTL8723BE wifi dropping connection on Ubuntu 14.04

    Which country you currently are in? Your regdomain settings are set to 'CN' (China). If you are not there, we may try setting it to your actual country code so there are no doubts there.

    Please also try channels 1 or 11 (or 13, if the router supports that) in the router. Just for a test. Make sure to reboot the router after saving changes in it.

    Let us have a fresh wireless-info report after applying the changes.

    PS:
    If the overall current performance is problematic again, I think you should remove the [SOLVED] prefix. It is supposed to indicate at least a 'satisfactory' solution.


    --
    Last edited by varunendra; September 19th, 2014 at 09:34 AM.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  9. #9
    Join Date
    Sep 2014
    Location
    Rybnik, Poland
    Beans
    13
    Distro
    Ubuntu 15.10 Wily Werewolf

    Re: RTL8723BE wifi dropping connection on Ubuntu 14.04

    Quote Originally Posted by varunendra View Post
    Which country you currently are in? Your regdomain settings are set to 'CN' (China). If you are not there, we may try setting it to your actual country code so there are no doubts there.
    I live in Poland. I have changed the crda file:
    Code:
    REGDOMAIN=PL
    But when i run wireless-scritp my country is still CN. Can you tell me how to properly change it please.

    BTW: I also changed channels in the router settings. Now it is set on channel 1.
    Last edited by pawe3pl; September 20th, 2014 at 06:08 PM.

  10. #10
    Join Date
    May 2014
    Location
    /home
    Beans
    6,022
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: RTL8723BE wifi dropping connection on Ubuntu 14.04

    Quote Originally Posted by pawel-juchnowski View Post
    I live in Poland. I have changed the crda file:
    Code:
    REGDOMAIN=PL
    But when i run wireless-scritp my country is still CN. Can you tell me how to properly change it please.

    BTW: I also changed channels in the router settings. Now it is set on channel 1.
    You will also need to run
    Code:
    sudo iw reg set PL
    Varunendra, there is some talk on the Linux Mint forum about some of the RTL8723BE problems being fixed in kernel 3.16, so the backports might be a solution
    Last edited by jeremy31; September 21st, 2014 at 12:34 AM.

Page 1 of 6 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •