Results 1 to 5 of 5

Thread: Updates broke gnome flashback with compiz

  1. #1
    Join Date
    Aug 2009
    Beans
    Hidden!
    Distro
    Xubuntu

    Updates broke gnome flashback with compiz

    I noticed an update to gnome-session-flashback yesterday along with several others and never gave it a 2nd thought. They didn't require a reboot.

    But, today gnome-flashback (with compiz) just boots to a blank screen (I see my wallpaper and nothing else happens).
    This is booting with upstart or systemd - the same result.

    All I can boot into is a Unity session.

    Anybody else have the same problem?
    Last edited by Cavsfan; August 24th, 2014 at 05:45 PM.

  2. #2
    Join Date
    Jun 2010
    Location
    London, England
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Updates broke gnome flashback with compiz

    Yes, it is happening on my system running Nouveau. It is login screen bounce but without the password panel and the app indicators. The same login background image with Ubuntu 14.10 logo. So, it does not load to the desktop. I used Ctrl+Alt+F2 and as I entered the third character of my user name the screen went blank. Same thing with Crtl+Alt+F3

    Regards.
    It is a machine. It is more stupid than we are. It will not stop us from doing stupid things.
    Ubuntu user #33,200. Linux user #530,530


  3. #3
    Join Date
    Jan 2007
    Location
    Connecticut
    Beans
    1,649
    Distro
    Ubuntu Development Release

    Re: Updates broke gnome flashback with compiz

    i had almost the exact same thing happen a few days ago....except it was unity that would give me the blank desktop (wallpaper was there, but no unity launcher, dash, etc..). i could only do a ctrl-alt-f1 to get to terminal, then "sudo reboot", and finally booted to gnome-shell to get to a working desktop.

    i somehow reset unity/compiz settings and all has been fine since. could be mistaken, but i think these were the commands that fixed it:

    Code:
    dconf reset -f /org/compiz/
     
    setsid unity
    btw, creating a new user resulted in a working unity desktop...it was just my user settings which failed. like i said, all is working perfectly again after resetting things.




  4. #4
    Join Date
    Aug 2009
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: Updates broke gnome flashback with compiz

    Quote Originally Posted by grahammechanical View Post
    Yes, it is happening on my system running Nouveau. It is login screen bounce but without the password panel and the app indicators. The same login background image with Ubuntu 14.10 logo. So, it does not load to the desktop. I used Ctrl+Alt+F2 and as I entered the third character of my user name the screen went blank. Same thing with Crtl+Alt+F3

    Regards.
    Glad to see it is not only me. I seen this in the changelog:
    Code:
    gnome-panel (1:3.8.1-1ubuntu1) utopic; urgency=medium
    
      * Merge with Debian unstable, remaining changes:
        - Use an epoch in version number.
        - Recommend indicator-applet-complete.
        - Use unity-control-center instead of gnome-control-center.
        - Recommend gnome-screensaver instead of depending on it.
        - Suggest compiz.
        - Adjust Breaks/Replaces for Ubuntu versioning.
        - Drop 14_revert_timedate_change.patch, we are using timedated.
        - Add patches:
          + git_drop_gconf.patch
          + 40_unset_menuproxy.patch
          + 41_classic_layout.patch
          + 50_ubuntu_sessions.patch
          + 51_desktop_file.patch
          + lp-1314706.patch
          + clock-fix-expanding.patch
      * Merge 49_no_screensaver.patch into 50_ubuntu_sessions.patch.
      * Drop git_fix_panel_size.patch, applied upstream:
      * Refresh patches:
        - git_drop_gconf.patch
        - 40_unset_menuproxy.patch
        - lp-1314706.patch
        - clock-fix-expanding.patch
      * Rebase patches:
        - 50_ubuntu_sessions.patch
        - 51_desktop_file.patch
    
     --   Sat, 23 Aug 2014 18:48:54 +0400
    I found that I didn't have unity-control-panel installed so I installed it. Rebooted and still no flashback - neither metacity or compiz would boot.
    It would boot with gnome (cairo dock) though, that and Unity.

    So I checked to see if there were any more updates and another update to gnome-panel and gnome-session-flashback came in.

    Code:
    gnome-panel (1:3.8.1-1ubuntu2) utopic; urgency=medium
    
      * Fixes for gnome-session-flashback (LP: #1360778):
        - debian/rules: Add back symlinking code.
        - debian/patches/50_ubuntu_sessions.patch: make sure
          session file for Compiz session is installed.
      * Update previous changelog entries for proper merge.
    
     --   Sun, 24 Aug 2014 16:55:17 +0400
    It fixed this bug which was done really fast! https://bugs.launchpad.net/ubuntu/+s...l/+bug/1360778

    Quote Originally Posted by fooman View Post
    i had almost the exact same thing happen a few days ago....except it was unity that would give me the blank desktop (wallpaper was there, but no unity launcher, dash, etc..). i could only do a ctrl-alt-f1 to get to terminal, then "sudo reboot", and finally booted to gnome-shell to get to a working desktop.

    i somehow reset unity/compiz settings and all has been fine since. could be mistaken, but i think these were the commands that fixed it:

    Code:
    dconf reset -f /org/compiz/
     
    setsid unity
    btw, creating a new user resulted in a working unity desktop...it was just my user settings which failed. like i said, all is working perfectly again after resetting things.
    Thanks but I had no problem with Unity and now with the 2nd update gnome flashback (with compiz) is working great!
    I booted with systemd and all is good now.

    It was kind of weird at first with the gnome (cairo dock) small panels overlaid on the flashback top panel but clicking the mouse on them caused them to go away.

  5. #5
    Join Date
    Aug 2009
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: Updates broke gnome flashback with compiz

    An update also asked me if I wanted to use the default cairo-dock themes and I gave that a "Y" which wiped out my custom settings. It did mention that it backed my settings up though.

    I just had to find where they were and finally found them in /home/cavsfan/.config/cairo-dock/themes/Theme_20140824_111000.
    So I just had to copy the contents of that folder back into /home/cavsfan/.config/cairo-dock/current_theme logout and back in and all was back to normal.


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •