Page 1 of 4 123 ... LastLast
Results 1 to 10 of 31

Thread: Broadcom BCM43142: Ubuntu 14.04, wifi connectivity issues

  1. #1
    Join Date
    Aug 2014
    Beans
    19

    Broadcom BCM43142: Ubuntu 14.04, wifi connectivity issues

    Having problems with my wifi connecting to any websites that require username and passwords including ubuntu forums. Also having problems with yahoo, hotmail, gmail, youtube etc.,etc.. If anyone can figure out a solution, please let me know. Thanks in advance.


    Code:
    ======== Wireless-Info START ========
    
    
    System-Info ~~~~~~~~~~~~~~~~~~~~~~~~
    
    
    Superfristic 3.13.0-34-generic x86_64,  Ubuntu 14.04.1 LTS, trusty
    
    
    CPU    : Intel(R) Core(TM) i5-4200H CPU @ 2.80GHz
    Memory : 3836 MB
    Uptime : 09:24:14 up  1:19,  2 users,  load average: 0.45, 0.40, 0.49
    
    
    
    
    lspci ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    
    
    03:00.0 Network controller [0280]: Broadcom Corporation BCM43142 802.11b/g/n [14e4:4365] (rev 01)
    	Subsystem: Lite-On Communications Inc Device [11ad:6605]
    	Kernel driver in use: wl
    --
    04:00.1 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 12)
    	Subsystem: ASUSTeK Computer Inc. Device [1043:200f]
    	Kernel driver in use: r8169
    
    
    
    
    lsusb ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    
    
    Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 001 Device 004: ID 0bda:57b4 Realtek Semiconductor Corp. 
    Bus 001 Device 003: ID 04ca:2006 Lite-On Technology Corp. 
    Bus 001 Device 002: ID 093a:2510 Pixart Imaging, Inc. Optical Mouse
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    
    
    
    
    PCMCIA Card Info ~~~~~~~~~~~~~~~~~~~
    
    
    
    
    
    
    iwconfig ~~~~~~~~~~~~~~~~~~~~~~~~~~~
    
    
    wlan0     IEEE 802.11abg  ESSID:"ssbs-316"  
              Mode:Managed  Frequency:2.412 GHz  Access Point: <MAC C-01 ssbs-316>   
              Retry  long limit:7   RTS thr:off   Fragment thr:off
              Power Management:off
              
    
    
    
    
    rfkill ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    
    
          Interface               Soft blocked  Hard blocked
    0: asus-wlan: Wireless LAN        no            no
    1: asus-bluetooth: Bluetooth      no            no
    2: phy0: Wireless LAN             no            no
    3: brcmwl-0: Wireless LAN         no            no
    
    
    
    
    lsmod ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    
    
    rt61pci                32115  0 
    rt2x00pci              13287  1 rt61pci
    rt2x00mmio             13603  1 rt61pci
    rt2x00lib              55307  3 rt61pci,rt2x00pci,rt2x00mmio
    mac80211              630653  2 rt2x00lib,rt2x00pci
    eeprom_93cx6           13344  1 rt61pci
    crc_itu_t              12707  1 rt61pci
    wl                   4207846  0 
    asus_nb_wmi            16990  0 
    asus_wmi               24191  1 asus_nb_wmi
    sparse_keymap          13948  1 asus_wmi
    lib80211               14381  2 wl,lib80211_crypt_tkip
    cfg80211              484040  3 wl,mac80211,rt2x00lib
    mxm_wmi                13021  1 nouveau
    wmi                    19177  3 mxm_wmi,nouveau,asus_wmi
    video                  19476  3 i915,nouveau,asus_wmi
    
    
    
    
    module parameters ~~~~~~~~~~~~~~~~~~
    
    
    asus_nb_wmi   (1): wapf=0
    cfg80211      (2): cfg80211_disable_40mhz_24ghz=N | ieee80211_regdom=00
    mac80211      (5): beacon_loss_count=7 | ieee80211_default_rc_algo=minstrel_ht | max_nullfunc_tries=2 | max_probe_tries=5 | probe_wait_ms=500
    rt61pci       (1): nohwcrypt=Y
    video         (3): allow_duplicates=N | brightness_switch_enabled=Y | use_native_backlight=-1
    wmi           (2): debug_dump_wdg=N | debug_event=N
    
    
    
    
    nm-tool ~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    
    
    State: connected (global)
    =====================o=============o========o=====  ========o=========o===========o==============o====  =======
     Interface & ID      | Type        | Driver | State       | Default | Speed     | Support      | HW Addr   
    =====================o=============o========o=====  ========o=========o===========o==============o====  =======
     eth0                | Wired       | r8169  | unavailable | no      |           |              | <MAC eth0>
    ---------------------+-------------+--------+-------------+---------+-----------+--------------+-----------
     wlan0  [ssbs-316 1] | 802.11 WiFi | wl     | connected   | yes     | 19 Mb/s   | WEP/WPA/WPA2 | <MAC wlan0>
    
    
        IP-COM:          Infra, <MAC C-NA IP-COM 1>, Freq 2437 MHz, Rate 54 Mb/s, Strength 45
        *ssbs-316:       Infra, <MAC C-01 ssbs-316>, Freq 2412 MHz, Rate 54 Mb/s, Strength 71 WPA WPA2
    
    
        Address:         192.168.1.126
        Prefix:          24 (255.255.255.0)
        Gateway:         192.168.1.1
        DNS:             202.96.209.133
        DNS:             202.96.209.5
    ---------------------+-------------+--------+-------------+---------+-----------+--------------+-----------
    
    
    
    
    NetworkManager.state ~~~~~~~~~~~~~~~
    [main]
    NetworkingEnabled=true
    WirelessEnabled=true
    WWANEnabled=true
    WimaxEnabled=true
    
    
    
    
    NetworkManager.conf ~~~~~~~~~~~~~~~~
    
    
    [main]
    plugins=ifupdown,keyfile,ofono
    dns=dnsmasq
    
    
    [ifupdown]
    managed=false
    
    
    
    
    NM WiFi Profiles ~~~~~~~~~~~~~~~~~~~
    
    
    ssbs-316             : ssid=ssbs-316 | ipv4=auto | ipv6=auto 
    ssbs-316 1           : ssid=ssbs-316 | mac-address=<MAC wlan0> | ipv4=auto | ipv6=auto 
    
    
    
    
    interfaces ~~~~~~~~~~~~~~~~~~~~~~~~~
    
    
    # interfaces(5) file used by ifup(8) and ifdown(8)
    auto lo
    iface lo inet loopback
    
    
    resolv.conf ~~~~~~~~~~~~~~~~~~~~~~~~
    
    
    nameserver 127.0.1.1
    
    
    
    
    Routes & Ping ~~~~~~~~~~~~~~~~~~~~~~
    
    
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    0.0.0.0         0.0.0.0         0.0.0.0         U     0      0        0 tun0
    10.119.8.0      0.0.0.0         255.255.248.0   U     0      0        0 tun0
    69.50.200.241   192.168.1.1     255.255.255.255 UGH   0      0        0 wlan0
    192.168.1.0     0.0.0.0         255.255.255.0   U     9      0        0 wlan0
    
    
    
    
    iw reg get ~~~~~~~~~~~~~~~~~~~~~~~~~
    
    
    (Region : zh_CN.UTF-8)
    country 00:
    	(2402 - 2472 @ 40), (3, 20)
    	(2457 - 2482 @ 40), (3, 20), PASSIVE-SCAN, NO-IBSS
    	(2474 - 2494 @ 20), (3, 20), NO-OFDM, PASSIVE-SCAN, NO-IBSS
    	(5170 - 5250 @ 40), (3, 20), PASSIVE-SCAN, NO-IBSS
    	(5735 - 5835 @ 40), (3, 20), PASSIVE-SCAN, NO-IBSS
    
    
    
    
    iwlist chan ~~~~~~~~~~~~~~~~~~~~~~~~
    
    
    wlan0     26 channels in total; available frequencies :
              Channel 01 (2.412 GHz) - 14 (2.484 GHz)
              Channel 36 (5.18 GHz)
              Channel 38 (5.19 GHz)
              Channel 40 (5.2 GHz)
              Channel 42 (5.21 GHz)
              Channel 44 (5.22 GHz)
              Channel 46 (5.23 GHz)
              Channel 48 (5.24 GHz)
              Channel 149 (5.745 GHz)
              Channel 153 (5.765 GHz)
              Channel 157 (5.785 GHz)
              Channel 161 (5.805 GHz)
              Channel 165 (5.825 GHz)
    
    
              Current Frequency:2.412 GHz (Channel 1)
    
    
    
    
    iwlist scan ~~~~~~~~~~~~~~~~~~~~~~~~
    
    
    wlan0     Scan completed :
              Cell 01 - Address: <MAC C-01 ssbs-316>
                        Channel:1
                        Frequency:2.412 GHz (Channel 1)
                        Quality=60/70  Signal level=-50 dBm  
                        Encryption key:on
                        ESSID:"ssbs-316"
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                                  9 Mb/s; 12 Mb/s; 18 Mb/s
                        Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                        Mode:Master
                        Extra:tsf=0000000000000000
                        Extra: Last beacon: 88ms ago
                        IE: IEEE 802.11i/WPA2 Version 1
                            Group Cipher : CCMP
                            Pairwise Ciphers (1) : CCMP
                            Authentication Suites (1) : PSK
                        IE: WPA Version 1
                            Group Cipher : CCMP
                            Pairwise Ciphers (1) : CCMP
                            Authentication Suites (1) : PSK
    
    
    
    
    blacklist ~~~~~~~~~~~~~~~~~~~~~~~~~~
    
    
    [/etc/modprobe.d/blacklist-ath_pci.conf]
    blacklist ath_pci
    
    
    [/etc/modprobe.d/blacklist-bcm43.conf]
    blacklist b43
    blacklist b43legacy
    blacklist ssb
    blacklist brcm80211
    blacklist brcmfmac
    blacklist brcmsmac
    blacklist bcma
    
    
    
    
    modinfo ~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    
    
    [rt61pci]
    filename:       /lib/modules/3.13.0-34-generic/kernel/drivers/net/wireless/rt2x00/rt61pci.ko
    firmware:       rt2661.bin
    firmware:       rt2561s.bin
    firmware:       rt2561.bin
    version:        2.3.0
    srcversion:     CF4E6C5B3BC64AAF193A5A5
    depends:        rt2x00lib,rt2x00mmio,rt2x00pci,eeprom_93cx6,crc-itu-t
    parm:           nohwcrypt:Disable hardware encryption. (bool)
    
    
    [rt2x00pci]
    filename:       /lib/modules/3.13.0-34-generic/kernel/drivers/net/wireless/rt2x00/rt2x00pci.ko
    version:        2.3.0
    srcversion:     9B9D0D0D0F8571AF43705FD
    depends:        rt2x00lib,mac80211
    
    
    [rt2x00mmio]
    filename:       /lib/modules/3.13.0-34-generic/kernel/drivers/net/wireless/rt2x00/rt2x00mmio.ko
    version:        2.3.0
    srcversion:     07530604F5CE4EF69872C75
    depends:        rt2x00lib
    
    
    [rt2x00lib]
    filename:       /lib/modules/3.13.0-34-generic/kernel/drivers/net/wireless/rt2x00/rt2x00lib.ko
    version:        2.3.0
    srcversion:     CC69EE39E7D673974A21C0A
    depends:        mac80211,cfg80211
    
    
    [mac80211]
    filename:       /lib/modules/3.13.0-34-generic/kernel/net/mac80211/mac80211.ko
    srcversion:     8ADA881D348148A3358334C
    depends:        cfg80211
    parm:           max_nullfunc_tries:Maximum nullfunc tx tries before disconnecting (reason 4). (int)
    parm:           max_probe_tries:Maximum probe tries before disconnecting (reason 4). (int)
    parm:           beacon_loss_count:Number of beacon intervals before we decide beacon was lost. (int)
    parm:           probe_wait_ms:Maximum time(ms) to wait for probe response before disconnecting (reason 4). (int)
    parm:           ieee80211_default_rc_algo:Default rate control algorithm for mac80211 to use (charp)
    
    
    [eeprom_93cx6]
    filename:       /lib/modules/3.13.0-34-generic/kernel/drivers/misc/eeprom/eeprom_93cx6.ko
    version:        1.0
    srcversion:     215D8C1284A3C33B4A5A1C5
    depends:        
    
    
    [crc_itu_t]
    filename:       /lib/modules/3.13.0-34-generic/kernel/lib/crc-itu-t.ko
    srcversion:     57DB184B6F722970048006C
    depends:        
    
    
    [wl]
    filename:       /lib/modules/3.13.0-34-generic/updates/dkms/wl.ko
    srcversion:     FF25FE784DC6BDFF69DAFCB
    depends:        cfg80211,lib80211
    parm:           wl_txq_thresh:int
    parm:           oneonly:int
    parm:           piomode:int
    parm:           instance_base:int
    parm:           nompc:int
    parm:           intf_name:string
    
    
    [asus_nb_wmi]
    filename:       /lib/modules/3.13.0-34-generic/kernel/drivers/platform/x86/asus-nb-wmi.ko
    srcversion:     67514DF02FC4A206C47D0F5
    depends:        asus-wmi
    parm:           wapf:WAPF value (uint)
    
    
    [asus_wmi]
    filename:       /lib/modules/3.13.0-34-generic/kernel/drivers/platform/x86/asus-wmi.ko
    srcversion:     222BD5E26B3EE82CC433FF2
    depends:        sparse-keymap,wmi,video
    
    
    [lib80211]
    filename:       /lib/modules/3.13.0-34-generic/kernel/net/wireless/lib80211.ko
    srcversion:     84DEF767F03D28E373F18E5
    depends:        
    
    
    [cfg80211]
    filename:       /lib/modules/3.13.0-34-generic/kernel/net/wireless/cfg80211.ko
    srcversion:     E786D076B61F97809B04B64
    depends:        
    parm:           ieee80211_regdom:IEEE 802.11 regulatory domain code (charp)
    parm:           cfg80211_disable_40mhz_24ghz:Disable 40MHz support in the 2.4GHz band (bool)
    
    
    [mxm_wmi]
    filename:       /lib/modules/3.13.0-34-generic/kernel/drivers/platform/x86/mxm-wmi.ko
    srcversion:     62CBD37DE87DF0C4CD7FBA3
    depends:        wmi
    
    
    [wmi]
    filename:       /lib/modules/3.13.0-34-generic/kernel/drivers/platform/x86/wmi.ko
    srcversion:     CED5410F008DC70DF5F064B
    depends:        
    parm:           debug_event:Log WMI Events [0/1] (bool)
    parm:           debug_dump_wdg:Dump available WMI interfaces [0/1] (bool)
    
    
    [video]
    filename:       /lib/modules/3.13.0-34-generic/kernel/drivers/acpi/video.ko
    srcversion:     274A2250DEAB415D412A67C
    depends:        
    parm:           brightness_switch_enabled:bool
    parm:           allow_duplicates:bool
    parm:           use_native_backlight:int
    
    
    
    
    udev rules ~~~~~~~~~~~~~~~~~~~~~~~~~
    
    
    # PCI device 0x10ec:0x8168 (r8169)
    SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC eth0>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
    
    
    # PCI device 0x14e4:0x4365 (wl)
    SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC wlan0>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"
    
    
    
    
    Custom files/entries ~~~~~~~~~~~~~~~
    
    
    /etc/modules        : Default
    /etc/rc.local       : Default
    /etc/modprobe.d     : Not Default
    /etc/pm/(cnf|pw|sl) : Default
    
    
    [/etc/modprobe.d]
    iwlwifi.conf      : remove iwlwifi \
                        (/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
                        && /sbin/modprobe -r mac80211
    mlx4.conf         : softdep mlx4_core post: mlx4_en
    
    
    
    
    Kernel boot line ~~~~~~~~~~~~~~~~~~~
    
    
    BOOT_IMAGE=/vmlinuz-3.13.0-34-generic.efi.signed root=UUID=b0aecd0f-5d9d-466c-a221-eb72a52eb991 ro quiet splash vt.handoff=7
    
    
    
    
    dmesg ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    
    
    [    0.500135] microcode: Microcode Update Driver: v2.00 <tigran@aivazian.fsnet.co.uk>, Peter Oruba
    [    0.500339] audit: initializing netlink socket (disabled)
    [    0.649695] wmi: Mapper loaded
    [    0.661312] r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
    [    6.646292] asus_wmi: ASUS WMI generic driver loaded
    [    6.795584] asus_wmi: Initialization: 0x1
    [    6.795620] asus_wmi: BIOS WMI version: 7.9
    [    6.795661] asus_wmi: SFUN value: 0x4a0877
    [    6.796493] input: Asus WMI hotkeys as /devices/platform/asus-nb-wmi/input/input21
    [    6.802033] asus_wmi: Backlight controlled by ACPI video driver
    [    6.881936] wl: module license 'MIXED/Proprietary' taints kernel.
    [    6.883627] wl: module verification failed: signature and/or  required key missing - tainting kernel
    [    6.913160] INFO @wl_cfg80211_attach : Registered CFG80211 phy
    [    7.049740] wlan0: Broadcom BCM4365 802.11 Hybrid Wireless Controller 6.30.223.141 (r415941)
    [   16.548229] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
    [ 4749.455165] ERROR @wl_dev_intvar_get : error (-1)
    [ 4749.455172] ERROR @wl_cfg80211_get_tx_power : error (-1)
    
    
    	======== Done ========

  2. #2
    Join Date
    Aug 2014
    Beans
    19

    Re: Broadcom BCM43142: Ubuntu 14.04, wifi connectivity issues

    Can someone help me with this? I need this laptop working for work. Thanks

  3. #3
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,392
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Broadcom BCM43142: Ubuntu 14.04, wifi connectivity issues

    Why is rt61pci loading?
    rt61pci 32115 0
    rt2x00pci 13287 1 rt61pci
    rt2x00mmio 13603 1 rt61pci
    rt2x00lib 55307 3 rt61pci,rt2x00pci,rt2x00mmio
    mac80211 630653 2 rt2x00lib,rt2x00pci
    eeprom_93cx6 13344 1 rt61pci
    crc_itu_t 12707 1 rt61pci
    wl 4207846 0
    asus_nb_wmi 16990 0
    asus_wmi 24191 1 asus_nb_wmi
    sparse_keymap 13948 1 asus_wmi
    lib80211 14381 2 wl,lib80211_crypt_tkip
    cfg80211 484040 3 wl,mac80211,rt2x00lib
    mxm_wmi 13021 1 nouveau
    wmi 19177 3 mxm_wmi,nouveau,asus_wmi
    video 19476 3 i915,nouveau,asus_wmi
    Is it called in /etc/modules?
    Code:
    cat /etc/modules
    Anything you'd like to confess to the doctor under strict patient-linuxian confidentiality?
    Having problems with my wifi connecting to any websites that require username and passwords including ubuntu forums. Also having problems with yahoo, hotmail, gmail, youtube etc.,etc..
    What exactly happens or not?

    Is the firewall interfering?
    Code:
    sudo status ufw
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  4. #4
    Join Date
    Aug 2014
    Beans
    19

    Re: Broadcom BCM43142: Ubuntu 14.04, wifi connectivity issues

    Hmm, I am not sure why r61pci is loading. in cat /etc/modules, the only thing listed are lp and rtc.

    I would like to confess that I am using Broadcom 802.11 Linux STA wireless drivers from bcmwl-kernel source even though I am not sure if it is compatible with my wifi. However if I do not use this, I unable to connect to any wifi.

    When I try to connect to hotmail, enter my usrname and password, I keep getting ERR_Connection_RESET. When I try to login to ubuntu, I get ERR_EMPTY_RESPONSE, when I go to yahoo.com website, it takes forever to load and when it finish, there is broken flash and all links are on the left hand side.

  5. #5
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,392
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Broadcom BCM43142: Ubuntu 14.04, wifi connectivity issues

    I think that rt61pci and its conflicting 80211 system is part of the problem. We need to find out how it is getting loaded and stop it and reboot and then, if needed, troubleshoot from there. May we see:
    Code:
    ls /etc/modprobe.d
    cat /etc/rc.local
    I am using Broadcom 802.11 Linux STA wireless drivers from bcmwl-kernel source even though I am not sure if it is compatible with my wifi.
    It is quite correct.

    Thanks.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  6. #6
    Join Date
    Aug 2014
    Beans
    19

    Re: Broadcom BCM43142: Ubuntu 14.04, wifi connectivity issues

    Code:
    ls /etc/modprobe.d alsa-base.conf blacklist-watchdog.conf blacklist-ath_pci.conf dkms.conf blacklist-bcm43.conf fbdev-blacklist.conf blacklist.conf iwlwifi.conf blacklist-firewire.conf mlx4.conf blacklist-framebuffer.conf nvidia-340_hybrid.conf blacklist-modem.conf nvidia-graphics-drivers.conf blacklist-oss.conf vmwgfx-fbdev.conf blacklist-rare-network.conf cat /etc/rc.local #!/bin/sh -e # # rc.local # # This script is executed at the end of each multiuser runlevel. # Make sure that the script will "exit 0" on success or any other # value on error. # # In order to enable or disable this script just change the execution # bits. # # By default this script does nothing. exit 0
    This is what I get from ls /etc/modprobe.d and cat /etc/rc.local

    Also when I try to reply to posts here in Ubuntu, even though I typed in a lot more than 1 char's using my laptop, it still pops up saying I need to type more than 1 char to post. Sometimes when I post with code quotes, the code does not appear in the code box just a blank code box shows.
    Last edited by zlyspl; August 25th, 2014 at 01:53 PM.

  7. #7
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,136

    Re: Broadcom BCM43142: Ubuntu 14.04, wifi connectivity issues

    Quote Originally Posted by zlyspl View Post
    Sometimes when I post with code quotes, the code does not appear in the code box just a blank code box shows.
    Happening here with me as well since this morning (now is 8:10 pm). This is most probably happening due to the server sync issue that we were notified about a few days ago - something like "..in the process of changing server layout, users may experience a few minor glitches/problems due to the delay in the syncing of the two forum servers - bilberry and lingonberry.."

    There are other problems like unintentional multi-posting as well, I hope it's all just temporary issue that will solve itself as soon as the forum layout change is finished.

    By the way, posting just to keep track of the original issue about wifi, not to discuss the above ones.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  8. #8
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,392
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Broadcom BCM43142: Ubuntu 14.04, wifi connectivity issues

    I see no other reasons that rt61pci is loading. Is there a listing for it here?
    Code:
    cat /etc/udev/rules.d/70-persistent-net.rules
    Something like:
    Code:
    # PCI device 0x8086:0xblah (rt61pci)
    SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="58:94:6b:99:55:a0", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"
    If so, I suggest you remove the file and immediately reboot:
    Code:
    sudo rm /etc/udev/rules.d/70-persistent-net.rules
    Then check again:
    Code:
    lsmod | grep -e rt61pci -e rt2x
    If they are all gone now, how is the wireless working?
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  9. #9
    Join Date
    Aug 2014
    Beans
    19

    Re: Broadcom BCM43142: Ubuntu 14.04, wifi connectivity issues

    I did as you asked, deleted the file and rebooted the computer.

    Not getting anything from :
    Code:
    lsmod | grep -e rt61pci -e rt2x


    Typed in
    Code:
    cat /etc/udev/rules.d/70-persistent-net.rules
    again and I get

    Code:
    PCI device 0x10ec:0x8168 (r8169)
    SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="54:a0:50:0b:8b:6d", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
    
    PCI device 0x14e4:0x4365 (wl)
    SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="18:cf:5e:bf:0c:4d", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"
    Still encountering the same problems
    Last edited by zlyspl; August 26th, 2014 at 03:34 AM.

  10. #10
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,136

    Re: Broadcom BCM43142: Ubuntu 14.04, wifi connectivity issues

    I was surprised to see rt61pci myself, since there is no hint in the usual places (covered in the script report) that are used to load a module forcibly. Does it load everytime automatically or did you load it manually? Maybe following some irrelevant guide just before generating that report?

    I suggest you reboot, then without doing anything fancy, simply run -
    Code:
    lsmod | grep rt6
    Does it (rt61pci) show up again? If not, please generate a fresh wireless_script report and post it here. If it does show up, take a look at syslog for hints on why is it loading -
    Code:
    grep rt6 /var/log/syslog
    And as an attempt to get rid of it, try to blacklist it -
    Code:
    echo "blacklist rt61pci" | sudo tee -a /etc/modprobe.d/blacklist.conf
    Reboot after this, and see if the wifi works now.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

Page 1 of 4 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •