Results 1 to 10 of 26

Thread: sh file (I think it's actually a binary) can't open xterm

Threaded View

  1. #1
    Join Date
    Jul 2014
    Beans
    290

    sh file (I think it's actually a binary) can't open xterm

    Newbie here.

    Trying to help a user get their lexmark printer working in Ubuntu. Found the appropriate linux driver at lexmark and downloaded it, uncompressed it and ran the sh file as the instructions said. At first it didn't work because it was looking for bin/linux/x86/libc.so.6, so I tried creating a folder in the Downloads folder of bin/lib/x86 and created a link there to the 64-bit libc.so.6 (I thought it would at least get past this problem but give me errors as it tried to actuall use the library) - didn't work. Tried the same but in /bin - didn't work. Backed out both attempts so the folders were cleaned up.

    Opened synaptic package manager and found the package for g++ for i386 - clicked it for install and it included 2 other packages (I think 1 of those was the actual i386 support libraries). I then ran the script again and got past the initial error. I know that this is supposed to eventually open a gui to install/config the printer, but I now get an error that it can't open xterm, so I don't know if there is another (older) version I might need as the last update I can find on the net for actually installing this was back in 10.xx. The attachment is a screen capture.
    Attached Images Attached Images

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •