Results 1 to 8 of 8

Thread: Add user in User Accounts not displaying /etc/passwd users

  1. #1
    Join Date
    Mar 2013
    Beans
    11

    Add user in User Accounts not displaying /etc/passwd users

    I have created a new user and group from the cli. I needed to create the new user and group with specific IDs. They both show up in /etc/passwd and /etc/group.

    However, this user is not available to add in the Unity User Accounts gui. In fact, the drop-down is disabled.

    How can I enable this user to login to the gui?

  2. #2
    Join Date
    Jun 2010
    Location
    London, England
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Add user in User Accounts not displaying /etc/passwd users

    You could have done this through User Accounts but we need to Unlock the utility and enter our administrator password. I am assuming that you are using 14.04. There should be a button that says Unlock.
    It is a machine. It is more stupid than we are. It will not stop us from doing stupid things.
    Ubuntu user #33,200. Linux user #530,530


  3. #3
    Join Date
    Apr 2012
    Beans
    7,257

    Re: Add user in User Accounts not displaying /etc/passwd users

    What uid, specifically? is it less than the default lightdm minimum-uid?

  4. #4
    Join Date
    Mar 2013
    Beans
    11

    Re: Add user in User Accounts not displaying /etc/passwd users

    Yes, I did unlock the the utility.

    816 is the UID and GID. What is the minimum?

  5. #5
    Join Date
    Apr 2012
    Beans
    7,257

    Re: Add user in User Accounts not displaying /etc/passwd users

    I'm not sure what you mean by the Unity User Accounts gui, but afaik the default minimum-uid to get the account to display in the lightdm greeter GUI is 1000

    In 12.04, the setting is in /etc/lightdm/users.conf however I think it may have moved to somewhere in a conf.d/ directory in 14.04 - sorry I don't know for sure

    Code:
    [UserAccounts]
    minimum-uid=500

  6. #6
    Join Date
    May 2007
    Location
    The New Forest
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: Add user in User Accounts not displaying /etc/passwd users

    /etc/lightdm/users.conf
    Still the same in 14.04 and 14.10 for Xubuntu, I'd assume the same elsewhere

  7. #7
    Join Date
    Mar 2013
    Beans
    11

    Re: Add user in User Accounts not displaying /etc/passwd users

    The minimum is already set to 500 in /etc/lightdm/users.conf.

    [UserAccounts]
    minimum-uid=500
    hidden-users=nobody nobody4 noaccess
    hidden-shells=/bin/false /usr/sbin/nologin

    Last edited by larzeb; August 12th, 2014 at 12:18 AM.

  8. #8
    Join Date
    Mar 2013
    Beans
    11

    Re: Add user in User Accounts not displaying /etc/passwd users

    I noticed another post pertinent to my problem. See the response by Sebastian Tylkowski.

    I changed both the UID_MIN AND GID_MIN to 500 (both defaulted to 1000) in /etc/login.defs and my user showed up!
    Last edited by larzeb; August 12th, 2014 at 03:32 AM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •