Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Could Samba help to get difficult printer working?

  1. #11
    Join Date
    Jul 2014

    Re: Could Samba help to get difficult printer working?


    - open System Settings

    - open Printers

    - click Add

    - select the printer (may just be a raw device on a USB port)

    You may want to follow this link. While it is in a discussion about a Dell printer, judging from what it is showing I think it applies to most any printer:

    BTW - I downloaded the linux driver from lexmark but the downloaded file is actually a binary and the driver is included within that binary, and it doesn't install in newer versions of Ubuntu. Looks like the last supported was 10.xx . I tried running it but it comes up with an error - it's looking for a file in a specific system path and it's not found. I tried a find on the file name and it appears it is no longer included with Ubuntu.

    08/19/2014 EDIT: I was able to get the installer to start, but there are other errors being encountered when it actually tries to install. I have asked for help and gotten great help in a thread I opened, but no solution has been found yet. I'm keeping me fingers crossed that someone can figure something out so that if worse comes to worse we get the driver-only files loaded somehow and then let Ubuntu find the printer via the above suggestions for Printers. Don't know if that can be done either. The main problem here is that lexmark hasn't offered any updates to that driver since 2010 and for what is now a really old version of Ubuntu. It may end up not being possible.
    Last edited by dave131; August 20th, 2014 at 02:31 AM.

  2. #12
    Join Date
    Jul 2014

    Re: Could Samba help to get difficult printer working?

    I found something I need you to try as I *think* it's the driver for your printer!

    (1) go to

    This will download the driver installation file and put it in your Downloads folder.

    Now do this:

    (1) Open a terminal window - ctrl/alt/F1

    (2) Type:

    sudo dpkg -i New-lexmark-08z-series-driver-1.0-1.i386.deb.deb

    When that completes, do the following:

    (1) hook up the USB cable to your printer

    (2) go to System Settings

    (3) click on Printers

    (4) click Add

    (5) *hopefully* your printer will show in the list - click on it and follow the on-screen prompts. When it asks, try printing the test page.

    *IF* this works, you should be able to try the wireless printing next.

    Please post back with any and all results/questions.

  3. #13
    Join Date
    May 2008
    Usually northern Thailand
    Ubuntu 14.04 Trusty Tahr

    Re: Could Samba help to get difficult printer working?

    Oh, fantastic!! It works! After struggling for 2 years, finally we have success! That new driver New-lexmark-08z-series-driver-1.0.i386.deb.deb is clearly the secret that's done the trick.

    Once I had it working via USB, for the wireless, I unplugged my USB lead and used CUPS to install a new printer which I simply called "Lexmark Wireless". Using Lexmarks Windows software, I had previously set the Lexmark up to use a fixed IP address (in my case of and I'd already set my router to use that same fixed IP address. So then in CUPS I set socket:// and that was it. It did a test print via wireless without any problem. The net result is that in Settings -> Printers I now have two Printers, one is "Lexmark" which works on USB, the other is "Lexmark Wireless" and they both work equally well.

    So thank you very much Dave 131. Very good result! I'm quite curious to know where this new driver has come from and who produced it so that I can thank them.

  4. #14
    Join Date
    Jul 2014

    Re: Could Samba help to get difficult printer working?

    Here's the link to the page:

    I'm glad this worked for you! I'm just a newbie myself so this was a rather exciting thing to work on, and I'm glad someone had a solution for version 11.xx that still works now. I was able to install the driver on my PC with version 14.04 - I just don't have a printer like that to test it with - but I might assume since it did install that it might work in 14.04 as well.

    Thank you for letting me work on this with you. It's been a real learning experience for me!


    BTW if you could go to the first post on this page, select Thread Tools, then mark as solved it would be great as then others could see there is a solution.

Page 2 of 2 FirstFirst 12


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts