Results 1 to 9 of 9

Thread: Cannot get ubuntu 14 to recognise Android phone?

  1. #1
    Join Date
    Aug 2012
    Beans
    16

    Cannot get ubuntu 14 to recognise Android phone?

    I tried lsusb and it says
    humanracer@humanracer-Compaq-Mini-110c-1100:~$ lsusb
    Bus 001 Device 002: ID 058f:3831 Alcor Micro Corp.
    Bus 001 Device 053: ID 22b8:2e83 Motorola PCS
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub



    my phone is a motorola G. I cannot find the file folder on my desktop. I want to transfer mp3 files to my phone. Can this be done on ubuntu or shall I use my girlfriend's windows computer?

    Thanks

  2. #2
    Join Date
    Jan 2009
    Location
    South Carolina
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Cannot get ubuntu 14 to recognise Android phone?

    Do you have to "enable USB storage" or something similar on the Android phone?

  3. #3
    Join Date
    Jun 2007
    Location
    Porirua, New Zealand
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Cannot get ubuntu 14 to recognise Android phone?

    When I've conncected Android devices via USB, the device usually has a popup asking if I want to turn USB on. Does your phone do this? If so, have you turned USB on?
    Forum DOs and DON'Ts
    Please use CODE tags
    Including your email address in a post is not recommended
    My Blog

  4. #4
    Join Date
    Aug 2012
    Beans
    16

    Re: Cannot get ubuntu 14 to recognise Android phone?

    No it doesn't say anything like that. I have looked in the phone settings and cannot find anything.

  5. #5
    Join Date
    Jul 2014
    Location
    South Coast NSW Australia
    Beans
    38
    Distro
    Xubuntu

    Re: Cannot get ubuntu 14 to recognise Android phone?

    I use gMobileMedia from the software centre for mine. Picks up phone and does whatever you want. Worth a try with yours.

  6. #6
    Join Date
    Jun 2006
    Location
    California
    Beans
    638

    Re: Cannot get ubuntu 14 to recognise Android phone?

    Ok, on my Lg G2 with Android 4.4.2 I plug the phone into a USB port. A window pops up on the phone's screen that says, "Select USB connection". The choices are:

    Charge Phone
    Media Sync (MTP)
    LG Software
    Send Images (PTP)

    To copy files to my phone I select "Media Sync (MTP)".

    If you don't see that window, you should see a USB icon in the notification area at the top of your phone's screen. Pull down from the top of the screen to show your notifications and select the USB icon that says, "USB Connected" which will open the window I mentioned above.

  7. #7
    Join Date
    Dec 2005
    Location
    Western Australia
    Beans
    11,480
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Cannot get ubuntu 14 to recognise Android phone?

    I have a Moto G like you, and Ubuntu 14.04.

    When I plug the phone in it displays a quick notification about "Media Transfer Active" or something like that. Then the phone appears at the bottom of the Ubuntu launcher.

    If none of this happens, try plugging the phone into a different port directly on your computer.

  8. #8
    Join Date
    Aug 2013
    Beans
    17

    Re: Cannot get ubuntu 14 to recognise Android phone?

    You may have to enable usb debugging on your phone. Its under developer options which is hidden on recent versions of android.

    A quick internet search for "enable usb debugging moto g" shows a number of sites with instructions.

  9. #9
    Join Date
    Jan 2010
    Location
    Hyperborea
    Beans
    2,049
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Cannot get ubuntu 14 to recognise Android phone?

    I have a Moto G and I too was puzzled by it not appearing in Nautilus. The answer is to go to Settings then Storage and select the Storage settings (the three dots in the top right corner). Then "USB connection" and choose "Camera(PTP)" instead of "Media Device (MTP)". Hope this helps.

    Edit: To clarify, I mean the Settings on the phone not your PC
    Last edited by coldraven; July 17th, 2014 at 10:30 AM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •