Results 1 to 6 of 6

Thread: 12.04 server wireless won't work

  1. #1
    Join Date
    Sep 2013
    Beans
    12

    12.04 server wireless won't work

    I have a reason for doing wireless on a file server box - really! It's an older box. I bought a D-Link DWA-552 for it. I'm attempting to connect with WPA2-PSK [AES].

    It works just fine from a live disk Ubuntu, but in server it knows the card is there but won't connect. I've Googled hard for help and tried a bunch of stuff. Nothing works.

    Here's my /etc/network/interfaces file:
    Code:
    # The loopback network interface
    auto lo
    iface lo inet loopback
    
    # The primary network interface
    #auto eth0
    #iface eth0 inet dhcp
    
    # Wireless
    auto wlan0
    iface wlan0 inet static
    address 192.168.1.101
    netmask 255.255.255.0
    gateway 192.168.1.1
    wpa-driver wext
    wpa-ssid numberone
    wpa-ap-scan 1
    wpa-proto RSN
    wpa-pairwise CCMP
    wpa-group CCMP
    wpa-key-mgmt WPA-PSK
    wpa-psk c7d301308817...more hex numbers
    Also tried this:
    Code:
    # The loopback network interface
    auto lo
    iface lo inet loopback
    
    # The primary network interface
    #auto eth0
    #iface eth0 inet dhcp
    
    # Wireless
    auto wlan0
    iface wlan0 inet dhcp
    wpa-driver wext
    wpa-ssid numberone
    wpa-ap-scan 1
    wpa-proto RSN
    wpa-pairwise CCMP
    wpa-group CCMP
    wpa-key-mgmt WPA-PSK
    wpa-psk c7d301308817...more hex numbers
    Anyway, I can see the box in the router's attached devices list, but it has no IP, and isn't connected properly. I'm so close...
    Last edited by futz2; July 13th, 2014 at 01:07 AM.

  2. #2
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    24,669
    Distro
    Ubuntu 18.10 Cosmic Cuttlefish

    Re: 12.04 server wireless won't work

    I suggest you try this:
    Code:
    # The loopback network interface
    auto lo
    iface lo inet loopback
    
    # The primary network interface
    #auto eth0
    #iface eth0 inet dhcp
    
    # Wireless
    auto wlan0
    iface wlan0 inet static
    address 192.168.1.101
    netmask 255.255.255.0
    gateway 192.168.1.1
    wpa-ssid numberone
    wpa-psk c7d301308817...more hex numbers
    dns-nameservers 8.8.8.8 192.168.1.1
    I assume that this is your actual key in plain text and not some translated super encrypted wacky key:
    c7d301308817...more hex numbers
    Restart the interface:
    Code:
    sudo ifdown wlan0 && sudo ifup -v wlan0
    Check:
    Code:
    ping -c3 192.168.1.1
    ping -c3 www.google.com
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  3. #3
    Join Date
    Sep 2013
    Beans
    12

    Re: 12.04 server wireless won't work

    Quote Originally Posted by chili555 View Post
    I suggest you try this:
    Thank you Chili555!!! Using my passphrase in plain text cured it.

    I kept seeing people saying to use wpa-passphrase to convert it to numbers. Obviously that's just plain wrong.

    Here's my working interfaces file:
    Code:
    # Wireless
    auto wlan0
    iface wlan0 inet dhcp
    wpa-ssid numberone
    wpa-ap-scan 1
    wpa-proto RSN
    wpa-pairwise CCMP
    wpa-group CCMP
    wpa-key-mgmt WPA-PSK
    wpa-psk "my_passphrase_in_plain_text"
    Probably I can thin that down some more, looking at your suggested input. I'll test that next. But for now it's working! Yee haw!
    Last edited by futz2; July 13th, 2014 at 02:44 AM.

  4. #4
    Join Date
    Sep 2013
    Beans
    12

    Re: 12.04 server wireless won't work

    Yup, it can be thinned down. Still works just fine like this:
    Code:
    # Wireless
    auto wlan0
    iface wlan0 inet dhcp
    wpa-ssid numberone
    wpa-psk "my_passphrase_in_plain_text"

  5. #5
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    24,669
    Distro
    Ubuntu 18.10 Cosmic Cuttlefish

    Re: 12.04 server wireless won't work

    Quote Originally Posted by futz2 View Post
    Yup, it can be thinned down. Still works just fine like this:
    Code:
    # Wireless
    auto wlan0
    iface wlan0 inet dhcp
    wpa-ssid numberone
    wpa-psk "my_passphrase_in_plain_text"
    It certainly can, however, I think you want a static IP for a server so you can find it for ssh and ftp. As well, unless you disable DNS caching and populate /etc/resolv.conf, you need dns-nameservers for a static setup. You do not need:
    wpa-ap-scan 1
    wpa-proto RSN
    wpa-pairwise CCMP
    wpa-group CCMP
    Less is more.

    Glad it's working. Please use thread tools at the top to mark Solved. The searchers will appreciate it.
    Last edited by chili555; July 13th, 2014 at 03:02 AM.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  6. #6
    Join Date
    Sep 2013
    Beans
    12

    Re: 12.04 server wireless won't work

    Quote Originally Posted by chili555 View Post
    It certainly can, however, I think you want a static IP for a server so you can find it for ssh and ftp.
    For now I'm just telling the router DHCP to always give that MAC address the same IP. When I install the box at the "customer's" house (friend of mine) I'll decide what works best for his router.

    I'll also do some testing with static IPs on my router as well. Haven't set up many static IPs on it before. I usually just do the above-mentioned thing. It's got a zillion settings though, so I should have no problem getting that working.

    Glad it's working. Please use thread tools at the top to mark Solved. The searchers will appreciate it.
    Will do. Thanks so much for your help.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •