Results 1 to 2 of 2

Thread: Steam segmentation fault on startup - Ubuntu Gnome 14.04

  1. #1
    Join Date
    Jul 2014

    Exclamation Steam segmentation fault on startup - Ubuntu Gnome 14.04


    I've just installed Steam and it crashes after updating its files.

    The terminal spits out the following:
    /.steam/ line 755:  4131 Segmentation fault      (core dumped) $STEAM_DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"
    I've seen many threads with a similar problem but it always seems to come down to an AMD or NVIDIA driver problem.
    I have an intel card and running the latest open source driver.

    I was hoping someone could point me in the right direction in terms of troubleshooting.

    I'm using an Asus Zenbook Prime UX31A which has Intel HD4000 video.
    I'm running Ubuntu Gnome 14.04
    I've tried uninstalling and reinstalling Steam of course; from both the website and from the software center.

    What would be my next step?
    (pls let me know any commands needed to get extra information)

    Thanks in advance!

  2. #2
    Join Date
    Mar 2011
    Ubuntu 16.04 Xenial Xerus

    Re: Steam segmentation fault on startup - Ubuntu Gnome 14.04

    When I'm trying to troubleshoot Python 2.7 segmentation faults I use the tip I found here ..

    i.e. temporarily patch /usr/share/pyshared/gobject/

    I run a simple python script to set/reset the patch.

    Note that while the patch is in use other Python apps may not run.
    So after troubleshooting Steam reset to default value.


    set temporary patch in
    launch Steam to pin down the source of the segmentation fault
    reset to default content.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts