Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: 14.04 & Audacity problem

  1. #1
    Join Date
    Feb 2009
    Beans
    44

    14.04 & Audacity problem

    I installed audacity from the software center & I'm getting the following error when I try to start audacity from a terminal:

    Code:
    audacity: error while loading shared libraries: libid3tag.so.0: wrong ELF class: ELFCLASS32
    Can anyone help me with this? I did a search on the internet & didn't get very far. I did read that this may be saying that my system is 64 bit & I'm trying to use 32 bit libraries. But I didn't install those libraries.

    Any help would be appreciated.

    Thanks

  2. #2
    Join Date
    Jun 2007
    Beans
    16,077

    Re: 14.04 & Audacity problem

    Maybe start here to see what you do have installed -
    Code:
    apt-cache policy libid3tag0 audacity

  3. #3
    Join Date
    Feb 2009
    Beans
    44

    Re: 14.04 & Audacity problem

    Here is the output:

    Code:
    libid3tag0:
      Installed: 0.15.1b-10ubuntu1
      Candidate: 0.15.1b-10ubuntu1
      Version table:
     *** 0.15.1b-10ubuntu1 0
            500 http://us.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
            100 /var/lib/dpkg/status
    audacity:
      Installed: 2.0.5-1ubuntu3.2
      Candidate: 2.0.5-1ubuntu3.2
      Version table:
     *** 2.0.5-1ubuntu3.2 0
            500 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/universe amd64 Packages
            100 /var/lib/dpkg/status
         2.0.5-1ubuntu3 0
            500 http://us.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
    Does this give any useful information?

  4. #4
    Join Date
    Jun 2007
    Beans
    16,077

    Re: 14.04 & Audacity problem

    Quote Originally Posted by Qu4rk View Post
    Here is the output:
    ...

    Does this give any useful information?
    No that looks normal.
    How about these -
    Code:
    which audacity
    If it says /usr/bin/audacity then -
    Code:
    ldd /usr/bin/audacity
    Code:
    apt-cache policy libwxgtk*

  5. #5
    Join Date
    Feb 2009
    Beans
    44

    Re: 14.04 & Audacity problem

    I did those:

    Code:
    which audacity
    Code:
    /usr/bin/audacity
    Code:
    ldd /usr/bin/audacity
    Code:
    	linux-vdso.so.1 =>  (0x00007fff76b68000)
    	libwx_gtk2u_html-2.8.so.0 => /usr/lib/x86_64-linux-gnu/libwx_gtk2u_html-2.8.so.0 (0x00007f4e803c0000)
    	libwx_gtk2u_adv-2.8.so.0 => /usr/lib/x86_64-linux-gnu/libwx_gtk2u_adv-2.8.so.0 (0x00007f4e800e0000)
    	libwx_gtk2u_core-2.8.so.0 => /usr/lib/x86_64-linux-gnu/libwx_gtk2u_core-2.8.so.0 (0x00007f4e7faf8000)
    	libwx_baseu_net-2.8.so.0 => /usr/lib/x86_64-linux-gnu/libwx_baseu_net-2.8.so.0 (0x00007f4e7f8c8000)
    	libwx_baseu-2.8.so.0 => /usr/lib/x86_64-linux-gnu/libwx_baseu-2.8.so.0 (0x00007f4e7f578000)
    	libvorbisenc.so.2 => /usr/lib/x86_64-linux-gnu/libvorbisenc.so.2 (0x00007f4e7f0a8000)
    	libvorbisfile.so.3 => /usr/lib/x86_64-linux-gnu/libvorbisfile.so.3 (0x00007f4e7eea0000)
    	libvorbis.so.0 => /usr/lib/x86_64-linux-gnu/libvorbis.so.0 (0x00007f4e7ec70000)
    	libogg.so.0 => /usr/lib/x86_64-linux-gnu/libogg.so.0 (0x00007f4e7ea60000)
    	libmad.so.0 => /usr/lib/x86_64-linux-gnu/libmad.so.0 (0x00007f4e7e840000)
    	libsndfile.so.1 => /usr/lib/x86_64-linux-gnu/libsndfile.so.1 (0x00007f4e7e5d8000)
    	libFLAC++.so.6 => /usr/lib/x86_64-linux-gnu/libFLAC++.so.6 (0x00007f4e7e3b8000)
    	libFLAC.so.8 => /usr/lib/x86_64-linux-gnu/libFLAC.so.8 (0x00007f4e7e180000)
    	libid3tag.so.0 => not found
    	libsoxr.so.0 => /usr/lib/x86_64-linux-gnu/libsoxr.so.0 (0x00007f4e7df38000)
    	libsbsms.so.10 => /usr/lib/x86_64-linux-gnu/libsbsms.so.10 (0x00007f4e7dce0000)
    	libSoundTouch.so.0 => /usr/lib/x86_64-linux-gnu/libSoundTouch.so.0 (0x00007f4e7dad0000)
    	libvamp-hostsdk.so.3 => /usr/lib/x86_64-linux-gnu/libvamp-hostsdk.so.3 (0x00007f4e7d888000)
    	libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f4e7d680000)
    	libexpat.so.1 => /lib/x86_64-linux-gnu/libexpat.so.1 (0x00007f4e7d450000)
    	libtwolame.so.0 => /usr/lib/libtwolame.so.0 (0x00007f4e7d228000)
    	libavcodec.so.54 => /usr/lib/x86_64-linux-gnu/libavcodec.so.54 (0x00007f4e7c4d0000)
    	libavformat.so.54 => /usr/lib/x86_64-linux-gnu/libavformat.so.54 (0x00007f4e7c1a8000)
    	libavutil.so.52 => /usr/lib/x86_64-linux-gnu/libavutil.so.52 (0x00007f4e7bf80000)
    	libportSMF.so.0 => /usr/lib/x86_64-linux-gnu/libportSMF.so.0 (0x00007f4e7bd58000)
    	libportaudio.so.2 => /usr/lib/x86_64-linux-gnu/libportaudio.so.2 (0x00007f4e7bb28000)
    	libasound.so.2 => /usr/lib/x86_64-linux-gnu/libasound.so.2 (0x00007f4e7b838000)
    	libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f4e7b618000)
    	libmp3lame.so.0 => /usr/lib/x86_64-linux-gnu/libmp3lame.so.0 (0x00007f4e7b388000)
    	libgtk-x11-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0 (0x00007f4e7ad48000)
    	libgdk-x11-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgdk-x11-2.0.so.0 (0x00007f4e7aa90000)
    	libgobject-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0 (0x00007f4e7a838000)
    	libglib-2.0.so.0 => /lib/x86_64-linux-gnu/libglib-2.0.so.0 (0x00007f4e7a530000)
    	libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f4e7a228000)
    	libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f4e79f20000)
    	libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f4e79d08000)
    	libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f4e79940000)
    	libgdk_pixbuf-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgdk_pixbuf-2.0.so.0 (0x00007f4e79718000)
    	libpango-1.0.so.0 => /usr/lib/x86_64-linux-gnu/libpango-1.0.so.0 (0x00007f4e794c8000)
    	libXinerama.so.1 => /usr/lib/x86_64-linux-gnu/libXinerama.so.1 (0x00007f4e792c0000)
    	libXxf86vm.so.1 => /usr/lib/x86_64-linux-gnu/libXxf86vm.so.1 (0x00007f4e790b8000)
    	libSM.so.6 => /usr/lib/x86_64-linux-gnu/libSM.so.6 (0x00007f4e78eb0000)
    	libpng12.so.0 => /lib/x86_64-linux-gnu/libpng12.so.0 (0x00007f4e78c88000)
    	libjpeg.so.8 => /usr/lib/x86_64-linux-gnu/libjpeg.so.8 (0x00007f4e78a30000)
    	libtiff.so.5 => /usr/lib/x86_64-linux-gnu/libtiff.so.5 (0x00007f4e787b8000)
    	libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f4e78598000)
    	libgomp.so.1 => /usr/lib/x86_64-linux-gnu/libgomp.so.1 (0x00007f4e78388000)
    	/lib64/ld-linux-x86-64.so.2 (0x00007f4e80690000)
    	libxvidcore.so.4 => /usr/lib/x86_64-linux-gnu/libxvidcore.so.4 (0x00007f4e78048000)
    	libx264.so.142 => /usr/lib/x86_64-linux-gnu/libx264.so.142 (0x00007f4e77cb0000)
    	libvpx.so.1 => /usr/lib/x86_64-linux-gnu/libvpx.so.1 (0x00007f4e778d0000)
    	libtheoraenc.so.1 => /usr/lib/x86_64-linux-gnu/libtheoraenc.so.1 (0x00007f4e77690000)
    	libtheoradec.so.1 => /usr/lib/x86_64-linux-gnu/libtheoradec.so.1 (0x00007f4e77470000)
    	libspeex.so.1 => /usr/lib/x86_64-linux-gnu/libspeex.so.1 (0x00007f4e77250000)
    	libschroedinger-1.0.so.0 => /usr/lib/x86_64-linux-gnu/libschroedinger-1.0.so.0 (0x00007f4e76f88000)
    	libopus.so.0 => /usr/lib/x86_64-linux-gnu/libopus.so.0 (0x00007f4e76d40000)
    	libopenjpeg.so.2 => /usr/lib/x86_64-linux-gnu/libopenjpeg.so.2 (0x00007f4e76b18000)
    	libgsm.so.1 => /usr/lib/x86_64-linux-gnu/libgsm.so.1 (0x00007f4e76908000)
    	libva.so.1 => /usr/lib/x86_64-linux-gnu/libva.so.1 (0x00007f4e766f0000)
    	librtmp.so.0 => /usr/lib/x86_64-linux-gnu/librtmp.so.0 (0x00007f4e764d0000)
    	libgnutls.so.26 => /usr/lib/x86_64-linux-gnu/libgnutls.so.26 (0x00007f4e76210000)
    	libbz2.so.1.0 => /lib/x86_64-linux-gnu/libbz2.so.1.0 (0x00007f4e76000000)
    	librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f4e75df8000)
    	libjack.so.0 => /usr/lib/x86_64-linux-gnu/libjack.so.0 (0x00007f4e75b98000)
    	libgmodule-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgmodule-2.0.so.0 (0x00007f4e75990000)
    	libpangocairo-1.0.so.0 => /usr/lib/x86_64-linux-gnu/libpangocairo-1.0.so.0 (0x00007f4e75780000)
    	libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007f4e75448000)
    	libXfixes.so.3 => /usr/lib/x86_64-linux-gnu/libXfixes.so.3 (0x00007f4e75240000)
    	libatk-1.0.so.0 => /usr/lib/x86_64-linux-gnu/libatk-1.0.so.0 (0x00007f4e75018000)
    	libcairo.so.2 => /usr/lib/x86_64-linux-gnu/libcairo.so.2 (0x00007f4e74d08000)
    	libgio-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0 (0x00007f4e74990000)
    	libpangoft2-1.0.so.0 => /usr/lib/x86_64-linux-gnu/libpangoft2-1.0.so.0 (0x00007f4e74778000)
    	libfontconfig.so.1 => /usr/lib/x86_64-linux-gnu/libfontconfig.so.1 (0x00007f4e74538000)
    	libXrender.so.1 => /usr/lib/x86_64-linux-gnu/libXrender.so.1 (0x00007f4e74328000)
    	libXi.so.6 => /usr/lib/x86_64-linux-gnu/libXi.so.6 (0x00007f4e74118000)
    	libXrandr.so.2 => /usr/lib/x86_64-linux-gnu/libXrandr.so.2 (0x00007f4e73f08000)
    	libXcursor.so.1 => /usr/lib/x86_64-linux-gnu/libXcursor.so.1 (0x00007f4e73cf8000)
    	libXcomposite.so.1 => /usr/lib/x86_64-linux-gnu/libXcomposite.so.1 (0x00007f4e73af0000)
    	libXdamage.so.1 => /usr/lib/x86_64-linux-gnu/libXdamage.so.1 (0x00007f4e738e8000)
    	libXext.so.6 => /usr/lib/x86_64-linux-gnu/libXext.so.6 (0x00007f4e736d0000)
    	libffi.so.6 => /usr/lib/x86_64-linux-gnu/libffi.so.6 (0x00007f4e734c8000)
    	libpcre.so.3 => /lib/x86_64-linux-gnu/libpcre.so.3 (0x00007f4e73288000)
    	libthai.so.0 => /usr/lib/x86_64-linux-gnu/libthai.so.0 (0x00007f4e73078000)
    	libICE.so.6 => /usr/lib/x86_64-linux-gnu/libICE.so.6 (0x00007f4e72e58000)
    	libuuid.so.1 => /lib/x86_64-linux-gnu/libuuid.so.1 (0x00007f4e72c50000)
    	liblzma.so.5 => /lib/x86_64-linux-gnu/liblzma.so.5 (0x00007f4e72a28000)
    	libjbig.so.0 => /usr/lib/x86_64-linux-gnu/libjbig.so.0 (0x00007f4e72818000)
    	liborc-0.4.so.0 => /usr/lib/x86_64-linux-gnu/liborc-0.4.so.0 (0x00007f4e72590000)
    	libgcrypt.so.11 => /lib/x86_64-linux-gnu/libgcrypt.so.11 (0x00007f4e72310000)
    	libtasn1.so.6 => /usr/lib/x86_64-linux-gnu/libtasn1.so.6 (0x00007f4e720f8000)
    	libp11-kit.so.0 => /usr/lib/x86_64-linux-gnu/libp11-kit.so.0 (0x00007f4e71eb0000)
    	libfreetype.so.6 => /usr/lib/x86_64-linux-gnu/libfreetype.so.6 (0x00007f4e71c08000)
    	libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007f4e719e8000)
    	libpixman-1.so.0 => /usr/lib/x86_64-linux-gnu/libpixman-1.so.0 (0x00007f4e71738000)
    	libxcb-shm.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-shm.so.0 (0x00007f4e71530000)
    	libxcb-render.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-render.so.0 (0x00007f4e71320000)
    	libselinux.so.1 => /lib/x86_64-linux-gnu/libselinux.so.1 (0x00007f4e710f8000)
    	libresolv.so.2 => /lib/x86_64-linux-gnu/libresolv.so.2 (0x00007f4e70ed8000)
    	libharfbuzz.so.0 => /usr/lib/x86_64-linux-gnu/libharfbuzz.so.0 (0x00007f4e70c80000)
    	libdatrie.so.1 => /usr/lib/x86_64-linux-gnu/libdatrie.so.1 (0x00007f4e70a78000)
    	libgpg-error.so.0 => /lib/x86_64-linux-gnu/libgpg-error.so.0 (0x00007f4e70870000)
    	libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007f4e70668000)
    	libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007f4e70460000)
    	libgraphite2.so.3 => /usr/lib/x86_64-linux-gnu/libgraphite2.so.3 (0x00007f4e70240000)
    Code:
    apt-cache policy libwxgtk*
    Code:
    libwxgtk2.8-dbg:
      Installed: (none)
      Candidate: 2.8.12.1+dfsg-2ubuntu2
      Version table:
         2.8.12.1+dfsg-2ubuntu2 0
            500 http://us.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
    libwxgtk2.8-dev:
      Installed: (none)
      Candidate: 2.8.12.1+dfsg-2ubuntu2
      Version table:
         2.8.12.1+dfsg-2ubuntu2 0
            500 http://us.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
    libwxgtk2.6-0-python:
      Installed: (none)
      Candidate: (none)
      Version table:
    libwxgtk-media3.0-0:
      Installed: (none)
      Candidate: 3.0.0-2
      Version table:
         3.0.0-2 0
            500 http://us.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
    libwxgtk-media3.0-dev:
      Installed: (none)
      Candidate: 3.0.0-2
      Version table:
         3.0.0-2 0
            500 http://us.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
    libwxgtk3.0-0-dbg:
      Installed: (none)
      Candidate: 3.0.0-2
      Version table:
         3.0.0-2 0
            500 http://us.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
    libwxgtk-media3.0-0-dbg:
      Installed: (none)
      Candidate: 3.0.0-2
      Version table:
         3.0.0-2 0
            500 http://us.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
    libwxgtk-media2.8-dbg:
      Installed: (none)
      Candidate: 2.8.12.1+dfsg-2ubuntu2
      Version table:
         2.8.12.1+dfsg-2ubuntu2 0
            500 http://us.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
    libwxgtk-media2.8-0:
      Installed: (none)
      Candidate: 2.8.12.1+dfsg-2ubuntu2
      Version table:
         2.8.12.1+dfsg-2ubuntu2 0
            500 http://us.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
    libwxgtk-media2.8-dev:
      Installed: (none)
      Candidate: 2.8.12.1+dfsg-2ubuntu2
      Version table:
         2.8.12.1+dfsg-2ubuntu2 0
            500 http://us.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
    libwxgtk3.0-0:
      Installed: (none)
      Candidate: 3.0.0-2
      Version table:
         3.0.0-2 0
            500 http://us.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
    libwxgtk2.4-python:
      Installed: (none)
      Candidate: (none)
      Version table:
    libwxgtk3.0-dev:
      Installed: (none)
      Candidate: 3.0.0-2
      Version table:
         3.0.0-2 0
            500 http://us.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
    libwxgtk2.8-0:
      Installed: 2.8.12.1+dfsg-2ubuntu2
      Candidate: 2.8.12.1+dfsg-2ubuntu2
      Version table:
     *** 2.8.12.1+dfsg-2ubuntu2 0
            500 http://us.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
            100 /var/lib/dpkg/status
    Any advice?

  6. #6
    Join Date
    Jun 2007
    Beans
    12,689

    Re: 14.04 & Audacity problem

    You didn't happen to install a 32-bit version, did you? ( https://bugs.debian.org/cgi-bin/bugr...cgi?bug=698959 )
    Code:
    apt-cache policy libid3tag0:i386

  7. #7
    Join Date
    Feb 2009
    Beans
    44

    Re: 14.04 & Audacity problem

    I installed Audacity from the Software Center. I'm not sure how what Libraries are/were installed. The output of the following command:

    Code:
    apt-cache policy libid3tag0:i386
    is

    Code:
    libid3tag0:i386:
      Installed: (none)
      Candidate: 0.15.1b-10ubuntu1
      Version table:
         0.15.1b-10ubuntu1 0
            500 http://us.archive.ubuntu.com/ubuntu/ trusty/main i386 Packages
    Since I installed it from the Software Center, I thought everything would take care of itself.

  8. #8
    Join Date
    Jun 2007
    Beans
    16,077

    Re: 14.04 & Audacity problem

    libid3tag.so.0 => not found
    (should return "libid3tag.so.0 => /usr/lib/libid3tag.so.0 ..."
    Could you check 2 things
    Code:
     ls -R /usr/local/lib
    Code:
    file /usr/lib/libid3tag.so.0.3.0
    maybe also
    Code:
    find / -name 'libid3tag.so.0' 2>/dev/null
    Last edited by mc4man; July 5th, 2014 at 11:34 PM.

  9. #9
    Join Date
    Feb 2009
    Beans
    44

    Re: 14.04 & Audacity problem

    Code:
    ls -R /usr/local/lib
    Code:
    /usr/local/lib:
    python2.7  python3.4
    
    /usr/local/lib/python2.7:
    dist-packages  site-packages
    
    /usr/local/lib/python2.7/dist-packages:
    
    /usr/local/lib/python2.7/site-packages:
    
    /usr/local/lib/python3.4:
    dist-packages
    
    /usr/local/lib/python3.4/dist-packages:
    Code:
    file /usr/lib/libid3tag.so.0.3.0
    Code:
    /usr/lib/libid3tag.so.0.3.0: ELF 32-bit LSB  shared object, Intel 80386, version 1 (SYSV), dynamically linked, BuildID[sha1]=39a916ff741fdcc2516feb46f6bf4e165399b9ba, stripped
    Code:
    find / -name 'libid3tag.so.0' 2>/dev/null
    Code:
    /usr/lib/libid3tag.so.0

  10. #10
    Join Date
    Jun 2007
    Beans
    16,077

    Re: 14.04 & Audacity problem

    Then just go ahead & remove audacity & libid3tag0 packages
    Code:
    sudo apt-get purge audacity  libid3tag0
    Then clean
    Code:
    sudo apt-get clean
    check that there is no libid3tag.so.0 file anymore with the find command (if still there then remove manually
    Then re-install
    Code:
    sudo apt-get install audacity

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •