Results 1 to 3 of 3

Thread: dovecot fails to create socket /var/spool/postfix/private/auth

  1. #1
    Join Date
    Apr 2006
    Location
    Sydney, Australia
    Beans
    269
    Distro
    Ubuntu Kylin 19.10 Eoan Ermine

    dovecot fails to create socket /var/spool/postfix/private/auth

    After following this link http://wiki2.dovecot.org/HowTo/PostfixAndDovecotSASL to configure devecot with postfix I've found the problem that dovecot does not create the socket "/var/spool/postfix/private/auth" at startup.

    There are no errors in any of the logs as to the cause of this, so am somewhat stumped as to how this can be resolved

    Thanks

  2. #2
    Join Date
    May 2014
    Beans
    1

    Re: dovecot fails to create socket /var/spool/postfix/private/auth

    I followed the ubuntu server guide and it am having the similar problem.

    try:
    https://help.ubuntu.com/14.04/server...roubleshooting

    You should run "tail -f /var/log/mail.err" This will tell you why it is not working.

    When i run it i get this message postfix/smtpd[20866]: fatal: no SASL authentication mechanisms.

    i think /etc/dovecot/conf.d/10-master.cf holds the key to the configuration. But when I run "service dovecot status"
    i get "stopped/waiting" and there is no dovecot file in /etc/init.d/.

    I hope this helps?

  3. #3
    Join Date
    Apr 2006
    Location
    Sydney, Australia
    Beans
    269
    Distro
    Ubuntu Kylin 19.10 Eoan Ermine

    Re: dovecot fails to create socket /var/spool/postfix/private/auth

    The problem was that the following line was missing from my dovecot.conf

    !include conf.d/*.conf

    I found this by invoking the following

    dovecot -n

    which shows the non default setting

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •