Results 1 to 9 of 9

Thread: [lubuntu 14.04] Keyboard layout

  1. #1
    Join Date
    Jul 2013
    Beans
    7

    [lubuntu 14.04] Keyboard layout

    Hello,
    I set my keyboard layout manager on french and russian (fr, ru). It has been quite unstable, yet usable, until I disconnected from the session. I could not enter my password to enter a new session, so I put the english layout, my password worked and:
    1. All my system had turned to english!
    2. there seems to be no way to use FR and RU again, the layout it is stuck on english (US). Note that the keyboard layout manager still shows french and russian with a Alt+Shift toggle...
    My /etc/default/keyboard looks well set:
    HTML Code:
    XKBMODEL="pc105"
    XKBLAYOUT="fr, ru"
    XKBVARIANT=""
    XKBOPTIONS="grp:alt_shift_toggle,grp_led:scroll"
    when I try:
    HTML Code:
     setxkbmap -option grp:alt_shift_toggle "fr,ru"
    or:
    HTML Code:
    setxkbmap -layout "fr,ru" -option "grp:alt_shift_toggle"
    I get this:
    HTML Code:
    Error loading new keyboard description
    In /usr/share/X11/xkb/symbols, the fr and ru files are here, although I have made a few modifications to the fr keyboard.
    Thank you in advance.
    Last edited by Kifferand; May 24th, 2014 at 11:46 PM.

  2. #2
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: [lubuntu 14.04] Keyboard layout

    If you right click on the keyboard layout in the panel > Keyboard Layout handler Settings, can you choose your keyboard layout, or add or move up one already there ?

    The system language is in Prefs > Language Support.
    Attached Images Attached Images
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests / username changes by PM, thanks. |
    [SIGPIC][/SIGPIC]

  3. #3
    Join Date
    Jul 2013
    Beans
    7

    Re: [lubuntu 14.04] Keyboard layout

    Thank you,
    Everything was set as I wanted in the Keyboard Layout handler Settings.
    I saw that I'm far from being the only one to have this problem. It is a well-known bug.
    I decided to reinstall lubuntu and just set one quick time the keyboard layouts I need. Then I won't touch it until the bug is solved. It's been an hour and so far it works.

  4. #4
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: [lubuntu 14.04] Keyboard layout

    Question is now if the settings are going to stick after a session logout or a reboot.
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests / username changes by PM, thanks. |
    [SIGPIC][/SIGPIC]

  5. #5
    Join Date
    Jul 2013
    Beans
    7

    Re: [lubuntu 14.04] Keyboard layout

    I've been rebooting around five times today, and it still works. I'll write here if I encounter the same problem again.
    Thanks !

  6. #6
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: [lubuntu 14.04] Keyboard layout

    Glad to know you fixed it so far. Please do not hesitate to post again.
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests / username changes by PM, thanks. |
    [SIGPIC][/SIGPIC]

  7. #7
    Join Date
    Apr 2008
    Location
    Winchester, UK
    Beans
    272
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: [lubuntu 14.04] Keyboard layout

    Yes. Seems to be a bug in the install.

    I chose UK keyboard during Lubuntu 14.04 Install but I ended up with US keyboard.

    I changed the the key layout of the keyboard as follows:

    right mouse click on the US icon at the RHS of the taskbar
    click "Keyboard Layout Handler" Settings
    in the Keyboard Layout Handler window
    click + Add gb English(uk) then OK
    click us then click - Remove
    click Close
    ASUS ZenBook UX305 (Intel® Core™ M-5Y10c ) CPU @ 0.80GHz × 4, 8GiB RAM, 128GiB SSD, Ubuntu 16.04 & W10.
    MSi CR620 (Novatech i3 Core i3-350M) 2.27GHz 2GiB RAM, 250GiB SSD, Ubuntu 16.04.

  8. #8
    Join Date
    Jun 2014
    Beans
    2

    Re: [lubuntu 14.04] Keyboard layout

    When i write:

    setxkbmap -option grp:alt_shift_toggle "fr,ru"
    in console return error

  9. #9
    Join Date
    Apr 2008
    Location
    Winchester, UK
    Beans
    272
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: [lubuntu 14.04] Keyboard layout

    Did you carry out the suggestion in my message #7 immediately before yours?
    The changes for you should be:
    click + Add re .... (or similar to add russian keyboard) then click OK
    click fr then click - Remove
    ASUS ZenBook UX305 (Intel® Core™ M-5Y10c ) CPU @ 0.80GHz × 4, 8GiB RAM, 128GiB SSD, Ubuntu 16.04 & W10.
    MSi CR620 (Novatech i3 Core i3-350M) 2.27GHz 2GiB RAM, 250GiB SSD, Ubuntu 16.04.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •