Results 1 to 3 of 3

Thread: can't install nvidia driver on MacBook Pro 9,1

  1. #1
    Join Date
    May 2009
    Austin, Texas USA
    Ubuntu 14.04 Trusty Tahr

    can't install nvidia driver on MacBook Pro 9,1

    I'm trying to get the proprietary nvidia driver working on my MBP running Ubuntu 14.04. I was previously successful in disabling the nvidia card and running only the Intel card, but it seemed unable to support an external monitor. So to reduce power consumption some, I disabled the integrated card:

    # cat /sys/kernel/debug/vgaswitcheroo/switch 
    0:IGD: :Off:0000:00:02.0
    2:DIS-Audio: :Pwr:0000:01:00.1
    However, I have several issues with the nouveau driver so I'm trying to get the nvidia driver to work. I have had no problems installing through the "additional drivers" dialog on my desktop, but the MBP didn't seem to respond so well to that. After a quick google search, I tried to follow this guide, but it doesn't seem to work for me:

    Specifically, my system failed to find the nvidia-xconfig command anywhere. I have tried installing both the nvidia-current package (which installed nvidia-304) and the nvidia-331-updates package. As you can see, the nvidia-331-updates package is currently installed right now, but the xconfig-command just isn't in my PATH for some reason:

    bdmayes@bdmlinux:~$ dpkg -l | grep nvidia
    rc  nvidia-304                                            304.117-0ubuntu1                                    amd64        NVIDIA legacy binary driver - version 304.117
    rc  nvidia-331                                            331.38-0ubuntu7                                     amd64        NVIDIA binary driver - version 331.38
    ii  nvidia-331-updates                                    331.38-0ubuntu7                                     amd64        NVIDIA binary driver - version 331.38
    rc  nvidia-libopencl1-304                                 304.117-0ubuntu1                                    amd64        NVIDIA OpenCL Driver and ICD Loader library
    rc  nvidia-libopencl1-331                                 331.38-0ubuntu7                                     amd64        NVIDIA OpenCL Driver and ICD Loader library
    ii  nvidia-libopencl1-331-updates                         331.38-0ubuntu7                                     amd64        NVIDIA OpenCL Driver and ICD Loader library
    rc  nvidia-opencl-icd-304                                 304.117-0ubuntu1                                    amd64        NVIDIA OpenCL ICD
    rc  nvidia-opencl-icd-331                                 331.38-0ubuntu7                                     amd64        NVIDIA OpenCL ICD
    ii  nvidia-opencl-icd-331-updates                         331.38-0ubuntu7                                     amd64        NVIDIA OpenCL ICD
    ii  nvidia-prime                                          0.6.2                                               amd64        Tools to enable NVIDIA's Prime
    ii  nvidia-settings                                       331.20-0ubuntu8                                     amd64        Tool for configuring the NVIDIA graphics driver
    bdmayes@bdmlinux:~$ nvidia-xconfig
    nvidia-xconfig: command not found

    No problem, I eventually found it under /usr/lib/nvidia-331-updates/bin and ran it manually. It generated the following xorg.conf:

    $ cat /etc/X11/xorg.conf
    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig:  version 331.38  (buildmeister@swio-display-x64-rhel04-15)  Wed Jan  8 19:53:14 PST 2014
    Section "ServerLayout"
        Identifier     "Default Layout"
        Screen         "Default Screen" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
    Section "InputDevice"
        # generated from default
        Identifier     "Keyboard0"
        Driver         "keyboard"
    Section "InputDevice"
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    Section "Device"
        Identifier     "Nvidia GT650M"
        Driver         "nvidia"
    Section "Screen"
        Identifier     "Default Screen"
        Device         "Nvidia GT650M"
        Option         "UseDPLib" "off"
        SubSection     "Display"
            Modes      "nvidia-auto-select"

    Looks like it already has UseDpLib off as an option so there is nothing to do there. I then modified my boot options as instructed and ran update-grub:

    $ grep "i915" /etc/default/grub
    GRUB_CMDLINE_LINUX_DEFAULT="elevator=deadline i915.lvds_channel_mode=2 i915.modeset=0 i915.lvds_use_ssc=0"

    Now that I have rebooted, I find the nvidia driver isn't loaded and nouveau is still running:

    bdmayes@bdmlinux:~$ lsmod | grep nvidia
    bdmayes@bdmlinux:~$ glxinfo | grep vendor
    server glx vendor string: SGI
    client glx vendor string: Mesa Project and SGI
    OpenGL vendor string: nouveau
    If I try to blacklist nouveau by putting the following in /etc/modprobe.d/blacklist.conf

    blacklist nouveau
        blacklist lbm-nouveau
        options nouveau modeset=0
        alias nouveau off
        alias lbm-nouveau off
    then it just fails to load any graphical interface after booting up and drops me to a tty. I'm also getting some rather odd messages in dmesg surrounding the nvidia and i915 stuff:

    [    6.028147] nvidia: module license 'NVIDIA' taints kernel.
    [    6.028152] Disabling lock debugging due to kernel taint
    [    6.031787] nvidia: module verification failed: signature and/or  required key missing - tainting kernel
    [    6.034993] nvidia 0000:01:00.0: enabling device (0006 -> 0007)
    [    6.238296] ------------[ cut here ]------------
    [    6.238323] WARNING: CPU: 7 PID: 427 at /build/buildd/linux-3.13.0/drivers/gpu/drm/i915/intel_dp.c:440 intel_dp_aux_ch+0x126/0x690 [i915]()
    [    6.238325] dp_aux_ch not started status 0xffffffff
    [    6.238326] Modules linked in: lib80211_crypt_tkip intel_rapl(+) x86_pkg_temp_thermal intel_powerclamp kvm_intel kvm crct10dif_pclmul crc32_pclmul ghash_clmulni_intel aesni_intel aes_x86_64 lrw gf128mul glue_helper ablk_helper cryptd wl(POF+) lib80211 cfg80211 binfmt_misc mei_me(+) mei lpc_ich(+) snd_hda_intel(+) snd_hda_codec snd_hwdep snd_pcm snd_page_alloc snd_seq_midi snd_seq_midi_event snd_rawmidi snd_seq snd_seq_device nvidia(POF+) snd_timer apple_gmux parport_pc snd i915(+) ppdev soundcore video apple_bl drm_kms_helper mac_hid drm i2c_algo_bit nls_iso8859_1 applesmc input_polldev coretemp lp parport tg3 firewire_ohci ahci ptp sdhci_pci firewire_core libahci pps_core sdhci crc_itu_t
    [    6.238359] CPU: 7 PID: 427 Comm: systemd-udevd Tainted: PF          O 3.13.0-24-generic #47-Ubuntu
    [    6.238360] Hardware name: Apple Inc. MacBookPro9,1/Mac-4B7AC7E43945597E, BIOS MBP91.88Z.00D3.B08.1208081132 08/08/2012
    [    6.238361]  0000000000000009 ffff880455e75688 ffffffff81715ac4 ffff880455e756d0
    [    6.238381]  ffff880455e756c0 ffffffff810676bd 0000000000000000 0000000000000005
    [    6.238383]  ffff880455e2c000 0000000000000003 0000000000000000 ffff880455e75720
    [    6.238386] Call Trace:
    [    6.238392]  [<ffffffff81715ac4>] dump_stack+0x45/0x56
    [    6.238396]  [<ffffffff810676bd>] warn_slowpath_common+0x7d/0xa0
    [    6.238398]  [<ffffffff8106772c>] warn_slowpath_fmt+0x4c/0x50
    [    6.238417]  [<ffffffffa017e216>] intel_dp_aux_ch+0x126/0x690 [i915]
    [    6.238439]  [<ffffffffa01a4242>] ? gen6_read32+0x52/0x110 [i915]
    [    6.238454]  [<ffffffffa017dfdf>] ? ironlake_edp_have_panel_power+0x3f/0x50 [i915]
    [    6.238468]  [<ffffffffa0180be8>] intel_dp_i2c_aux_ch+0xb8/0x2d0 [i915]
    [    6.238473]  [<ffffffffa0124159>] i2c_dp_aux_add_bus+0x39/0x50 [drm_kms_helper]
    [    6.238487]  [<ffffffffa01824d7>] intel_dp_init_connector+0x2f7/0x720 [i915]
    [    6.238500]  [<ffffffffa00c5edb>] ? drm_mode_object_get+0x5b/0x70 [drm]
    [    6.238509]  [<ffffffffa00c5cc2>] ? drm_modeset_unlock_all+0x52/0x60 [drm]
    [    6.238519]  [<ffffffffa00c6000>] ? drm_encoder_init+0x80/0x90 [drm]
    [    6.238531]  [<ffffffffa0182a12>] intel_dp_init+0x112/0x180 [i915]
    [    6.238545]  [<ffffffffa016e057>] intel_setup_outputs+0x3d7/0x750 [i915]
    [    6.238558]  [<ffffffffa01720c7>] intel_modeset_init+0x607/0x8f0 [i915]
    [    6.238566]  [<ffffffffa00bd9cb>] ? drm_irq_install+0x13b/0x250 [drm]
    [    6.238578]  [<ffffffffa0134064>] i915_driver_load+0xbb4/0xe70 [i915]
    [    6.238595]  [<ffffffffa00c0ce2>] drm_dev_register+0xa2/0x1e0 [drm]
    [    6.238603]  [<ffffffffa00c2be2>] drm_get_pci_dev+0x92/0x140 [drm]
    [    6.238615]  [<ffffffffa013067c>] i915_pci_probe+0x3c/0x90 [i915]
    [    6.238618]  [<ffffffff813a2255>] local_pci_probe+0x45/0xa0
    [    6.238621]  [<ffffffff813a34f5>] ? pci_match_device+0xc5/0xd0
    [    6.238624]  [<ffffffff813a3619>] pci_device_probe+0xd9/0x130
    [    6.238628]  [<ffffffff8148eb95>] driver_probe_device+0x125/0x3b0
    [    6.238631]  [<ffffffff8148eef3>] __driver_attach+0x93/0xa0
    [    6.238634]  [<ffffffff8148ee60>] ? __device_attach+0x40/0x40
    [    6.238637]  [<ffffffff8148cb03>] bus_for_each_dev+0x63/0xa0
    [    6.238640]  [<ffffffff8148e54e>] driver_attach+0x1e/0x20
    [    6.238643]  [<ffffffff8148e130>] bus_add_driver+0x180/0x250
    [    6.238646]  [<ffffffffa01f1000>] ? 0xffffffffa01f0fff
    [    6.238649]  [<ffffffff8148f574>] driver_register+0x64/0xf0
    [    6.238652]  [<ffffffffa01f1000>] ? 0xffffffffa01f0fff
    [    6.238655]  [<ffffffff813a1bec>] __pci_register_driver+0x4c/0x50
    [    6.238662]  [<ffffffffa00c2daa>] drm_pci_init+0x11a/0x130 [drm]
    [    6.238665]  [<ffffffffa01f1000>] ? 0xffffffffa01f0fff
    [    6.238677]  [<ffffffffa01f106a>] i915_init+0x6a/0x6c [i915]
    [    6.238681]  [<ffffffff8100214a>] do_one_initcall+0xfa/0x1b0
    [    6.238685]  [<ffffffff810598d3>] ? set_memory_nx+0x43/0x50
    [    6.238689]  [<ffffffff810e1d4d>] load_module+0x12dd/0x1b40
    [    6.238692]  [<ffffffff810dd7d0>] ? store_uevent+0x40/0x40
    [    6.238696]  [<ffffffff810e2726>] SyS_finit_module+0x86/0xb0
    [    6.238699]  [<ffffffff817266bf>] tracesys+0xe1/0xe6
    [    6.238701] ---[ end trace 8e37bbe9c3e6d8d6 ]---
    [   22.570148] init: Failed to spawn nvidia-persistenced main process: unable to execute: No such file or directory
    [   22.573404] init: nvidia-prime main process (1746) terminated with status 1

    Does anyone know how to make this work on this Macbook? Installing the nvidia drivers on my desktop system was a breeze and it just worked. I have no clue what is going on here. For now I removed the blacklisting of the nouveau drivers so that I can at least use the laptop.
    If all else fails, use fire.

  2. #2
    Join Date
    Aug 2013

    Re: can't install nvidia driver on MacBook Pro 9,1

    Is this problem solved yet? I would like to know the solution.

  3. #3
    Join Date
    May 2009
    Austin, Texas USA
    Ubuntu 14.04 Trusty Tahr

    Re: can't install nvidia driver on MacBook Pro 9,1

    Unfortunately, no. I have never been able to get this to work.
    If all else fails, use fire.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts