Results 1 to 7 of 7

Thread: Electric sheep in 14.04

  1. #1
    Join Date
    Aug 2013
    Beans
    12

    Electric sheep in 14.04

    Did anyone get electric sheep to work in Ubuntu Unity 14.04 ?
    If you did , please share. I have tried everything i can , google it follow bur reports , but no fix so far .
    I really like it and miss it .

  2. #2
    Join Date
    Aug 2013
    Location
    Colorado, US
    Beans
    222
    Distro
    Ubuntu Mate 18.04 Bionic Beaver

    Re: Electric sheep in 14.04

    Maybe a list of the guides you have tried would help as we don't know what you have tried and everyday more guides are posted. Here is one have you tried this one.

    http://www.distrogeeks.com/install-l...csheep-ubuntu/
    We all know Linux is great... it does infinite loops in 5 seconds.
    - Linus Torvald

  3. #3
    Join Date
    Aug 2013
    Beans
    4,369

  4. #4
    Join Date
    Aug 2013
    Beans
    12

    Re: Electric sheep in 14.04

    Well , thanks folks . So due to a bug evn if i do compile it myself it wont work .
    I also found tread on Electricsheep websitee , where compiling with custom settings and flags does not work yet.
    Thank you folks , i guess i will just have wait little more .

  5. #5
    Join Date
    Feb 2012
    Beans
    5

    Re: Electric sheep in 14.04 (Method may work for you too)

    UPDATE:

    On a fresh install of Ubuntu 14.04 (w/Unity) the following packages were required (w/links)

    (WARNING: know your architecture or you'll break your packages(can be found within :
    Code:
    uname -a
    ) )

    libavutil51 - i386 or amd64
    libavformat53 - i386 or amd64
    libavcodec53 - i386 or amd64
    electricsheep - i386 or amd64

    I recommend using gdebi, availible through the normal software channels.

    The result is a functioning version of the program (can be launched via command line, or a desktop entry can be made (see below)). It still doesn't have the full functionality available for windows, mac, or android versions (though I haven't tested the latter). Nothing broke my packages when the architecture was taken into account. I did run updates during the install of these .debs with --fix-missing and -f install.

    I am looking into how to package these all together. If anyone knows how to package .deb's together, please let me know, and I'll put out the complete package asap. When I am not in the middlelof school. I will look at getting full functioning going.

    -------------------------------------------------------------------------------------------------------------------

    Hello All,

    I figured there would be some interest in this. I have managed to compile by using an older version of the package : https://launchpad.net/ubuntu/+source/electricsheep (you will have to find the package for your architecture).

    Download the .deb. After that, use a package installer (I really suggest gdebi ).

    It will kick back errors. You're going to have to hunt out those packages which it requires.

    Most should be availible through the repositories. Some, such as libav...52 and 53 are no longer shipped.

    There happens to be this awesome package archiving website I just found (I'd save this one to bookmarks) : pkgs.org

    By recursively looking at what packages are required by electricsheep, those required by those, etc... you can get it up and running in about 15 minutes.

    I have spent hours before trying to get electricsheep to work. This is a flawless method. One the installation goes off, find a good logo, make a desktop entry for electricsheep and electricsheep-preferences, and enjoy the fractaline beauty (I also suggest enabling a fullscreen keyboard shortcut so that you can enjoy mplayer in full).

    Just as a breif poll: Anyone interested in getting the electricsheep repository back on-line? Or would appreciate it if it was? I don't think there is too much more that would need to be packaged along to get it running in 14.04/10.

    Also, I have been toying around with gnome integration, again, if anyone is interested.
    Last edited by dkz666; September 25th, 2014 at 12:06 AM. Reason: Update

  6. #6
    Join Date
    Jan 2011
    Beans
    1

    Re: Electric sheep in 14.04

    Would LOVE for electric sheep to be back in the repositories!

  7. #7
    Join Date
    Oct 2014
    Beans
    1

    Re: Electric sheep in 14.04

    ive managed to successfully compile ES for both my Desktop 14.04 and my girlfriends EFI Samsung laptop.
    By using aptitude to downgrade packages that its dependent on (done on 64 bit machines despite the i386 thing)

    https://launchpad.net/ubuntu/saucy/i386/curl
    https://launchpad.net/ubuntu/saucy/i386/debconf
    https://launchpad.net/ubuntu/saucy/i386/gconf2
    https://translations.launchpad.net/ubuntu/saucy
    https://launchpad.net/ubuntu/saucy/i386/libavcodec53
    https://launchpad.net/ubuntu/saucy/i386/libavformat53
    https://launchpad.net/ubuntu/saucy/i386/libc6
    https://launchpad.net/ubuntu/saucy/i386/libexpat1
    https://launchpad.net/ubuntu/saucy/i386/libglade2-0
    https://launchpad.net/ubuntu/saucy/i386/libgtk2.0-0
    https://launchpad.net/ubuntu/saucy/i386/libjpeg-progs
    https://launchpad.net/ubuntu/saucy/i386/xloadimage

    Autoreconf was important but rest is as per distrogeeks.
    .

    Then i re-installed Ubuntu to all new again, and the same "make" compiled code worked for sudu make install.... Viola.
    .
    i am wondering if i upload this compiled "make" that other may be able to use it

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •