Results 1 to 5 of 5

Thread: Weird coloring of the forums header in Firefox

  1. #1
    Join Date
    Jul 2011
    Location
    /Europe/Netherlands
    Beans
    401
    Distro
    Kubuntu 14.04 Trusty Tahr

    Weird coloring of the forums header in Firefox

    I have a weird Firefox issue with colors on some pages. On these forums the orange looks darker and the header has 2 colors now. It seems to be an issue with my current install of Firefox but I haven't located the source of the problem yet. I'm quite sure it's a local issue as I have tried a few things:

    - Firefox on a new user account -> normal colors
    - Other browsers (Chromium and Konqueror) -> normal colors

    This I have tried to fix the problem on my personal Firefox:

    - Restart with add-ons disabled -> colors still weird.
    - Clear browser cache -> colors still weird.

    My system:
    Kubuntu 14.04 (Upgrade from 13.10, problem existed before upgrade)
    Firefox 29 (problem also on Firefox 28)

    Maybe this thread is in the wrong place as the issues I probably not with the code of the forums, but still I'd appreciate some pointers on how to tackle this issue

    Some screenshots to illustrate the problem:

    Add-ons disabled
    http://imgur.com/C4Cs8Hm

    Comparison of Firefox and Chromium
    http://imgur.com/UiYq1dS

    Firefox on fresh user profile on same system.
    http://imgur.com/wV1jiV2
    "I believe humans get a lot done, not because we're smart, but because we have thumbs so we can make coffee." --Flash Rosenberg

  2. #2
    Join Date
    Mar 2011
    Location
    Saint Peter, MN
    Beans
    94

    Re: Weird coloring of the forums header in Firefox

    Have you tried re-installing FireFox in it's entirety? Might be a specific strange setting that has it confused but if you do a full re-install I'd assume a fresh FireFox install wouldn't have the problem? Just some thoughts good luck!

  3. #3
    Join Date
    Jul 2008
    Location
    The Left Coast of the USA
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: Weird coloring of the forums header in Firefox

    Moved to General Help.

    This is an issue with your browser, not with the Forums site itself.
    My Blog
    Ubuntu Help Pages I'm constructing: AMDGPU and AMDGPU-PRO
    Don't let the truth get in the way of a good story!
    This universe is crazy. I'm going back to my own.


  4. #4
    Join Date
    Apr 2005
    Location
    Finland/UK
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Weird coloring of the forums header in Firefox

    Firefox correcltly handles color profiles and gamma values stored in .png images, which is great for photographs but can cause that kind of issues if your computer's color management isn't quite correctly configured (or more often if the web designer doesn't know what color correction and profiles are, and the actual images on the page have strange profiles).

    Anyway, the settings in Firefox can be tweaked through about:config page, but I'd actually recommend getting this nice extension instead: https://addons.mozilla.org/en-US/fir...or-management/. If you've set up a color calibration in Ubuntu's color options, set firefox to use the same color profile (it should do it by default ut that doesn't seem to quite work...). Or, if you prefer, just set it to not use color profiles at all, in whch case you of course won't get accurate colors on photographs and such, but web site graphics will look ok (even though the colors won't be correct, they will at least be icorrect in the same way as with any other browser )

    edit: Here's a better and more detailed explanation about the problem you're seeing: http://www.metalvortex.com/blog/2012/03/16/831.html
    Last edited by mcduck; May 7th, 2014 at 04:42 PM.

  5. #5
    Join Date
    Jul 2011
    Location
    /Europe/Netherlands
    Beans
    401
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: Weird coloring of the forums header in Firefox

    Update
    @mcduck Thanks for your explanation. I haven't done anything with the color profiles manually ever, but could it be that having 2 monitors automatically changes the color profile? It can't be a coincidence that when I unplug my second monitor (different in resolution from my primary monitor) the colors on the forums are back to normal again.
    "I believe humans get a lot done, not because we're smart, but because we have thumbs so we can make coffee." --Flash Rosenberg

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •