Results 1 to 3 of 3

Thread: 14.04 - Cannot connect to VPN with either Open or PPTP

  1. #1
    Join Date
    Apr 2014

    Cool 14.04 - Cannot connect to VPN with either Open or PPTP

    I have just upgraded to Ubuntu GNOME 14.04. I have an existing account through PIA and now I can no longer connect to it. The VPN works on all other systems in the house so I know there is no problem there. I have tried both the OpenVPN option as well as PPTP and neither connects for some reason. I notice that on the PIA website the most current instructions they have for OpenVPN is Ubuntu 12.04. For PPTP it is Ubuntu 10.10. I have tried contacting their "tech support" but they really aren't much help.

    Does anyone here have any experience with this? Any help is greatly appreciated!

  2. #2
    Join Date
    May 2014

    Re: 14.04 - Cannot connect to VPN with either Open or PPTP

    I'd like to echo this post. To provide more information:

    This problem started immediately after upgrading to 14.04.
    I can connect just fine to the VPN server. Once connected I have no access to the internet. This occurs on PPTP and OpenVPN, and other systems are able to use the VPN connections fine.
    I have tried completely purging the system of OpenVPN, then reinstalling. I have tried multiple servers with two protocols. I have disabled IPv6. This problem occurs on multiple WANs.
    I suspect a routing problem.

    Any thoughts?

  3. #3
    Join Date
    Mar 2014

    Re: 14.04 - Cannot connect to VPN with either Open or PPTP

    Maybe this will solve the problem for you, for PPTP:

    When configuring your VPN connection, in the "Advanced" dialog, be sure that you UN-CHECK the PAP, CHAP, and EAP boxes, AND THEN check the "Use point-to-point encryption" box. If you don't do those things in that order, NetworkManager will incorrectly leave PAP, CHAP, and EAP enabled. (It appears PAP, CHAP, and EAP are not OK to have enabled when MPPE is in use, but I'm not sure why that is.) Further details follow.

    I can confirm that PPTP connections that work on 13.10 did NOT work for me when configured identically on a new install of 14.04. When I tried to connect on the 14.04 machine, I immediately get a toast saying "The VPN connection failed."

    However, I WAS able to connect manually using the pptp-linux package and the instructions here:

    That led me to investigate the config data a bit, and I found at that the pptp-linux configuration had the options refuse-eap, refuse-chap, and refuse-pap enabled. Those options were also enabled for the NetworkManager PPTP connection on the 13.10 box, but were NOT enabled in the PPTP configuration on the 14.04 box. So I added the following lines to the file /etc/NetworkManager/system-connections/MyVPNConnection:

    After that, the connection succeeded.

    Then I realized that when I checked the "point-to-point encryption" box in the VPN configuration, it disabled the PAP, CHAP, and EAP check-boxes, but it did not un-check them. So they stay enabled, even though they look like they aren't.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts