Results 1 to 10 of 10

Thread: Headless server doesn't connect to NIC

  1. #1
    Join Date
    Apr 2006
    Beans
    284
    Distro
    Ubuntu Gnome Development Release

    Headless server doesn't connect to NIC

    I just upgraded from Precise LTS to Trusty LTS.
    Now, unless i attach a monitor and keyboard and login, the server won't log into my network because eth0 fails.
    I get this message as the system loads: "no talloc stackframe at ../source3/param/loadparm.c:4864, leaking memory"
    And then I cannot ping the server. I cannot SSH into it. If I attach a monitor and keyboard and log in as a user and when I issue the command: "lshw -C network", I only get the configuration of l0
    If I "sudo ifup eth0 restart", then I get the "no talloc stackframe at ../source3/param/loadparm.c:4864, leaking memory" warning, but eth0 does start.

    Is there a workaround for this problem?

  2. #2
    Join Date
    Jun 2011
    Beans
    413
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Headless server doesn't connect to NIC

    Which NIC is it?? You could try to manually load the NIC module:

    sudo modeprobe nicdriver (e1000e is for intel GB NIC)

    sudo ifconfig eth0 up && dhclient eth0 (to bring up the NIC device and get an IP via DHCP)

    ping www.ubuntu.com

    if it fails please post the errors.

    - HTH

  3. #3
    Join Date
    Feb 2011
    Location
    Coquitlam, B.C. Canada
    Beans
    2,337
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Headless server doesn't connect to NIC

    I think the error message might be unrelated, and due to samba. See this.
    Any follow-up information on your issue would be appreciated. Please have the courtesy to report back.

  4. #4
    Join Date
    Jun 2011
    Beans
    413
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Headless server doesn't connect to NIC

    Ah ok - thanks - comment 14 have a workaround: https://bugs.launchpad.net/ubuntu/+s...86/comments/14

  5. #5
    Join Date
    Apr 2006
    Beans
    284
    Distro
    Ubuntu Gnome Development Release

    Re: Headless server doesn't connect to NIC

    Quote Originally Posted by Gyokuro View Post
    Ah ok - thanks - comment 14 have a workaround: https://bugs.launchpad.net/ubuntu/+s...86/comments/14
    Thanks, running "pam-auth-update" and remove "SMB password synchronization" solved the memory leak error, BUT still, in order to get the eth0 (which is an embedded chip on the MB) to work, I have to log in and issue the command "sudo ifup eth0 start".
    This is a headless server and should automatically start the network interfaces.

  6. #6
    Join Date
    Jun 2011
    Beans
    413
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Headless server doesn't connect to NIC

    Hi

    Do you have already checked/compared the setting of /etc/network/interfaces as I have already checked bug reports of ifup/ifdown problems but nothing interesting as it seems you are at the moment the only one with this problem. Another try could be that you make a clean install of a 14.04 server install in a VM and compare the usual places like /etc/network/interfaces as I think it's only a small bug in 14.04 which do not bring up your NIC at boot time (either an upstart problem or in the ifup/ifdown scripts).

  7. #7
    Join Date
    Apr 2006
    Beans
    284
    Distro
    Ubuntu Gnome Development Release

    Re: Headless server doesn't connect to NIC

    Quote Originally Posted by Gyokuro View Post
    Hi

    Do you have already checked/compared the setting of /etc/network/interfaces as I have already checked bug reports of ifup/ifdown problems but nothing interesting as it seems you are at the moment the only one with this problem. Another try could be that you make a clean install of a 14.04 server install in a VM and compare the usual places like /etc/network/interfaces as I think it's only a small bug in 14.04 which do not bring up your NIC at boot time (either an upstart problem or in the ifup/ifdown scripts).
    This looks OK, doesn't it?
    ::::::::::::::
    interfaces
    ::::::::::::::
    # This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).

    # The loopback network interface
    auto lo
    iface lo inet loopback

    # The primary network interface
    iface eth0 inet static
    address 192.168.15.15
    netmask 255.255.255.0
    # network 192.168.15.0
    # broadcast 192.168.15.255
    gateway 192.168.15.254
    # dns-nameservers 8.8.8.8

    # This is an autoconfigured IPv6 interface
    # iface eth0 inet6 auto

  8. #8
    Join Date
    Jan 2006
    Location
    Not heaven... Iowa
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Headless server doesn't connect to NIC

    Add eth0 to the auto line, or add an auto line to eth0 definition.
    Code:
     auto lo eth0
    or
    Code:
    # The primary network interface
    auto eth0
    iface eth0 inet static
    (not both)
    Last edited by Iowan; May 4th, 2014 at 04:40 PM.
    Linux User #415691 Ubuntu User #8629
    Iowa Team (LoCo): [Wiki] [Launchpad]
    IRC channel: #ubuntu-us-ia on irc.freenode.net

  9. #9
    Join Date
    Jun 2011
    Beans
    413
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Headless server doesn't connect to NIC

    Hi

    As notes by Iowan your lines should look like following:

    # The loopback network interface
    auto lo
    iface lo inet loopback

    # The primary network interface
    iface eth0 inet static
    address 192.168.15.15
    netmask 255.255.255.0
    # network 192.168.15.0
    # broadcast 192.168.15.255
    gateway 192.168.15.254
    # dns-nameservers 8.8.8.8

    # This is an autoconfigured IPv6 interface
    # iface eth0 inet6 auto

  10. #10
    Join Date
    Apr 2006
    Beans
    284
    Distro
    Ubuntu Gnome Development Release

    Re: Headless server doesn't connect to NIC

    Quote Originally Posted by Iowan View Post
    Add eth0 to the auto line, or add an auto line to eth0 definition.
    Code:
     auto lo eth0
    Worked like a charm. Can't believe I screwed that up. Thank you so much!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •