Results 1 to 2 of 2

Thread: nvidia-prime and optimus notebook

  1. #1
    renato3 is offline Oops! My Coffee Cup is empty.
    Join Date
    Aug 2013
    Beans
    58

    nvidia-prime and optimus notebook

    Hi, I'm using Ubuntu 14.04 on a Dell Inspiron 14R 5421. I have two cards, integrated Intel and dedicated Nvidia GT 730M. I installed the proprietay nvidia 331.38 by going on Settings --> Softwares & update --> Additional Drivers. Here is a print screen:



    Then I installed prime-indicator to be able to rapid switch between intel and nvidia cards. My Nvidia X Server settings was like this image (this is not a printscreen of mine, but it was very similar to this):



    glxgears was showing high FPS. EVERYTHING WAS PERFECT! But then I installed a LOT of packages, I removed the package linux-image-generic (because apt-get was complaining it was safe to remove) and now my nvidia card is not working anymore and I don't know exactly why

    prime-indicator icon is gone and my Nvidia X Server settings now look like this:



    How can I revert things back as they were, without making a clean install? I guess I have to purge some packages and reinstall them, right? Which packages should I purge and reinstall?
    Last edited by renato3; May 2nd, 2014 at 06:12 AM. Reason: solved

  2. #2
    renato3 is offline Oops! My Coffee Cup is empty.
    Join Date
    Aug 2013
    Beans
    58

    Re: nvidia-prime and optimus notebook

    Code:
    $ sudo apt-get purge nvidia-331 nvidia-opencl-icd-331 nvidia-settings nvidia-libopencl1-331 nvidia-prime prime-indicator
    $ sudo apt-get install nvidia-331 nvidia-opencl-icd-331 nvidia-settings nvidia-libopencl1-331 nvidia-prime prime-indicator
    Everything is back to normal now!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •