Page 4 of 5 FirstFirst ... 2345 LastLast
Results 31 to 40 of 44

Thread: Audacity under Trusty Tahr: Building it with FFmpeg

  1. #31
    Join Date
    Jan 2014
    Location
    UK
    Beans
    78
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: Audacity under Trusty Tahr: Building it with FFmpeg

    Quote Originally Posted by pcrolandhu View Post
    I ran it as you sad
    Post the output from this command:-
    Code:
    sudo apt-get -y install libwxgtk2.8-0 libwxgtk2.8-dev libsndfile1-dev \
    libsoxr-dev libexpat1-dev libgtk2.0-dev libasound2-dev libmad0-dev \
    libportaudio-dev libflac++-dev libid3tag0-dev libsbsms-dev libsoundtouch-dev \
    libtwolame-dev libportaudio-dev libmp3lame-dev libid3tag0-dev libfaac-dev \
    libopencore-amrnb-dev libopencore-amrwb-dev

  2. #32
    Join Date
    May 2014
    Beans
    4

    Re: Audacity under Trusty Tahr: Building it with FFmpeg

    Code:
    pc@roland:~$ sudo apt-get -y install libwxgtk2.8-0 libwxgtk2.8-dev libsndfile1-dev \
    > libsoxr-dev libexpat1-dev libgtk2.0-dev libasound2-dev libmad0-dev \
    > libportaudio-dev libflac++-dev libid3tag0-dev libsbsms-dev libsoundtouch-dev \
    > libtwolame-dev libportaudio-dev libmp3lame-dev libid3tag0-dev libfaac-dev \
    > libopencore-amrnb-dev libopencore-amrwb-dev
    [sudo] password for pc: 
    Csomaglisták olvasása... Kész
    Függőségi fa építése       
    Állapotinformációk olvasása... Kész
    libasound2-dev már a legújabb verzió.
    libexpat1-dev már a legújabb verzió.
    libflac++-dev már a legújabb verzió.
    libgtk2.0-dev már a legújabb verzió.
    libid3tag0-dev már a legújabb verzió.
    libsndfile1-dev már a legújabb verzió.
    libmad0-dev már a legújabb verzió.
    libmp3lame-dev már a legújabb verzió.
    libopencore-amrnb-dev már a legújabb verzió.
    libopencore-amrwb-dev már a legújabb verzió.
    libportaudio-dev már a legújabb verzió.
    libsbsms-dev már a legújabb verzió.
    libsoundtouch-dev már a legújabb verzió.
    libsoxr-dev már a legújabb verzió.
    libtwolame-dev már a legújabb verzió.
    libwxgtk2.8-0 már a legújabb verzió.
    libwxgtk2.8-dev már a legújabb verzió.
    libfaac-dev már a legújabb verzió.
    A következő csomagok automatikusan lettek telepítve, és már nincs rájuk szükség:
      hyphen-en-us kde-l10n-engb kde-l10n-hu libkateinterfaces4 libnetpbm10
      libportsmf0 libvamp-hostsdk3 mythes-en-au netpbm openoffice.org-hyphenation
    Ezeket az „apt-get autoremove” paranccsal törölheti.
    0 frissített, 0 újonnan telepített, 0 eltávolítandó és 0 nem frissített.
    pc@roland:~$
    English translate:
    már a legújabb verzió -> is the latest version
    A következő csomagok automatikusan lettek telepítve, és már nincs rájuk szükség -> The following packages were automaticly installed...
    Last edited by pcrolandhu; May 3rd, 2014 at 01:36 AM.

  3. #33
    Join Date
    Jan 2014
    Location
    UK
    Beans
    78
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: Audacity under Trusty Tahr: Building it with FFmpeg

    Quote Originally Posted by pcrolandhu View Post
    English translate...
    Looks OK.
    Run the configure command again:-
    Code:
    PKG_CONFIG_PATH="$HOME/audacity_build/audacity_deps/usr/lib/pkgconfig" \
    ./configure --prefix=/usr/local --with-ffmpeg
    If it fails look for config.log file, put it in an attachment or send to pastebin.

  4. #34
    Join Date
    May 2014
    Beans
    4

    Re: Audacity under Trusty Tahr: Building it with FFmpeg

    Code:
    pc@roland:~/audacity_build/audacity-src-2.0.5$ PKG_CONFIG_PATH="$HOME/audacity_build/audacity_deps/usr/lib/pkgconfig" \
    > ./configure --prefix=/usr/local --with-ffmpeg
    checking for gcc... gcc
    checking whether the C compiler works... yes
    checking for C compiler default output file name... a.out
    checking for suffix of executables... 
    checking whether we are cross compiling... no
    checking for suffix of object files... o
    checking whether we are using the GNU C compiler... yes
    checking whether gcc accepts -g... yes
    checking for gcc option to accept ISO C89... none needed
    checking for C compiler vendor... gnu
    checking for gcc... (cached) gcc
    checking whether we are using the GNU C compiler... (cached) yes
    checking whether gcc accepts -g... (cached) yes
    checking for gcc option to accept ISO C89... (cached) none needed
    checking for g++... g++
    checking whether we are using the GNU C++ compiler... yes
    checking whether g++ accepts -g... yes
    checking how to run the C++ preprocessor... g++ -E
    checking for a BSD-compatible install... /usr/bin/install -c
    checking for pkg-config... yes
    checking for a sed that does not truncate output... /bin/sed
    checking whether the linker accepts the -rdynamic flag... yes
    checking for an ANSI C-conforming const... yes
    checking for grep that handles long lines and -e... /bin/grep
    checking for egrep... /bin/grep -E
    checking for ANSI C header files... yes
    checking for sys/types.h... yes
    checking for sys/stat.h... yes
    checking for stdlib.h... yes
    checking for string.h... yes
    checking for memory.h... yes
    checking for strings.h... yes
    checking for inttypes.h... yes
    checking for stdint.h... yes
    checking for unistd.h... yes
    checking for size_t... yes
    checking for alloca.h... yes
    checking CFLAGS for strict prototypes... -Wstrict-prototypes
    checking wall_flags for maximum warnings... -Wall
    checking whether the C++ compiler accepts the  -Wall flag... yes
    checking whether the C++ preprocessor accepts the  -Wall flag... yes
    checking for simple visibility declarations... yes
    checking for wx-config... /usr/local/bin/wx-config
    
    
      Warning: No config found to match: /usr/local/bin/wx-config --unicode=yes --version
               in /usr/local/lib/wx/config
      If you require this configuration, please install the desired
      library build.  If this is part of an automated configuration
      test and no other errors occur, you may safely ignore it.
      You may use wx-config --list to see all configs available in
      the default prefix.
    
    
    configure: Checking that the chosen version of wxWidgets is 2.8.x
    configure: error: Unable to locate a suitable configuration of wxWidgets v2.8.x or higher.
    The currently available configurations are listed below.  If necessary, either
    install the package for your distribution or download the latest version of
    wxWidgets
    from http://wxwidgets.org.
    
    
        Default config is gtk2-ansi-release-2.8
    
    
      Default config will be used for output
    Config.log: http://pastebin.com/ucAVtgS9
    Last edited by pcrolandhu; May 3rd, 2014 at 05:19 PM.

  5. #35
    Join Date
    Sep 2006
    Location
    California
    Beans
    1,323
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Audacity under Trusty Tahr: Building it with FFmpeg

    Not working. Tried importing an MOV, which never gave any problem in the past. "Does not recognize this type of file."

    Also, did I just mess up my fully up-to-date install of ffmpeg which I use for commandline purposes?
    “Men are born ignorant, not stupid. They are made stupid by education.” -- Bertrand Russell

  6. #36
    Join Date
    Nov 2010
    Location
    Boulder, CO
    Beans
    147
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Audacity under Trusty Tahr: Building it with FFmpeg

    This is a great guide and worked for me! Thanks!

  7. #37
    Join Date
    Dec 2006
    Beans
    7,312

    Re: Audacity under Trusty Tahr: Building it with FFmpeg

    Quote Originally Posted by ricardisimo View Post
    Also, did I just mess up my fully up-to-date install of ffmpeg which I use for commandline purposes?
    No, this installations of FFmpeg does not actually install an executable and removes no system files. Can you post the troublesome file somewhere?
    You think that's air you're breathing now?

  8. #38
    Join Date
    Jan 2014
    Location
    UK
    Beans
    78
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: Audacity under Trusty Tahr: Building it with FFmpeg

    Quote Originally Posted by pcrolandhu View Post
    Config.log:
    Hi
    Looks like you need to ask question at Audacity forum ---> http://forum.audacityteam.org/
    "Compiling Audacity" section.

  9. #39
    Join Date
    Apr 2012
    Beans
    4

    Re: Audacity under Trusty Tahr: Building it with FFmpeg

    Thank you for this helpful guide! It worked on KXStudio 14.04

  10. #40
    Join Date
    Jun 2007
    Beans
    16,077

    Re: Audacity under Trusty Tahr: Building it with FFmpeg

    There is a patch now that allows audacity to work with libav 9/10 & FFmpeg >= 1.2
    It should show up in 14.04 shortly, is in trusty -proposed now but even though patched they didn't enable ffmpeg (makes no sense...
    The package for 14.10 was done properly

    edit: the trusty package & crash has been fixed, should appear in trusty -proposed shortly (patch is altered for libav9
    referring bug - https://bugs.launchpad.net/bugs/1076928
    The changes have been committed to audacity svn so it should work with newer FFmpeg or Libav
    Last edited by mc4man; June 6th, 2014 at 03:48 PM.

Page 4 of 5 FirstFirst ... 2345 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •