Results 1 to 4 of 4

Thread: No 70-persistent-net.rules?

  1. #1
    Join Date
    Aug 2008
    Location
    Sweden
    Beans
    43
    Distro
    Ubuntu 14.04 Trusty Tahr

    Question No 70-persistent-net.rules?

    I am trying to see/control how my 14.04 ubuntu server maps NICs to ethX names. I have two NICs in my host.

    Usually with earlier versions (and also suggested by Ubuntu Server Guide for 14.04!) I configure the file /etc/udev/rules.d/70-persistent-net.rules in which Ubuntu writes mappings for the interfaces after having discovered them for the first time.

    However with 14.04 there is no such file at all! How is this managed in 14.04?

  2. #2
    Join Date
    Aug 2008
    Location
    Sweden
    Beans
    43
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: No 70-persistent-net.rules?

    Hi, I got the interfaces in correct order by refreshing their MAC addresses in the virtual box settings.

    Still I am confused though, as to why no 70-persistent-net.rules is written.
    Last edited by jruden; April 25th, 2014 at 08:14 AM.

  3. #3
    Join Date
    Feb 2011
    Location
    Coquitlam, B.C. Canada
    Beans
    2,280
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: No 70-persistent-net.rules?

    Quote Originally Posted by jruden View Post
    Usually with earlier versions (and also suggested by Ubuntu Server Guide for 14.04!) I configure the file /etc/udev/rules.d/70-persistent-net.rules in which Ubuntu writes mappings for the interfaces after having discovered them for the first time.
    Yes, this change was not captured in the 14.04 Serverguide. I'll put in a bug report.

    See these:
    https://wiki.gentoo.org/wiki/Udev/upgrade
    http://www.freedesktop.org/wiki/Soft...nterfaceNames/

    Edit: Bug report
    Last edited by Doug S; April 25th, 2014 at 03:46 PM. Reason: added link to bug report
    Any follow-up information on your issue would be appreciated. Please have the courtesy to report back.

  4. #4
    Join Date
    Aug 2008
    Location
    Sweden
    Beans
    43
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: No 70-persistent-net.rules?

    Quote Originally Posted by Doug S View Post
    Yes, this change was not captured in the 14.04 Serverguide. I'll put in a bug report.
    Ahh, nice. This explains my confusion, it has really been a change in this area. Great links and bug report. Thanks!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •