Results 1 to 4 of 4

Thread: Engrid on Ubuntu 14.04

  1. #1
    Join Date
    Sep 2013

    Smile Engrid on Ubuntu 14.04

    Hi my dear friends,
    I need your help. I successfully compiled engrid (3D mesh generator for CFD analysis) in Ubuntu 14.04. Everything went smooth till the end. But when I try to open it from command prompt or start menu, nothing happenings.. Whats wrong? Any ideas...

    Hi Friends,
    i solved this by compiling enGrid from the Source.
    Last edited by aerodinesh; May 22nd, 2014 at 05:11 AM. Reason: Found answer to my problem..

  2. #2
    Join Date
    Jun 2014

    Exclamation Re: Engrid on Ubuntu 14.04

    Hi there

    I am also trying to install engrid on ubuntu 14.04 and have the same problems as you. I would be most grateful if you could tell me how to instal it properly, I have tried installing it via the link you shared and also from the bash script at the top of the page on the link you shared.
    any help would be most appreciated!


  3. #3
    Join Date
    Jun 2014

    Re: Engrid on Ubuntu 14.04


    I have followed the instructions in the above post for installing engrid; when the programme is compiling I believe the faults are in these two lines of code:
    can someone please assist me and help me to install Engrid on Ubuntu 14.04, I have changed os from fedora 20 just to achieve this.
    What is the problem with engrid scripts and new distros.
    I did not have this issue with openfoam.

    /usr/bin/ld: cannot find -ltcl8.5
    collect2: error: ld returned 1 exit status
    make[2]: *** [engrid] Error 1
    make[2]: Leaving directory `/home/gowain/software/engrid-release-1.4/src'
    make[1]: *** [release] Error 2
    make[1]: Leaving directory `/home/gowain/software/engrid-release-1.4/src'
    make: *** [sub-engrid-pro-app-make_default-ordered] E

  4. #4
    Join Date
    Sep 2013

    Re: Engrid on Ubuntu 14.04

    Solved by following this..

    qmake-qt4 --version
    qmake-qt5 --version

    sudo apt-get install libqt4-dev
    make clean

    Go into the folder "engrid/src".
    make clean
    rm Makefile* libengrid/Makefile* netgen_svn/Makefile*
    source scripts/setup_pathes.bash
    export PATH=$PWD/scripts:$PATH

    sudo apt-get install tcl8.5 tcl8.5-dev

    Continue following the instructions from the step #7

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts