Results 1 to 9 of 9

Thread: dialog menu displaying odd borders

  1. #1
    Join Date
    Sep 2011
    Location
    Behind you!
    Beans
    1,341
    Distro
    Ubuntu 18.04 Bionic Beaver

    dialog menu displaying odd borders

    When using "dialog" to make menus, they used to show a nice graphic-like border around the menu items but now it shows text instead. Not sure how or when this happened though.

    Example:
    Code:
    dialog --title "Confirmation"  --yesno "Want to quit?" 6 20
    Outputs:
    Code:
                          lqqConfirmationqqqqk
                          x Want to quit?    x
                          tqqqqqqqqqqqqqqqqqqu
                          x < Yes > < No  >  x
                          mqqqqqqqqqqqqqqqqqqj
    This is how it is supposed to look:


    Is there some kind of terminal emulation or variable something that needs to be set to make it work right?

    EDIT #1: I'm using PuTTY 0.63 connecting to Ubuntu Server 12.04.4 (dialog 1.1-20111020) and Ubuntu Server 14.04 (dialog 1.2-20130928)

    EDIT #2: I can use the "--ascii-lines" option to clean it up but I'd prefer the graphic option if possible.

    EDIT #3: Here is the solution to this problem which also fixes the aptitude menu:


    1. When using PuTTY to connect, click on Window -> Translation -> Remote character set. Change to UTF-8
    2. Type the following in your SSH/Telnet session to verify the locale you are using is UTF-8:
      Code:
      locale
    3. Type the following in your SSH/Telnet session:
      Code:
      echo 'export NCURSES_NO_UTF8_ACS=1' >> ~/.bashrc
    4. Logout and log back in for the changes to take affect.



    Thanks,
    LHammonds
    Last edited by LHammonds; November 3rd, 2017 at 02:36 PM.

  2. #2

    Re: dialog menu displaying odd borders

    Windows assumes the user is an idiot.
    Linux demands proof.

  3. #3
    Join Date
    Sep 2011
    Location
    Behind you!
    Beans
    1,341
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: dialog menu displaying odd borders

    Thanks for the link.

    My setting was already UTF8 so I thought I'd try an older version of PuTTY and 0.62 worked. Went back to 0.63 and its broke again. So it looks like I'll stick with 0.62.

    EDIT: I was thinking about just using --ascii-lines as a bandaid fix but the problem cropped up when going into the aptitude menu.

    Thanks,
    LHammonds

  4. #4

    Re: dialog menu displaying odd borders

    Well, you and I both know that just because something is "new" doesn't mean too much these days.
    Windows assumes the user is an idiot.
    Linux demands proof.

  5. #5
    Join Date
    Sep 2011
    Location
    Behind you!
    Beans
    1,341
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: dialog menu displaying odd borders

    Ya, I know...I was just updating my "How To" dox for installing Ubuntu Server 14.04 and thought I'd update my tools to the current versions since the last time I did this doc was 2 years ago.

  6. #6

    Re: dialog menu displaying odd borders

    Your HowTos rock!
    Windows assumes the user is an idiot.
    Linux demands proof.

  7. #7
    Join Date
    Nov 2012
    Location
    Halloween Town
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: dialog menu displaying odd borders

    Reopened per OP request

  8. #8
    Join Date
    Sep 2011
    Location
    Behind you!
    Beans
    1,341
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: dialog menu displaying odd borders

    Solution can be found in 1st post in EDIT #3 section.

    LHammonds

  9. #9
    Join Date
    Feb 2011
    Location
    Coquitlam, B.C. Canada
    Beans
    2,817
    Distro
    Ubuntu Development Release

    Re: dialog menu displaying odd borders

    Oh, Thank you. I have been using "--ascii-lines".
    Any follow-up information on your issue would be appreciated. Please have the courtesy to report back.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •