Page 1 of 6 123 ... LastLast
Results 1 to 10 of 52

Thread: Wireless not working on Acer aspire E1-571 (i3 ver)

  1. #1
    Join Date
    Sep 2010
    Beans
    27

    Wireless not working on Acer aspire E1-571 (i3 ver)

    Hi all,

    Tearing my hair out here, trying to get my Dad's laptop wireless connection working again. The wifi was working when the computer was new (early Feb) and then stopped shortly afterwards. Back then, I booted off an installation cd (we're running 12.04 LTS) and the wifi worked fine. So I booted back into the installed version and all was fine, up until today.

    So today I tried the same thing (booted off the installation cd and tried to connect) but that didn't work this time. So I checked and re-installed the drivers as per this page: http://ubuntuforums.org/showthread.php?t=2214110

    This had no effect either.

    lspci -nn -d 14e4:
    gives:

    <code>
    02:00.0 Ethernet controller [0200]: Broadcom Corporation NetLink BCM57785 Gigabit Ethernet PCIe [14e4:16b5] (rev 10)
    02:00.1 SD Host controller [0805]: Broadcom Corporation BCM57765/57785 SDXC/MMC Card Reader [14e4:16bc] (rev 10)
    02:00.2 System peripheral [0880]: Broadcom Corporation BCM57765/57785 MS Card Reader [14e4:16be] (rev 10)
    02:00.3 System peripheral [0880]: Broadcom Corporation BCM57765/57785 xD-Picture Card Reader [14e4:16bf] (rev 10)
    03:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11bgn Wireless Network Adapter [14e4:4727] (rev 01)
    </code>

    Notes:

    There's no problem with the router, all other devices work fine.
    If the wifi is disabled using the hardware switch, it cannot be turned on again until after a reboot.
    Wireless is shown as enabled in the network-manager icon dropdown, but the actual wifi network is not listed.
    If I try to connect to the wifi network using 'connect to hidden wifi network' the network-manager icon throbs but never connects (the network is remembered from when it was all up and running). It will sometimes ask for a password after a while, but entering the password leads to a 'network disconnected' popup or it asks for the password again. This process usually takes a minute or two.

    It's starting to feel like a dodgy hardware issue, but I'm still a complete Ubuntu noob, so I thought I'd try posting here before I start looking at replacing the wifi card.

    I have to go abroad in a few days, and my Dad really needs his machine up and running before I go - please help!

    avedub.co.uk

  2. #2
    Join Date
    Nov 2004
    Location
    Maine
    Beans
    1,839
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Wireless not working on Acer aspire E1-571 (i3 ver)

    Hi davedub

    You need the b43 driver for you card sta/wl does not work well with it.
    do the following from a terminal after connecting to a ethernet cable.

    Code:
     sudo apt-get purge bcmwl-kernel-source
    sudo apt-get install linux-firmware-nonfree
    Code:
    sudo modprobe -rv b43
    sudo modprobe -v b43
    Then reboot it should work.
    if it does go to a terminal and
    enter
    Code:
    rfkill list
    and post the output here.
    Wireless script
    Dave
    Registered Linux User #462608
    Ubuntu-Mate 16.04

  3. #3
    Join Date
    Sep 2010
    Beans
    27

    Re: Wireless not working on Acer aspire E1-571 (i3 ver)

    Thanks for the very quick reply!

    That didn't work for me, no changes to the situation.
    rfkill list output here:

    Code:
    :~$ rfkill list
    0: acer-wireless: Wireless LAN
        Soft blocked: no
        Hard blocked: no
    1: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no

  4. #4
    Join Date
    Apr 2012
    Beans
    Hidden!

    Re: Wireless not working on Acer aspire E1-571 (i3 ver)

    Hi davedub, i am surprised the sticky didnt work for you.
    lets take a look at some stuff..
    please post the output of..
    Code:
    uname -a
    lspci -nn | egrep '0200|0280'
    lsmod
    thanks
    Last edited by Hadaka; April 20th, 2014 at 10:14 PM.
    Craving anchovy, herring and squid pizza.....with clam sauce

  5. #5
    Join Date
    Nov 2004
    Location
    Maine
    Beans
    1,839
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Wireless not working on Acer aspire E1-571 (i3 ver)

    list the output of
    Code:
    lsmod
    Wireless script
    Dave
    Registered Linux User #462608
    Ubuntu-Mate 16.04

  6. #6
    Join Date
    Sep 2010
    Beans
    27

    Re: Wireless not working on Acer aspire E1-571 (i3 ver)

    All three here:
    Code:
    @Ubuntu-E1-203:~$ uname -a 
     Linux Ubuntu-E1-203 3.2.0-60-generic #91-Ubuntu SMP Wed Feb 19 03:54:44 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux 
     @Ubuntu-E1-203:~$ lspci -nn | egrep '0200|0280' 
     02:00.0 Ethernet controller [0200]: Broadcom Corporation NetLink BCM57785 Gigabit Ethernet PCIe [14e4:16b5] (rev 10) 
     03:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11bgn Wireless Network Adapter [14e4:4727] (rev 01) 
     @Ubuntu-E1-203:~$ lsmod 
     Module                  Size  Used by 
     snd_hda_codec_hdmi     32530  1  
     snd_hda_codec_realtek   224173  1  
     joydev                 17693  0  
     rfcomm                 47604  0  
     bnep                   18281  2  
     bluetooth             180113  10 rfcomm,bnep 
     parport_pc             32866  0  
     ppdev                  17113  0  
     bcma                   26696  0  
     arc4                   12529  2  
     snd_hda_intel          33719  3  
     snd_hda_codec         127706  3 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel 
     snd_hwdep              17764  1 snd_hda_codec 
     snd_pcm                97275  3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec 
     snd_seq_midi           13324  0  
     snd_rawmidi            30748  1 snd_seq_midi 
     snd_seq_midi_event     14899  1 snd_seq_midi 
     snd_seq                61929  2 snd_seq_midi,snd_seq_midi_event 
     snd_timer              29990  2 snd_pcm,snd_seq 
     psmouse                97519  0  
     snd_seq_device         14540  3 snd_seq_midi,snd_rawmidi,snd_seq 
     snd                    79041  16 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device 
     uvcvideo               72627  0  
     videodev               98259  1 uvcvideo 
     v4l2_compat_ioctl32    17128  1 videodev 
     brcmsmac              570930  0  
     mac80211              506862  1 brcmsmac 
     brcmutil               15139  1 brcmsmac 
     serio_raw              13211  0  
     soundcore              15091  1 snd 
     snd_page_alloc         18529  2 snd_hda_intel,snd_pcm 
     i915                  478556  3  
     drm_kms_helper         46978  1 i915 
     cfg80211              205774  2 brcmsmac,mac80211 
     crc8                   12893  1 brcmsmac 
     cordic                 12574  1 brcmsmac 
     drm                   241971  4 i915,drm_kms_helper 
     i2c_algo_bit           13423  1 i915 
     mei                    41616  0  
     acer_wmi               28418  0  
     sparse_keymap          13890  1 acer_wmi 
     video                  19651  1 i915 
     wmi                    19256  1 acer_wmi 
     mac_hid                13253  0  
     lp                     17799  0  
     parport                46562  3 parport_pc,ppdev,lp 
     tg3                   152144  0  
     sdhci_pci              18826  0  
     sdhci                  33205  1 sdhci_pci 0
    Last edited by davedub; April 20th, 2014 at 10:50 PM.

  7. #7
    Join Date
    Nov 2004
    Location
    Maine
    Beans
    1,839
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Wireless not working on Acer aspire E1-571 (i3 ver)

    Go to /etc/modprob.d/blacklist/bcm43-blacklist.conf see if b43 in the list. if it is open gedit as root
    Code:
    gksu gedit
    and place a # sign in front of the line b43 or delete it.
    then run these commands again
    Code:
    sudo modprobe -rv b43
    sudo modprobe -v b43
    wait a minute or so and see if wireless comes up.

    you may have to reboot.
    Wireless script
    Dave
    Registered Linux User #462608
    Ubuntu-Mate 16.04

  8. #8
    Join Date
    Sep 2010
    Beans
    27

    Re: Wireless not working on Acer aspire E1-571 (i3 ver)

    Hi Dave,

    /etc/modprobe.d/blacklist/bcm43-blacklist.conf did not exist. I checked /etc/modprobe.d/blacklist.conf which did have the line, so I tried commenting it out there, but after running the modprobes and restarting nothing changed.

    I have un-commented the line 'blacklist b43' in /etc/modprobe.d/blacklist.conf so it's back as it was and re-run the modprobes.

    Cheers,

    Davedub

  9. #9
    Join Date
    Apr 2012
    Beans
    Hidden!

    Re: Wireless not working on Acer aspire E1-571 (i3 ver)

    Hi, give this a go..
    Code:
    sudo apt-get update
    sudo apt-get upgrade
    once finished..then do..
    Code:
    sudo su
    echo "blacklist b43" >>  /etc/modprobe.d/blacklist.conf
     echo "blacklist ssb" >>  /etc/modprobe.d/blacklist.conf
    exit 0
    then do..
    Code:
    sudo modprobe -rf bcma
    sudo modprobe -v bcma
    sudo modprobe -rf brcmsmac
    sudo modprobe -v brcmsmac
    BOOT
    Craving anchovy, herring and squid pizza.....with clam sauce

  10. #10
    Join Date
    Sep 2010
    Beans
    27

    Re: Wireless not working on Acer aspire E1-571 (i3 ver)

    Hi Hadaka,

    Done - no change...

    Cheers,

    Dave

Page 1 of 6 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •