Results 1 to 9 of 9

Thread: Google Earth

  1. #1
    Join Date
    May 2007
    Location
    Sheffield, UK
    Beans
    1,217

    Re: Share with us your Trusty (14.04) Upgrade & Installation Experiences

    Hey!

    Install of 64 bit edition of Ubuntu 14.04 onto a Samsung NP355VC with 6Gb RAM but a dual core AMD processor. Install went flawlessly and setup similarly so with minimal tweaking regarding function keys. Only real issue thus far has been installation of Google Earth which isn't working. Followed numerous guides but nowt works.

    Otherwise massively impressed with new Ubuntu and am considering it for my own desktop PC which is running Mint at the mo.
    Intel Core i3-8100, 16GB Corsair DDR4 2400 RAM, 240GB Crucial SSD+1TB HDD, Nvidia GTX 1050 Ti

  2. #2
    Join Date
    Apr 2007
    Location
    Brussels, Belgium
    Beans
    271
    Distro
    Kubuntu 20.04 Focal Fossa

    Google Earth

    Quote Originally Posted by BigSilly View Post
    Only real issue thus far has been installation of Google Earth which isn't working.
    Otherwise massively impressed with new Ubuntu and am considering it for my own desktop PC which is running Mint at the mo.
    I followed http://www.noobslab.com/2014/03/inst...untulinux.html and that seems to work. (64-bit) but I'm no expert with Google Earth, I just play with it.
    But indeed, it seems a very good release.

  3. #3
    Join Date
    May 2007
    Location
    Sheffield, UK
    Beans
    1,217

    Re: Share with us your Trusty (14.04) Upgrade & Installation Experiences

    Quote Originally Posted by jdeca57 View Post
    I followed http://www.noobslab.com/2014/03/inst...untulinux.html and that seems to work. (64-bit) but I'm no expert with Google Earth, I just play with it.
    But indeed, it seems a very good release.
    Thanks for that but I've already tried it. Doesn't work for me sadly on this laptop. Splash screen appears, then I get a crash and a signal 11 error if running from the terminal.
    Intel Core i3-8100, 16GB Corsair DDR4 2400 RAM, 240GB Crucial SSD+1TB HDD, Nvidia GTX 1050 Ti

  4. #4
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: Google Earth

    Moved these posts (first one copied so it is still in the original thread : http://ubuntuforums.org/showthread.php?t=2217531) in a separate support thread. The original one is for feedback only
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests / username changes by PM, thanks. |
    [SIGPIC][/SIGPIC]

  5. #5
    Join Date
    Apr 2012
    Beans
    181
    Distro
    Ubuntu 19.10 Eoan Ermine

    Re: Google Earth

    Google Earth was flaky in 13.10 and is still flaky in 14.04. Started OK twice. Crashed lots of times at the splash screen. Was really hoping that this would be reliable in 14.04.

  6. #6
    Join Date
    Aug 2013
    Beans
    4,369

    Re: Google Earth

    I installed the 64 bit by rebuilding the .deb
    See post #5 of http://ubuntuforums.org/showthread.php?t=2196304
    See post #27 and #28 for getting the Panoramio pictures back.

    Tested in 13.10 and 14.04.

  7. #7
    Join Date
    Apr 2007
    Location
    GMT+1
    Beans
    87
    Distro
    Ubuntu 14.04 Trusty Tahr

    Question Re: Google Earth

    My install of G-Earth to run on Trusty 64 bits was flawless.
    I used: http://www.noobslab.com/2014/03/inst...ative-method64

    I just had to relaunch it a second time before all of G-Earth's features kicked in. (wonder why this happens sometimes, especially if I don't restart my session, but just relaunch the app.)

    I am wondering if others see the same thing as I...
    Everything seems to work perfectly well except I see none of the pictures usually available in Google Earth. Concretely, I can open the corresponding windows, but the pictures are actually never displayed.
    Any clue anyone ? Tx.
    -ced
    Last edited by Cbhihe; June 23rd, 2014 at 04:50 PM. Reason: add pertinent link
    --
    Lx Ubuntu 14.04 (LTS) Desktop Ed. on HP 8510w
    Intel T9300 Duo Core 2.5GHz - 4GB RAM - 64 bits

  8. #8
    Join Date
    Jul 2007
    Location
    Magic City of the Plains
    Beans
    Hidden!
    Distro
    Xubuntu

  9. #9
    Join Date
    Apr 2007
    Location
    GMT+1
    Beans
    87
    Distro
    Ubuntu 14.04 Trusty Tahr

    Question Re: Google-Earth version 7.1.2.2041

    Hi oldos2er and thank you for the pointer.
    I had not realized that the "Panoramio images" mentioned by monkeybrain20122 were just what I called "pictures" in the post following his. So much for being awake.

    I have a little problem though as, for instance, I have no 'ia32-libs' dependency shown on the Depends line of my '/var/lib/dpkg/status' file. So I am not sure of the extent to which your fix applies in my case.

    I downloaded the version of the tar.xz you refer to in your post, 'ge7.1.1.1580-0.x86_64-new-qt-libs-debian7-ubuntu12.tar.xz' and untarred it in /opt/google/earth/free after installing libfreeimage3 per monkeybrain20122's post http://ubuntuforums.org/showthread.p...0#post12892580.
    The stdout for the untarring was:
    Code:
    googleearth
    libQtCore.so.4
    libQtGui.so.4
    libQtNetwork.so.4
    libQtWebKit.so.4
    patchlib
    plugins/
    plugins/imageformats/
    plugins/imageformats/libqjpeg.so
    plugins/imageformats/libqgif.so
    Trying to launch G-Earth produced:
    Code:
    >  google-earth
    ERROR: ld.so: object 'libfreeimage.so.3' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
    ./googleearth-bin: symbol lookup error: ./libge_chrome_net.so: undefined symbol: _Z34QBasicAtomicInt_fetchAndAddOrderedPVii
    So obviously I did something incomplete and/or wrong....
    --
    Lx Ubuntu 14.04 (LTS) Desktop Ed. on HP 8510w
    Intel T9300 Duo Core 2.5GHz - 4GB RAM - 64 bits

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •