Page 4 of 7 FirstFirst ... 23456 ... LastLast
Results 31 to 40 of 61

Thread: Copy.com indicator problem with Ubuntu 14.04

  1. #31
    Join Date
    May 2014
    Beans
    1

    Re: Copy.com indicator problem with Ubuntu 14.04

    I have the same problem. I noticed that runnung the CopyAgent as root (kdesudo), solves it (even it is probably not recommended to run it as root).

  2. #32
    Join Date
    Apr 2006
    Beans
    Hidden!

    Re: Copy.com indicator problem with Ubuntu 14.04

    this worked for me on a 64 bit install of 14.04 upgrade from 13.10

    it also worked for me on my laptop which was a clean install of 14.04 64 bit

    This the first time I have had the menu working in over a year


    step1:


    so the proper way to get your (a) copy icon back is to first install this ppa
    sudo apt-add-repository ppa:gurqn/systray-trusty
    sudo apt-get update
    sudo apt-get upgrade




    step2:

    kill the copy agent ( i use system monitor to do so)

    step3: install sqlite to modify copy agent datatbase (if the update doesn't work there is a line to return it to its previous settings later on)

    sudo apt-get install sqlite3


    cd $HOME/.copy


    echo 'UPDATE config2 SET value=0 WHERE option="csmBlackWhiteIconsV2" ;' | sqlite3 config.db

    (more details here:

    http://askubuntu.com/questions/45767...con-of-copy-co...)

    after restarting copyagent and or logging out and logging in, it is fixed)

    (to undo any change if it fails for you

    echo 'UPDATE config2 SET value=1 WHERE option="csmBlackWhiteIconsV2" ;' | sqlite3 config.db)

  3. #33
    Join Date
    Jun 2007
    Beans
    16,988

    Re: Copy.com indicator problem with Ubuntu 14.04

    I had moved to copy as a replacement for ubuntuone in 14.04 & saw no issues getting a working menu (ubuntu session
    Likely that is because my unity install had the systray enabled prior to copy being installed so no other commands, edits were needed
    (I maintain a 14.04 build here that's slightly advanced from others, this has 14.10 updates & a fix for unity launcher pips
    https://launchpad.net/~mc3man/+archive/systray-white

    Just to note -
    copy is a qt4 app, usually qt4 apps get indicator support thru sni-qt which may work ok (smplayer), or not very well (vlc). In the case of copy it doesn't seem to work with sni-qt or if it does, it does so poorly. The systray icon for copy does work well.
    (smplayer & vlc both support the systray though it can only be had if the sni-qt package is removed.

    The only little issue in unity/ambiance is the menu is wrong color, (white), & wrong highlighted background (blue
    The menu can be adjusted thru qt4-qtconfig though that app can be extremely frustrating to use & any changes should be checked against any other qt4 app for suitability.
    (- simply switching gui style from Desktop settings to GTK+ will give proper highlighted background color, any other changes need to be done via "Tune Palette" . The cleanlooks style isn't that bad either.

    Have come close here to getting a better looking menu but as mentioned qt4-qtconfig is a pita to use. If inclined I'd back up ~/.copy first & keep in mind every time you open qt4-qtconfig it may return some values to default

    Would love to find where qtconfig settings changes are saved but haven't as of yet..

  4. #34
    Join Date
    Jul 2013
    Beans
    2

    Re: Copy.com indicator problem with Ubuntu 14.04

    I've debugged this issue a little, and it's not actually a copy bug.
    But a libdbusmenu issue, that might happen also with other indicators (see bug #1086563)

    If you're brave enough you might want to try the fix by compiling by yourself my libdbusmenu (using the --with-gtk=2 configure flag, if you need it only for copy)

    Quick instructions, that will fix your CopyAgent:
    Code:
    bzr branch lp:~3v1n0/libdbusmenu/really-recreate-menu libdbusmenu
    cd libdbusmenu
    sudo apt-get build-dep libdbusmenu-gtk4
    ./autogen.sh --with-gtk=2
    make install DESTDIR=$PWD/install
    sudo cp install/usr/local/lib/libdbusmenu-gtk.so.* $SAME_DIRECTORY_WHERE_YOUR_CopyAgent_IS

  5. #35
    Join Date
    Jun 2007
    Beans
    16,988

    Re: Copy.com indicator problem with Ubuntu 14.04

    Quote Originally Posted by 3v1n0 View Post
    I've debugged this issue a little, and it's not actually a copy bug.
    But a libdbusmenu issue, that might happen also with other indicators (see bug #1086563)

    If you're brave enough you might want to try the fix by compiling by yourself my libdbusmenu (using the --with-gtk=2 configure flag, if you need it only for copy)

    Quick instructions, that will fix your CopyAgent:
    Code:
    bzr branch lp:~3v1n0/libdbusmenu/really-recreate-menu libdbusmenu
    cd libdbusmenu
    sudo apt-get build-dep libdbusmenu-gtk4
    ./autogen.sh --with-gtk=2
    make install DESTDIR=$PWD/install
    sudo cp install/usr/local/lib/libdbusmenu-gtk.so.* $SAME_DIRECTORY_WHERE_YOUR_CopyAgent_IS
    Thanks Marco - that works quite well, proper colors & all
    (gather it doesn't use sni-qt as I don't have it installed for better vlc icon

    (- for user that just have extracted copy in Home folder no need to use sudo to cp

  6. #36
    Join Date
    Jun 2007
    Beans
    16,988

    Re: Copy.com indicator problem with Ubuntu 14.04

    Quote Originally Posted by AleveSicofante View Post
    Code:
    prompt:~$ cd libdbusmenu
    pablo@T400:~/libdbusmenu$ sudo apt-get build-dep libdbusmenu-gtk4
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
     E: You must put some 'source' URIs in your sources.list
    prompt:~/libdbusmenu$
    I usually don't have any source repositories. Which should I put in my sources.list file in order to install build-dep or libdbusmenu-gtk4?
    Open up Software & Updates & check the "Source code" box (it may then show a line or checkmark, doesn't matter

  7. #37
    Join Date
    Mar 2014
    Beans
    10

    Re: Copy.com indicator problem with Ubuntu 14.04

    This is great, thank you! And now a stupid question.

    How exactly does the last command have to look like: "sudo cp install/usr/local/lib/libdbusmenu-gtk.so.* $SAME_DIRECTORY_WHERE_YOUR_CopyAgent_IS"

    Like this for example?: "sudo cp install/usr/local/lib/libdbusmenu-gtk.so.* /home/blablub/CopyClient/x86_64"

    Thanks a lot!

  8. #38
    Join Date
    Jun 2011
    Beans
    60
    Distro
    Ubuntu

    Re: Copy.com indicator problem with Ubuntu 14.04

    My CopyAgent executable is in /opt/copy (I put it there). That was my "$SAME_DIRECTORY_WHERE_YOUR_CopyAgent_IS".

    If you're not sure where your CopyAgent executable is, try finding it:

    Code:
    sudo find / -name CopyAgent


  9. #39
    Join Date
    Mar 2014
    Beans
    10

    Re: Copy.com indicator problem with Ubuntu 14.04

    Works like a charm! Thank you!

  10. #40
    Join Date
    Sep 2008
    Location
    luxembourg
    Beans
    47
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Copy.com indicator problem with Ubuntu 14.04

    @3v1n0
    Worked for me on 64bit - thanks!
    Ubuntu 11.04(amd64)
    |Abit FP-IN9 SLI | Intel(R) Core(TM)2 Duo CPU E8200@2.66GHz | GeForce 9800 GT |

Page 4 of 7 FirstFirst ... 23456 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •