Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: problem: configure could not find the zlib library

  1. #11
    Join Date
    Apr 2014
    Beans
    23
    Distro
    Kubuntu

    Re: problem: configure could not find the zlib library

    Alright! I've determined the problem. It wasn't the version of zlib, though it was worth looking into. Instead, it was that pkg-config from lscsoft was overwriting pkg-config from the apt repos. I reinstalled pkg-config and added the following to my .bashrc:

    Code:
    export PKG_CONFIG=/usr/bin/pkg-config
    After logging off and then back on, I was able to run the configure script and install without any errors.

    Thank you so much for your time, steeldriver. I'll mark this as solved.

  2. #12
    Join Date
    Apr 2014
    Beans
    23
    Distro
    Kubuntu

    Re: problem: configure could not find the zlib library

    It turned out that the shell script installed versions of the software that were too old for the lalsuite code to utilize. I removed them and updated my pkg-config environment variable accordingly. Once done, the installation went smoothly. Wish I had realized that earlier! Thanks for your help, steeldriver. If nothing else, this might help promote an update of the online documentation for lscsoft/lalsuite.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •