Results 1 to 2 of 2

Thread: Recover glibc/libc from failed update

  1. #1
    Join Date
    Apr 2014

    Recover glibc/libc from failed update


    I needed to upgrade libc for an app I wanted to install, however this machine has no net connection, so I downloaded elsewhere and transferred there through an external hdd. (it's no problem doing that quickly if it's needed for the fix)

    I got the source though (should probably have tried a .deb package?) and followed the instructions to config, build and install glibc. At the end of sudo make install, it complained of a segfault and now X is not starting and a few core utils too (like gawk and find!) but many stuff are still working and even the external hdd is automatically detected and i can mount and copy stuff over.

    Researched the problem, it seems glibc requires all optional libs to be the same build, and since I only tried to upgrade the core, existing ones are not compatible (dmesg seems to complain mostly about libm)

    I can also access the install CD (or boot into repair mode if necessary) and tried to copy and dpkg glibc over, which worked flawlessly, only it was not glibc but glib! And I dunno where glibc is on the CD... but I'd hope I could upgrade directly to the new version by downloading that instead and dpkg it in place? Though getting it back to working condition would be nice if that is not possible. but how?


  2. #2
    Join Date
    Apr 2014

    Re: Recover glibc/libc from failed update

    Fixed by reinstalling... =/

    Now how would I upgrade my libc6 with no net access? (I think I better create a new thread for that)

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts