Results 1 to 2 of 2

Thread: Broken Package Manager (apt-get)

  1. #1
    Join Date
    Oct 2013

    Broken Package Manager (apt-get)

    After an upgrade from 13.10 to 14.04 (beta 2), I seem to have a corrupt package manager. When I try to fix, install, or remove a package, apt-get fails with:

    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution)

    Not a problem, so far. However, the suggestion fails with:

    $ sudo apt-get -f install
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Correcting dependencies... Done
    The following extra packages will be installed:
    The following NEW packages will be installed:
    0 upgraded, 1 newly installed, 0 to remove and 52 not upgraded.
    19 not fully installed or removed.
    Need to get 0 B/30.6 kB of archives.
    After this operation, 100 kB of additional disk space will be used.
    Do you want to continue? [Y/n]
    dpkg: error processing archive /var/cache/apt/archives/libpostproc52_6%3a0.git20120821-4_amd64.deb (--unpack):
    libpostproc52:amd64 6:0.git20120821-4 (Multi-Arch: no) is not co-installable with libpostproc52 which has multiple installed instances
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    Is there a recommended way to directly remove libpostproc52 or related files? I have already tried every apt-get command.


    SOLVED:"dpkg -P fubar" deleted all of the offending packages
    Last edited by pnashdc; April 7th, 2014 at 06:49 PM. Reason: Solved

  2. #2
    ibjsb4 is offline Ubuntu addict and loving it
    Join Date
    Sep 2012

    Re: Broken Package Manager (apt-get)


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts