prefixed "Xubuntu", since that is what I am running, but I think the problem is not specific. The library libnss3-1d depends on a newer version of libnss3, but the latter is up to date according to aptitude. How do I resolve this paradox?
My system is Xubuntu 13.10-saucy AMD64. Following the uname -a output:
3.11.0-19-generic #33-Ubuntu SMP Tue Mar 11 18:48:34 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
I cannot say how and when this happened, just the other day on my production machine and I am/was very busy and could not focus on it. I did nothing special but safe-upgrade and install from repos.
complaines about broken dependencies and
sudo aptitude safe-upgrade
produces the following broken package:
sudo aptitude safe-upgrade --full-resolver
libnss3-1d : Depends: libnss3 (= 2:3.15.4-0ubuntu0.13.10.2) but 2:3.15.4-0ubuntu0.13.10.1 is installed.
aptitude show libnss3
What am I missing and what can I do about this?
rforge@xbk:~$ aptitude show libnss3
Automatically installed: no
Maintainer: Ubuntu Mozilla Team <firstname.lastname@example.org>
Uncompressed Size: 3,702 k
Depends: libc6 (>= 2.14), libnspr4 (>= 2:4.9-2~) | libnspr4-0d (>= 4.8.6), libsqlite3-0 (>= 3.5.9), zlib1g (>= 1:1.1.4)
Conflicts: libnss3-1d (< 2:3.13.4-2), libnss3-1d (< 2:3.13.4-2)
Breaks: libnss3 (!= 2:3.15.4-0ubuntu0.13.10.1)
Replaces: libnss3 (< 2:3.15.4-0ubuntu0.13.10.1)
Any help appreciated,